Audio qjackctl does not start

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

deepakdeshp wrote:
Thu Nov 28, 2019 1:35 pm
MrEen wrote:
Thu Nov 28, 2019 1:28 pm
Better yet, go to the Parameters tab and change Interface there to hw:Generic
It wass there in advanced tab. There is no such option in parameters tab
Mine looks like this:
Image

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

trytip wrote:
Thu Nov 28, 2019 1:34 pm
we need to see your drop down selections for output/input in qjackctl.
i use this, but really annoyed that i can't see the whole output window since the theme cuts it off
Image
Output device in qjackctl was default , I changed it to hw:1. Somehow I cant capture the options screen, as I try to capture it , the dropdown disappears.

The options are
hw:hdmi
hw:generic
hw:generic,0
default
These are common for input and output device both.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Yeah, as recently as yesterday, you were still outputting to HDMI as shown by this:

Code: Select all

09:27:29.856 JACK is starting...
09:27:29.857 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic
My settings on the Advanced tab are both default, but the Interface on the Parameters tab is the important one, I believe.

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

search for screenshot in menu, open it and give it a 6 seconds delay or more, whatever you feel comfortable with, include the mouse pointer hit Take Snapshot, there will be a delay which will not show but open your dropdown menu

@Mr.Een the Parameters mean nothing this is only latency related. but if you select realtime you need to be sure you have real time enabled.
ulimit -r -l
sudo dpkg-reconfigure jackd2
Image

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

trytip wrote:
Thu Nov 28, 2019 2:01 pm
search for screenshot in menu, open it and give it a 6 seconds delay or more, whatever you feel comfortable with, include the mouse pointer hit Take Snapshot, there will be a delay which will not show but open your dropdown menu

@Mr.Een the Parameters mean nothing this is only latency related. but if you select realtime you need to be sure you have real time enabled.
ulimit -r -l
sudo dpkg-reconfigure jackd2
Sorry I didn't spot this sooner. The Parameters TAB has the Interface setting that is incorrect in this case I believe. See my screenshot above. I believe that's where the hw:0 is coming from in the .jackdrc output.

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Thu Nov 28, 2019 1:38 pm
deepakdeshp wrote:
Thu Nov 28, 2019 1:35 pm
MrEen wrote:
Thu Nov 28, 2019 1:28 pm
Better yet, go to the Parameters tab and change Interface there to hw:Generic
It wass there in advanced tab. There is no such option in parameters tab
Mine looks like this:
Image
The interface option is greyed out in the options tab . I cant change it. Its set to generic.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Thu Nov 28, 2019 1:58 pm
Yeah, as recently as yesterday, you were still outputting to HDMI as shown by this:

Code: Select all

09:27:29.856 JACK is starting...
09:27:29.857 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic
My settings on the Advanced tab are both default, but the Interface on the Parameters tab is the important one, I believe.
I reinstalled qjackctl . The parameter tab looks like
config.png
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

deepakdeshp wrote:
Sun Dec 01, 2019 2:21 pm
The interface option is greyed out in the options tab . I cant change it. Its set to generic.
Well, that's odd! Sounds like permissions again. I would try deleting .jackdrc which qjackctl clobbers anyway.

Again, what happens if instead of using qjackctl you run jackd -dalsa -dhw:Generic -r44100 -p1024 -n2 then start sonic-pi?

Just saw your new post. Try this instead:

Code: Select all

pasuspender -- jackd -dalsa -dhw:Generic -r44100 -p1024 -n2
Then launch sonic-pi

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

trytip wrote:
Thu Nov 28, 2019 2:01 pm
search for screenshot in menu, open it and give it a 6 seconds delay or more, whatever you feel comfortable with, include the mouse pointer hit Take Snapshot, there will be a delay which will not show but open your dropdown menu

@Mr.Een the Parameters mean nothing this is only latency related. but if you select realtime you need to be sure you have real time enabled.
ulimit -r -l
sudo dpkg-reconfigure jackd2
I manually noted down the drop down values in one of my earlier posts,
I enabled realtime with the above commands, the I started Sonic-pi. But it coudnt be started.
The SP error messages are

Code: Select all

Sonic Pi Boot Error Report
==================


System Information
----------------

* Sonic Pi version: 2.10.0
* OS: Linux Mint 19.2


GUI Log
-------

**/home/uma/.sonic-pi/log/gui.log**
```
[GUI] - using default editor colours
[GUI] - shutting down any old audio servers...
[GUI] - starting UDP OSC Server on port 4558...
[GUI] - UDP OSC Server ready and listening
[GUI] - booting live coding server
[GUI] - waiting for server to boot...
....................................[GUI] - server failed to start with this error message: 
      > Server Exception:
 Boot - Unable to connect to SuperCollider
........................
[GUI] - Critical error! Could not boot server.

```


Server Errors
-------------

**/home/uma/.sonic-pi/log/server-errors.log**
```
Failed to start server: Boot - Unable to connect to SuperCollider
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/scsynthexternal.rb:292:in `boot_and_wait'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/scsynthexternal.rb:392:in `boot_server_linux'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/scsynthexternal.rb:181:in `boot'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/scsynthexternal.rb:29:in `initialize'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/server.rb:73:in `new'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/server.rb:73:in `initialize'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/studio.rb:102:in `new'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/studio.rb:102:in `init_studio'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/studio.rb:43:in `initialize'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/lang/sound.rb:123:in `new'
/usr/lib/sonic-pi/server/sonicpi/lib/sonicpi/lang/sound.rb:123:in `block (2 levels) in included'
/usr/lib/sonic-pi/server/bin/sonic-pi-server.rb:99:in `new'
/usr/lib/sonic-pi/server/bin/sonic-pi-server.rb:99:in `<main>'

```


Server Output
-------------

**/home/uma/.sonic-pi/log/server-output.log**
```
Sonic Pi server booting...
Using protocol: udp
Server is exiting.
Shutting down GUI...
Goodbye :-)

```


Scsynth Output
--------------

**/home/uma/.sonic-pi/log/scsynth.log**
```
# Starting SuperCollider 2019-12-01 23:59:31
Found 109 LADSPA plugins
JackDriver: client name is 'SuperCollider'
SC_AudioDriver: sample rate = 44100.000000, driver's block size = 1024
SuperCollider 3 server ready.

```
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Sun Dec 01, 2019 2:28 pm
deepakdeshp wrote:
Sun Dec 01, 2019 2:21 pm
The interface option is greyed out in the options tab . I cant change it. Its set to generic.
Well, that's odd! Sounds like permissions again. I would try deleting .jackdrc which qjackctl clobbers anyway.

Again, what happens if instead of using qjackctl you run jackd -dalsa -dhw:Generic -r44100 -p1024 -n2 then start sonic-pi?

Just saw your new post. Try this instead:

Code: Select all

pasuspender -- jackd -dalsa -dhw:Generic -r44100 -p1024 -n2
Then launch sonic-pi
With this command jackd gui doesnt launch. Starting SP after it didnt help. But it does launch and start qjackd with following command.

Code: Select all

pasuspender -- qjackctl [code]
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

If any more thing to be tried, I will do that approx 10 hours from Now. Thank you.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Yes, it's okay to open qjackctl, but don't use it's Start button, instead launching jackd from the terminal. Assuming your .jackdrc still starts with /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2, that's what I'm trying to help you get around. the hw:0 there is wrong.

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

deepakdeshp wrote:
Sun Dec 01, 2019 2:40 pm
If any more thing to be tried, I will do that approx 10 hours from Now. Thank you.
No problem. Have a good day/night. :D

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

if jackaudio server is not running and able to receive sounds that you hear through your speakers, sonic-pi will not open it will crash
can you successfully run a video/audio application with jack server?
you will see supercolider in jack connections:
Image

we need to see your dropdown from advanced > output devices interface has nothing to do with audio, i never once touched options here unless i wanted to test how my cpu would do with shortening latency

@Mr.Een i always start jack by pushing on the start button. unless i load it from boot
jackdbus <<< should be the only thing jack related running
Image

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Sun Dec 01, 2019 2:28 pm
deepakdeshp wrote:
Sun Dec 01, 2019 2:21 pm
The interface option is greyed out in the options tab . I cant change it. Its set to generic.
Well, that's odd! Sounds like permissions again. I would try deleting .jackdrc which qjackctl clobbers anyway.

I deleted .jackdrc but the interface option stays greyed out.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

trytip wrote:
Thu Nov 28, 2019 8:30 am
deepakdeshp wrote:
Thu Nov 28, 2019 12:09 am
Connect screen looks like this after I start SP
Image
your readable clients don't look right, your jackaudio is missing components. test it with smplayer >>> in smplayer options change audio output to jack, start
Inj VLC tools-- preferences--audio--output module is set to automatic. jack isnt one of the drop down choices. Can you try capturing and pasting a screen here with drop down choices? The drop down disappears as soon as I click outside the figure.

The
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

well if the snapshot above is any indication of how the present looks, you do not have pulseaudio module for jackaudio sinkapt install pulseaudio-module-jack and how come i can take a screenshot just fine but your drop down disappears and doesn't want to be captured? :? of course the drop down is gone when you click somewhere else. you need to take the snapshot before dropping down the menu
did you say you tried to purge pulseaudio or was that another thread, i can't remember anymore. i have no clue how Mr.Een does it
and why is Inj VLC tools-- preferences--audio--output module is set to automatic and not jack for the test? c'mon guy work with me here :lol:

your jackaudio should look like this when nothing is connected to it. your is missing things, why?
Image
Image

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

trytip wrote:
Mon Dec 02, 2019 9:59 am
well if the snapshot above is any indication of how the present looks, you do not have pulseaudio module for jackaudio sinkapt install pulseaudio-module-jack and how come i can take a screenshot just fine but your drop down disappears and doesn't want to be captured? :? of course the drop down is gone when you click somewhere else. you need to take the snapshot before dropping down the menu
did you say you tried to purge pulseaudio or was that another thread, i can't remember anymore. i have no clue how Mr.Een does it
and why is In VLC tools-- preferences--audio--output module is set to automatic and not jack for the test? c'mon guy work with me here :lol:

your jackaudio should look like this when nothing is connected to it. your is missing things, why?
When qjackctl is active I cant run any media file, there is no sound. Is that normal? I am using Rhythmbox as the media player for this test.

As mentioned an my last post VLC tools-- preferences--audio--output module is set to automatic and not jack, because there is no option to choose jack for output module in VLC player.
Now patchbay looks like this when qjackctl is started.
patchbay.png
Pulseaudio-module-jack is already installed.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9630
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

I have an idea.

With qjackctl open and having clicked on Start, go to the terminal and enter pactl list modules short | grep jack. Here's mine:

Code: Select all

scott@scott-HP ~ $ pactl list modules short | grep jack
10	module-jackdbus-detect	channels=2	
27	module-jack-sink	connect=yes channels=2	
28	module-jack-source	connect=yes channels=2	
scott@scott-HP ~ $
If those last 2 lines aren't there, run these:

Code: Select all

pactl load-module module-jack-sink
pactl load-module module-jack-source
Now test anything that uses jack.

Those lines won't be there if jack isn't running, so make sure to click on Start, and see that it completed starting before running the list modules command.

deepakdeshp
Level 17
Level 17
Posts: 7524
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Mon Dec 02, 2019 5:53 pm
I have an idea.

With qjackctl open and having clicked on Start, go to the terminal and enter pactl list modules short | grep jack. Here's mine:

Code: Select all

scott@scott-HP ~ $ pactl list modules short | grep jack
10	module-jackdbus-detect	channels=2	
27	module-jack-sink	connect=yes channels=2	
28	module-jack-source	connect=yes channels=2	
scott@scott-HP ~ $
If those last 2 lines aren't there, run these:

Code: Select all

pactl load-module module-jack-sink
pactl load-module module-jack-source
Now test anything that uses jack.

Those lines won't be there if jack isn't running, so make sure to click on Start, and see that it completed starting before running the list modules command.
The last 2 lines were not present when I started qjackctl. It goes to started state as soon as I start it with command mode. No need to hit start button of qjackctl.

Code: Select all

pactl list modules short | grep jack
9	module-jackdbus-detect	channels=2	
(base) uma@mint-18-uma ~ $ pactl load-module module-jack-sink
28
(base) uma@mint-18-uma ~ $ pactl load-module module-jack-source
29
(base) uma@mint-18-uma ~ $ pactl list modules short | grep jack
9	module-jackdbus-detect	channels=2	
28	module-jack-sink		
29	module-jack-source	
But SP doesnt start . After starting SP in a terminal I always get

Code: Select all

could not open file /proc/asound/card0/pcm0p/info
libpng warning: iCCP: known incorrect sRGB profile

Bur there is this info file

Code: Select all

ls -l /proc/asound/card0/pcm3p/
total 0
-r--r--r-- 1 root root 0 Dec  3 09:15 info
dr-xr-xr-x 2 root root 0 Dec  3 08:55 sub0

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Software & Applications”