(SOLVED) Mint 19.3 and Virtualbox 6.1

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Fontenele
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 7:18 am

(SOLVED) Mint 19.3 and Virtualbox 6.1

Post by Fontenele »

Good morning,

I'm trying to install Virtuabox 6.1, downloaded the .deb file from the developer site and got the following error:

Code: Select all

sudo dpkg -i virtualbox-6.1_6.1.0-135406_Ubuntu_bionic_amd64.deb 
Selecting previously unselected package virtualbox-6.1.
(Reading database ... 296699 files and directories currently installed.)
Preparing to unpack virtualbox-6.1_6.1.0-135406_Ubuntu_bionic_amd64.deb ...
Unpacking virtualbox-6.1 (6.1.0-135406~Ubuntu~bionic) ...
dpkg: dependency problems prevent configuration of virtualbox-6.1:
 virtualbox-6.1 depends on libqt5opengl5 (>= 5.0.2); however:
  Package libqt5opengl5 is not installed.

dpkg: error processing package virtualbox-6.1 (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (237-3ubuntu10.33) ...
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint8) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.9-2) ...
Errors were encountered while processing:
 virtualbox-6.1
So, checking got this result:

Code: Select all

sudo apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 virtualbox-6.1 : Depends: libqt5opengl5 (>= 5.0.2) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
The result given from the so it was remove Virtualbox 6.1.

Using Kernel "Linux oxygen 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux"

Thanks in advance for any indication to solve the problem.

Fontenele
Last edited by Fontenele on Mon Dec 23, 2019 9:29 am, edited 1 time in total.

User avatar
AndyMH
Level 9
Level 9
Posts: 2975
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Mint 19.3 and Virtualbox 6.1

Post by AndyMH »

On my system (LM19.0 cinnamon), checking with synaptic, libqt5opengl5 is V5.9.5 and installed.
Screenshot from 2019-12-23 12-49-43.png
So I would do what vb is recommending:

Code: Select all

apt --fix-broken install
And if that doesn't fix it, install it in the synaptic package manager.

I also would not install from deb - you don't get any updates. Instead install as recommended by gm10 in his post here (four commands in a terminal, do each one, one-by-one):
viewtopic.php?f=47&t=307595&p=1731164#p1731164
Note - for a fully functional VB you also need to install the extension pack from oracle - it's on their download page (download, double click on it to install, the file manager will complain it doesn't know what to do with it, type in virtualbox) and then install guest-additions in the OS you want to run as a VM*. No need to download anything additional for guest-additions, it's included in the VB install.

* If windows, with windows running in VB, goto the VB devices menu and select insert guest-additions, win should automatically see it and offer to install. If not, in win in 'my computer' navigate to the CD drive and it will be there.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

User avatar
Fontenele
Level 1
Level 1
Posts: 8
Joined: Mon Mar 19, 2018 7:18 am

Re: Mint 19.3 and Virtualbox 6.1

Post by Fontenele »

AndyMH,

Killer tip and as you said, instead of using the .deb, i used a repository and Virtualbox it is working perfectly. :lol:

Thanks a lot!

Fontenele

Post Reply

Return to “Software & Applications”