Page 1 of 1

Double Trouble [SOLVED]

Posted: Tue Dec 24, 2019 9:17 am
by Amii_Leigh
I had been looking for a desktop clock that looked nice and was resizeable. I 'had' been using Cairo-Clock, but then I saw the XClock in viewtopic.php?f=206&t=307724&p=1731814& ... k#p1731814
so I thought I knew what I was doing and initially copied

Code: Select all

xclock & disown
and pasted that into the command line for Preferences/Startup applications and expected that to be the end of it. *Heavy Sigh*. I even tried it in the terminal before I pasted it into a startup launcher. it worked fine there. But on restarting Xorg, Xclock didn't start. So I deleted the contents of ~/.config/autostart/xclock that I'd made, then pasted the contents

Code: Select all

[Desktop Entry]
Version=1.0
Name=Xclock
Comment=Clock application
Icon=deja-dup
Exec=/usr/bin/xclock -update 1 -geometry 180x180-20+20
StartupNotify=false
NoDisplay=false
Type=Application
Categories=Utility;
into the then empty document and saved it, then restarted Xorg. It was upon restarting that I noticed I now had two instances of Saytime. (I could hear an echo.) Checking the System Monitor, I then discovered I had six copies of Redshift running as well as two copies of Saytime.
XClock is working fine, it popped up just the way it was supposed to.

It was after this, I deleted entirely the xclock.desktop inside of ~/.config/autostart and made an entirely new file called "Xclock.desktop. Upon restarting Xorg, I still had an echo, plus I had six copies of Redshift running.

Just in case you're wondering, my system is:

Code: Select all

amii@Basically ~ $ inxi -Fxz
System:    Host: Basically Kernel: 4.15.0-72-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard product: HP Compaq 8200 Elite CMT PC
           Mobo: Hewlett-Packard model: 1494
           Bios: Hewlett-Packard v: J01 v02.15 date: 11/10/2011
CPU:       Quad core Intel Core i5-2400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 24743
           clock speeds: max: 3400 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz
           4: 1596 MHz
Graphics:  Card: NVIDIA GP107 [GeForce GTX 1050] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1050/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GP107GL High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-3 Creative Labs EMU10k1 [Sound Blaster Live! Series]
           driver: snd_emu10k1 port: d000 bus-ID: 06:01.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-72-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection (Lewisville)
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Ralink RT5370 Wireless Adapter
           driver: rt2800usb v: 2.3.0 usb-ID: 001-004
           IF: wlx000ce7014af0 state: N/A mac: N/A
Drives:    HDD Total Size: 1820.4GB (23.0% used)
           ID-1: /dev/sda model: ST3500418AS size: 500.1GB
           ID-2: /dev/sdb model: Hitachi_HDS72105 size: 500.1GB
           ID-3: /dev/sdc model: ST3500312CS size: 500.1GB
           ID-4: USB /dev/sdd model: Storage_Device size: 320.1GB
Partition: ID-1: / size: 451G used: 127G (30%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.47GB used: 0.01GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A gpu: 0.0:40C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 247 Uptime: 1:51 Memory: 4319.2/7935.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
amii@Basically ~ $
Please give me *some* idea how to fix this problem...
Thank you in advance for any assistance rendered.

Re: Double Trouble

Posted: Tue Dec 24, 2019 10:35 am
by Moem
I can't help you with the problem you're having, but for a desktop clock, since you're on Cinnamon (the poster of the other thread is on Mate), you can use a desklet. Analog Chronometer may be suitable; you can change the size and the appearance.

Re: Double Trouble

Posted: Tue Dec 24, 2019 3:14 pm
by Amii_Leigh
I've tried all of the available desklets. All I want to know now is why I have two copies of Saytime and six copies of Redshift running on restarting of Xorg. That's all that's wrong, really.

By the way, thanks for fixing my first link. It hadn't occurred to me what I'd done wrong, but you fixed it, and thank you!

Re: Double Trouble

Posted: Tue Dec 24, 2019 3:45 pm
by Amii_Leigh
HEY! Deleting off the Xclock autostart seems to have fixed my 'double-trouble' problem! I also DO like the "Analog Chronometer" although it doesn't have any options to have it show on top like xclock would do.
Thank you.

Re: Double Trouble [SOLVED]

Posted: Tue Dec 24, 2019 7:01 pm
by Moem
That's good to hear! I'm glad that you got out of your 'double trouble'. Well done!