FileZilla problem [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

FileZilla problem [SOLVED]

Post by muffybean »

In preparation for moving more to Linux I need an FTP Client program to use instead of Ipswitch WS_FTP Client I use in Windows. I had no issues in installing FZ and when I put in the credentials for my Synology NAS manged to logon fine and be able to download files. However, with a private site hosted by a friend of mine that I have no issues logging into in Windows using WS_FTP Client I cannot get to the files on his server.

It logs on to it but then does not open. Here is the error log.
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.191.82.215:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/D:/BarnOwls" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (86,191,82,215,160,157)
Command: LIST
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing
Now I have spoken to my friend, who knows nothing about Linux and sent this error to him. He replied "the FTP does support TLS "

I do not know much about this sort of thing and wonder if anyone can help me. I definitely need to be able to access his site. It is passive and the port is 21.
Last edited by muffybean on Fri Jan 03, 2020 10:12 am, edited 1 time in total.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Here is some additional information I have captured from Ipswitch WS_FTP.
Transfer Settings.png
advanced-settings.png
SSL.png
There is on more capture that I cannot add in this message but will add it in the next.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Last capture.
SSH.png
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
mint-me
Level 3
Level 3
Posts: 137
Joined: Sat May 26, 2012 2:25 am
Location: Australia

Re: FileZilla problem

Post by mint-me »

Filezilla is a standard. Try these settings on Filezilla - include your FTP host, user and password. Leave other tabs as default:
FILEZILLA
Site Manager > YourServer > General
Protocol: FTP
Encryption: Require explicit FTP over TLS
Logon Type: Normal

My best guess, is that this may be a firewall problem.
A lot of hosts FTPS use either ports 30000:35000 or ports 30000:30500 to enable "passive" connections (as well as port 21).
The server should allow these port connections, AND these ports should also be open TCP OUT & UDP OUT flowing freely from your PC/firewall thru the router and ISP to eventually be accepted by the server.

You could also use "zenmap" to check that you can probe/access the ports on the server, take care you don't get blocked by the server's firewall.

Try to isolate where the problem might be - your PC, software, firewall, router, ISP, server ports, etc...

If you don't solve it, drop a line here with your findings - good luck!
Linux Mint 19.3 XFCE 64bit
HP Notebook 15 BS143TU Intel® Core™ i5-8250U, 8GB DDR4 2400Mhz, Intel® UHD Graphics 620, 1 TB SATA, 15.6" HD 1366x768

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

If you don't solve it, drop a line here with your findings - good luck!
I have tried different settings as follows. First I set up port forwarding on my router to 30000-35000, I also did this in the Firewall and Router Configuration Wizard.

These are what I set.
default-transfer-mode..png
passive mode..png
External-ip..png
In the last setting regarding port range I selected use the following port range 30000-35000.

This was the response from the wizard.
Connecting to probe.filezilla-project.org
Connection established, waiting for welcome message.
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.28.0
Response: 230 logged on.
Checking for correct external IP address
Retrieving external IP address from http://ip.filezilla-project.org/ip.php
Checking for correct external IP address
IP 81.154.13.49 ib-bfe-bd-ej
Response: 200 OK
PREP 32801
Response: 200 Using port 32801, data token 1925071138
PORT 81,154,13,49,128,33
Response: 200 PORT command successful
LIST
Response: 150 opening data connection
Response: 503 Failure of data connection.
Server sent unexpected reply.
Connection closed
At the finish it said the server sent an unexpected or unrecognized reply. This means that some router and/or firewall is still interfering with FileZilla, saying re-run the wizard.
Finally this is what I get when I try to log on to the server.
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.161.196.62:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing of "/D:/Barnowls"...
Command: CWD /D:/Barnowls
Response: 250 CWD command successful. "/D:/Barnowls" is current directory.
Command: PWD
Response: 257 "/D:/Barnowls" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (86,161,196,62,245,10)
Command: LIST
Error: Connection timed out after 65 seconds of inactivity
Error: Failed to retrieve directory listing
Status: Disconnected from server
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.161.196.62:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing of "/D:/Barnowls"...
I really cannot make head nor tail of this as it is beyond my knowledge. As I said using Ipswitch WS_FTP client in windows I have no issues.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: FileZilla problem

Post by Larry78723 »

Can you post the contents of the config file for your windows ftp client?
Image

User avatar
mint-me
Level 3
Level 3
Posts: 137
Joined: Sat May 26, 2012 2:25 am
Location: Australia

Re: FileZilla problem

Post by mint-me »

Firstly, I wouldn't use the wizard, its not needed. I tried it here and it didn't work, yet I can do FTPS easily. Try setting up the account in "Site Manager" as mentioned above, with those few settings, and the rest as default.

Here, I don't need to forward ports at all. Open GUFW (firewall config) on Mint, and check that required outgoing ports are open. You can set it to Allow Outgoing, to allow all ports out.

At this stage I suspect your friend's server is misconfigured for FTPS, and you have been connecting on standard unencrypted FTP.
Linux Mint 19.3 XFCE 64bit
HP Notebook 15 BS143TU Intel® Core™ i5-8250U, 8GB DDR4 2400Mhz, Intel® UHD Graphics 620, 1 TB SATA, 15.6" HD 1366x768

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

At this stage I suspect your friend's server is misconfigured for FTPS, and you have been connecting on standard unencrypted FTP.
Don't think he uses FTPS, just FTP.

Right I have checked GUFW and that is set to default, all outgoing open and had a go at setting up the connection to his server without using the wizard. I assume when you just set up the connection it does not use anything I have previously used with the wizard or is there somewhere it can be set to default?

This is the site manager settings I did.
General-settings..png


This is the result it produced from the connect log.
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.161.196.62:21...
Status: Connection established, waiting for welcome message...
Response: 220 BarnOwls SuperStore
Command: AUTH TLS
Response: 500 Unknown command.
Command: AUTH SSL
Response: 500 Unknown command.
Error: Critical error: Could not connect to server
One final thing, if I set my NAS box settings in Site Manager to "Require explicit FTP over TLS if available" I can't connect to that. When I change it to "Use explicit FTP over TLS if available" it connects instantly.

Update:
I tried the same setting with Sentinal and got this log from connection.
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.161.196.62:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing of "/D:/Barnowls"...
It then sits there not doing anything. Ironically when I run Ipswitch WS_FTP in Windows 10 VM on this machine using the same settings I use on my main Windows 10 machine this is the same result I get on that, connecting but not listing files. Could it be this machine that is the problem?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Just installed FZ on my Win 10 PC and getting same error. Out for lunch now so will get back to this later.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Larry78723 wrote:
Thu Dec 26, 2019 7:10 pm
Can you post the contents of the config file for your windows ftp client?
Hi Larry are you talking about in Windows or Linux?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
Larry78723
Level 7
Level 7
Posts: 1808
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: FileZilla problem

Post by Larry78723 »

The config file for your Windows ftp client that works correctly.
Image

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Larry78723 wrote:
Fri Dec 27, 2019 8:48 am
The config file for your Windows ftp client that works correctly.
Sorry Larry was out for lunch, which actually was excellent. Just logged into the site via Ipswitch WS_FTP cliaent in Windows 10 and here is the log.
Finding Host mylibrary.ddns.net ...
Connecting to 86.161.196.62:21
Connected to 86.161.196.62:21 in 0.015627 seconds, Waiting for Server Response
220 BarnOwls SuperStore
Host type (1): AUTO
USER Muffybean
331 Password required for Muffybean.
PASS (hidden)
230 User Muffybean logged in.
SYST
215 UNIX Type: L8
Host type (2): Unix (Standard)
Sending "FEAT" command to determine what features this server supports.
FEAT
211-Extensions supported:
CLNT
MDTM
PASV
REST STREAM
SIZE
211 End.
Finished interpreting "FEAT" response.
Sending the FEAT command is optional. You can disable it in the site options of the profile.
CLNT WS_FTP_LE 12.4.1
200 "WS_FTP_LE 12.4.1" noted.
PWD
257 "/D:/BarnOwls" is current directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (86,161,196,62,68,184)
connecting data channel to 86.161.196.62:68,184(17592)
Failed to connect data channel to 86.161.196.62:68,184(17592)
PORT 192,168,1,133,202,228
200 Port command successful.
LIST
150 Opening data connection for directory list.
# transferred 3385 bytes in 0.031 seconds, 866.552 kbps ( 108.319 kBps), transfer succeeded.
226 Transfer ok
QUIT
221 Goodbye.
Connection closed. Ready for next connection.
Hope you can sort something out from that. It does not mean that much to me.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
mint-me
Level 3
Level 3
Posts: 137
Joined: Sat May 26, 2012 2:25 am
Location: Australia

Re: FileZilla problem

Post by mint-me »

Your friend's server is not configured for FTPS, so you won't be able to connect using SSL/TLS. You are only able to connect to FTP unsecured.

If you want to connect securely, your friend will need configure his server for FTPS, AND set appropriate firewall rules.
Linux Mint 19.3 XFCE 64bit
HP Notebook 15 BS143TU Intel® Core™ i5-8250U, 8GB DDR4 2400Mhz, Intel® UHD Graphics 620, 1 TB SATA, 15.6" HD 1366x768

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

mint-me wrote:
Sat Dec 28, 2019 8:08 pm
Your friend's server is not configured for FTPS, so you won't be able to connect using SSL/TLS. You are only able to connect to FTP unsecured.

If you want to connect securely, your friend will need configure his server for FTPS, AND set appropriate firewall rules.
So how would I configure FZ to connect like this?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
mint-me
Level 3
Level 3
Posts: 137
Joined: Sat May 26, 2012 2:25 am
Location: Australia

Re: FileZilla problem

Post by mint-me »

Just like before, but make this change.

Encryption: Require explicit FTP over TLS

change to

Encryption: Only use plain FTP (insecure)

This method is always frowned upon these days as insecure, with FTPS or SSH/SFTP being recommended.
Linux Mint 19.3 XFCE 64bit
HP Notebook 15 BS143TU Intel® Core™ i5-8250U, 8GB DDR4 2400Mhz, Intel® UHD Graphics 620, 1 TB SATA, 15.6" HD 1366x768

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Hi Mint-me I did this in FZ on Windows 10 with your suggested settings as shown:
insecure-FTP.png
Still no connection it timed out. When I use WS_FTP it connects in 25 secs so what is different?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
mint-me
Level 3
Level 3
Posts: 137
Joined: Sat May 26, 2012 2:25 am
Location: Australia

Re: FileZilla problem

Post by mint-me »

Logon Type: Normal
Linux Mint 19.3 XFCE 64bit
HP Notebook 15 BS143TU Intel® Core™ i5-8250U, 8GB DDR4 2400Mhz, Intel® UHD Graphics 620, 1 TB SATA, 15.6" HD 1366x768

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

mint-me wrote:
Sun Dec 29, 2019 6:39 am
Logon Type: Normal
Did that but still no connection with FZ. I got this info from the connection details.
Status: Resolving address of mylibrary.ddns.net
Status: Connecting to 86.191.132.26:21...
Status: Connection established, waiting for welcome message...
Status: Plain FTP is insecure. Please switch to FTP over TLS.
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/D:/BarnOwls" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (86,191,132,26,231,189)
Command: LIST
Error: The data connection could not be established: ETIMEDOUT - Connection attempt timed out
As I said previously I am doing this from my Windows 10 machine which I have FZ and WS_FTP installed on. With WS_FTP it logs in every time after 25 secs but FZ it comes up with that ETIMEOUT message. The only difference from before is I changed from Account to Normal.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Connected. Been playing around with the settings and my friend did say try active mode, so in the settings I checked these settings in Connections/FTP.
Active-transfer-mode.png
This enabled me to access my friends server immediately and quicker than WS_FTP. I did this in Windows and will try it in Linux later on.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

User avatar
muffybean
Level 5
Level 5
Posts: 526
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: FileZilla problem

Post by muffybean »

Right I have now tried this in Linux and still issues. First of all when running FZ in Windows under Encryption I used "Use explicit FTP over TLS if available" and this worked fine and banged into the server in under 5 secs.

I opened up FZ in Linux and cross checked the settings I had in my Windows machine, both monitors are side by side, so it is easy to compare. I did the same thing in the EZ-Linux settings under FTP in Transfer mode using Active and Allow fall back to other transfer modes. Double checked everything and clicked on Connect and it logged on but got the following Directory error.
Failed-Directory-Listing..png
On this linux Machine I also run Windows in VM and when I run WS_FTP in that environment I get the same error, which I find rather strange. I have to say that FZ in Windows is very quick, as I said logging in in under 5 secs. When I use WS_FTP in Windows it takes 25 secs.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop

Post Reply

Return to “Software & Applications”