[SOLVED] Nemo zoom level doesn't stay the same

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
matt7137
Level 1
Level 1
Posts: 38
Joined: Mon May 19, 2014 5:18 pm

[SOLVED] Nemo zoom level doesn't stay the same

Post by matt7137 »

I have a desktop PC running Mint 19.3 cinnamon

When I click around my folders nemo displays the list view in varies sizes.
I have list view, inherit view type from parent, and I have checked and unchecked the box that says: Ignore per-folder view preferences but nemo refuses to keep my view that I used in my Home folder.

Help. I hate having to change the view every time I look around my PC.

Thanks
Last edited by matt7137 on Mon Feb 24, 2020 4:04 pm, edited 2 times in total.

User avatar
smurphos
Level 15
Level 15
Posts: 5938
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: nemo zoom level doesn't stay the same

Post by smurphos »

Hi,

Can you report the output of the terminal command below. It will check your home for files / folders not under your ownership. I'm wondering if there is a problem with file ownership preventing your Nemo preferences from 'sticking'

Code: Select all

find $HOME ! -user $USER
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

matt7137
Level 1
Level 1
Posts: 38
Joined: Mon May 19, 2014 5:18 pm

Re: nemo zoom level doesn't stay the same

Post by matt7137 »

I got:

matt@matt-desktop:~$ find $HOME ! -user $USER
/home/matt/.cache/dconf
find: ‘/home/matt/.cache/dconf’: Permission denied
/home/matt/.cache/doc
find: ‘/home/matt/.cache/doc’: Permission denied
/home/matt/.dbus
find: ‘/home/matt/.dbus’: Permission denied
/home/matt/.gvfs
find: ‘/home/matt/.gvfs’: Permission denied

Thanks

User avatar
smurphos
Level 15
Level 15
Posts: 5938
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: nemo zoom level doesn't stay the same

Post by smurphos »

Hi, run the command below in a terminal to fix those ownership issues. Log off and back on. Check your nemo preferences and see if it behaves itself better.

Code: Select all

sudo chown -Rc $USER:$USER $HOME
Checking Ignore per folder view preferences is working fine for me.

There does seem to be a bug with unchecking Inherit view type from parents.

I'd expect with Ignore per folder view preferences checked, and Inherit view type from parents unchecked that even if you manually switch from a default of list view to say icon view in a folder, stepping down to a sub-folder would revert to the default list view. It doesn't.

You can workaround this by using a terminal command to (relatively) quickly set a custom view preference for a bunch of folders and then run nemo with Ignore per folder view preferences unchecked. For example this command will set all folders in your home folder to have a custom view preference of List view at 100% zoom

Code: Select all

find -L $HOME -type d -print0 | while IFS= read -r -d $'\0' DIRS; do gio set "$DIRS" metadata::nemo-default-view "OAFIID:Nemo_File_Manager_List_View"; gio set "$DIRS" metadata::nemo-list-view-zoom-level "3"; done
Another example - make all subdirectories in Pictures in icon view at maximum zoom

Code: Select all

find -L $HOME/Pictures -type d -print0 | while IFS= read -r -d $'\0' DIRS; do gio set "$DIRS" metadata::nemo-default-view "OAFIID:Nemo_File_Manager_Icon_View"; gio set "$DIRS" metadata::nemo-icon-view-zoom-level "6"; done
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

matt7137
Level 1
Level 1
Posts: 38
Joined: Mon May 19, 2014 5:18 pm

Re: nemo zoom level doesn't stay the same

Post by matt7137 »

I did:
sudo chown -Rc $USER:$USER $HOME

Returned this:
changed ownership of '/home/matt/.cache/dconf/user' from root:root to matt:matt
changed ownership of '/home/matt/.cache/dconf' from root:root to matt:matt
changed ownership of '/home/matt/.cache/doc' from root:root to matt:matt
changed ownership of '/home/matt/.dbus/session-bus/aaa642a1efb049fba8d6ca0c8d22ff0a-0' from root:root to matt:matt
changed ownership of '/home/matt/.dbus/session-bus' from root:root to matt:matt
changed ownership of '/home/matt/.dbus' from root:root to matt:matt
changed ownership of '/home/matt/.gvfs' from root:root to matt:matt

Logged out and back on.

Originally it looked fine. But if I search within a folder my search results come back at least one, may be two zoom levels higher. It's like Nemo is shouting at me.
Even if I return to my Desktop and click the Trash Can that too isn't set at the zoom level I used when I set it in Nemo while in my Home Directory.
I've tried this with Inherit and Ignore per folder view checked and unchecked.

I haven't tried the other commands because they sound beyond my scope of understanding what is occurring. So better to be safe then sorry.

User avatar
smurphos
Level 15
Level 15
Posts: 5938
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: nemo zoom level doesn't stay the same

Post by smurphos »

matt7137 wrote:
Fri Feb 21, 2020 1:30 pm

Originally it looked fine. But if I search within a folder my search results come back at least one, may be two zoom levels higher. It's like Nemo is shouting at me.
Even if I return to my Desktop and click the Trash Can that too isn't set at the zoom level I used when I set it in Nemo while in my Home Directory.
Can you report the output of the terminal command below. It just lists all your nemo settings.

Code: Select all

dconf dump /org/nemo/
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

matt7137
Level 1
Level 1
Posts: 38
Joined: Mon May 19, 2014 5:18 pm

Re: nemo zoom level doesn't stay the same

Post by matt7137 »

matt@matt-desktop:~$ dconf dump /org/nemo/
[preferences]
inherit-show-thumbnails=true
quick-renames-with-pause-in-between=true
inherit-folder-viewer=true
executable-text-activation='display'
default-folder-viewer='list-view'
show-hidden-files=false
show-image-thumbnails='never'
show-location-entry=true
ignore-view-metadata=true

[window-state]
sidebar-width=343
side-pane-view='tree'
start-with-sidebar=true
maximized=true
sidebar-bookmark-breakpoint=5

[desktop]
show-orphaned-desktop-icons=false
font='Noto Sans CJK HK 12'
trash-icon-visible=true

[list-view]
default-zoom-level='standard'


I double clicked on my Home directory on my Desktop, set my view level, 2 steps higher than the lowest level. I close the directory. I double click on it again and it is back to it's chosen view, level 3.

Thanks,

matt

User avatar
smurphos
Level 15
Level 15
Posts: 5938
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: nemo zoom level doesn't stay the same

Post by smurphos »

matt7137 wrote:
Sat Feb 22, 2020 12:31 pm
[list-view]
default-zoom-level='standard'
Thanks - I think this is your issue - your default list view preference is 'standard' (100% in the GUI).

Change it here

Image
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

matt7137
Level 1
Level 1
Posts: 38
Joined: Mon May 19, 2014 5:18 pm

Re: nemo zoom level doesn't stay the same

Post by matt7137 »

Thank you smurphos that solved my problem!

matt

Post Reply

Return to “Software & Applications”