Page 1 of 1

Remmina won't launch

Posted: Fri Mar 13, 2020 10:36 am
by oldgranola
Hello, I like many may need to work from home shortly, so trying to get the client Remmina working. I have installed it both with the software manager and directly from the community web page. Seems to install fine without errors but won't launch from the gui icon or from the command line. This is on LM19.3 cinnamon all updated. Below is what I get from the command line:

Code: Select all

$ remmina
StatusNotifier/Appindicator support: not supported by desktop. libappindicator will try to fallback to GtkStatusIcon/xembed

(remmina:4786): Gtk-WARNING **: 07:29:45.085: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem
remmina: symbol lookup error: /usr/lib/x86_64-linux-gnu/libappindicator3.so.1: undefined symbol: xapp_status_icon_new
I went to the IRC linked to the the remmina mint project page from https://community.linuxmint.com/software/view/remmina# and posted the information above but get nothing but snark. Anyone more mature here that can help? Thanks

Re: Remmina won't launch

Posted: Fri Mar 13, 2020 11:23 am
by oldgranola
OK, like so many things cinnamon where I get a hint of incompatibility, I find the solution is flatpak. At least that loads and functions. The remote screen looks like crap on my HDMI hidpi screen, have to figure that out out. So why is it common enough now for programs to not work with current cinnamon in linux Mint19.x ?

Re: Remmina won't launch

Posted: Fri Mar 13, 2020 9:54 pm
by oldgranola
I'm not going to post solved because its not really solved until a reasonable fix why a program installable from the official repository from the program manager dosn't work in cinnamon. Crickets.

Re: Remmina won't launch

Posted: Fri Mar 13, 2020 10:10 pm
by Kadaitcha Man
oldgranola wrote:
Fri Mar 13, 2020 9:54 pm
I'm not going to post solved because its not really solved until a reasonable fix why a program installable from the official repository from the program manager dosn't work in cinnamon.
If you installed form "the official repository" then you've probably installed a rather old version. You would be far better off to try NoMachine. Download the .deb file and double-click it to install, then you should be up and running once its installed on both machines.

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 2:24 am
by smurphos
oldgranola wrote:
Fri Mar 13, 2020 9:54 pm
I'm not going to post solved because its not really solved until a reasonable fix why a program installable from the official repository from the program manager dosn't work in cinnamon. Crickets.
It should be trouble-shootable because the repo version is working fine on my Cinnamon 19.3. So something about your environment. The error is related to creating a tray icon.

Starting point - what version do you have of the libraries throwing the error

Code: Select all

apt policy libappindicator3-1

Code: Select all

apt policy libxapp1
I suspect this is an issue related to upgrading a machine from 19.2 to 19.3 with gm10's PPA active.

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:01 am
by oldgranola
Don't think so as I didn't upgrade from 19.2. I did a clean install to 19.3 because 19,2 was a disaster for all of my amd machines. Couldn't even run as a live usb
Are you asking me to run the above code in term?

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:04 am
by smurphos
Yes please run the commands to check the versions of those libraries.

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:14 am
by oldgranola
Heres one

Code: Select all

 apt policy libappindicator3-1
libappindicator3-1:
  Installed: 12.10.1+18.04.20180322.1-1mint2
  Candidate: 12.10.1+18.04.20180322.1-1mint2
  Version table:
 *** 12.10.1+18.04.20180322.1-1mint2 700
        700 http://packages.linuxmint.com tricia/upstream amd64 Packages
        100 /var/lib/dpkg/status
     12.10.1+18.04.20180322.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:16 am
by oldgranola
Her's two

Code: Select all

apt policy libxapp1
\libxapp1:
  Installed: 1.4.9
  Candidate: 1.4.9
  Version table:
     1.6.10+tricia 500
        500 http://packages.linuxmint.com tricia/backport amd64 Packages
 *** 1.4.9 700
        700 http://ppa.launchpad.net/gm10/linuxmint-tools/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.4-2fakesync1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:18 am
by oldgranola
Thank you Smurphos for your time as always. well I see on the second there is gm10's launchpad but how would that cause

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:25 am
by smurphos
Thanks, you need to switch from the version from gm10's PPA - which is a tweaked version of the 19.2 library to the newer stock Mint version for 19.3

This should do it

Code: Select all

apt install libxapp1/tricia
I've doublechecked on my system and forcing gm10's version breaks Remmina and quite a few other apps with sys tray icons on 19.3.

What I'm not sure about is how you've ended up with gm10's version on a fresh install, I could understand how it might get left behind on an upgrade.

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:39 am
by oldgranola
Ah. thank you Smurphos so much. I got Gm10's because I liked his aporoach to kernel tools n such long post 19.3. Think I applied about 3 months ago about the time he had his tiff with clem. Had no idea this was a known problem. dang. I'll apply your fix and report and eat crow. May I also ask how to get back to the official updater if you undersand? Thank you . I can just go back to UKUU for that. However, this dosen't stop my issues with cinnamon in general which started long before:>)

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:41 am
by smurphos
It's not the PPA that's a problem per-se - I've got it installed as-well although I'm starting to become concerned that gm10 has abandoned the project - no updates for 9 weeks now and he's absent from the forums for a good while.

It might be worth you checking via Software Sources if you've got any other packages installed from gm10's PPA's that probably shouldn't be on a 19.3 system.

Image

On my fresh install 19.3 with the PPA added I've not got the gm10 versions of libxapp1, libxapp-debug, libxapp-dev, linuxmint-tools-compatibility-pack, python-xapp, and xapp-docs.

If you did want to downgrade - instructions are on his PPA page - https://launchpad.net/~gm10/+archive/ub ... mint-tools

Re: Remmina won't launch

Posted: Sat Mar 14, 2020 5:45 am
by oldgranola
Thats so dang helpful! thanks I'll look. I'll be home due to the bug closing work at the university so should have time to muck around. Again, thanks so much for your time!!