Evolution & Claws email - error message

Questions about applications and software
Forum rules
Before you post please read how to get help
SilenceIsG0lden
Level 1
Level 1
Posts: 29
Joined: Thu Mar 12, 2020 3:50 pm

Re: Evolution & Claws email - error message

Post by SilenceIsG0lden »

Thanks for that, xenopeek. Just ran into the same problem as others with the Claws from the 19.3 repository not working with Yahoo mail.

Question, please: can we assume that Claws version 3.17.5 will be in the soon-to-be-released Mint 20 repository? (I'm still on newbie feet with installing anything from outside of those.)
~~~~~~~
Falling out of love with Windows7 and looking for new ways to use my PC (which I built myself, in 2008).
Testing with Linux Mint 19.3 cinnamon. Trying to use my old DOS knowledge, but not getting very far.

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution & Claws email - error message

Post by xenopeek »

SilenceIsG0lden wrote:
Tue May 19, 2020 1:39 pm
Question, please: can we assume that Claws version 3.17.5 will be in the soon-to-be-released Mint 20 repository?
Claws on Linux Mint 20 comes from the Ubuntu 20.04 package base; that has version 3.17.5.

However, this issue doesn't look to be with the Claws version or at least not with just that. As Claws and Evolution have the same issue I suspect some library used by both as the cause. The related Ubuntu bug report https://bugs.launchpad.net/ubuntu/+sour ... ug/1876286 doesn't mention anybody on Ubuntu 20.04 having the issue so hopefully the newer library versions on Ubuntu 20.04 solve this issue.
Image

t42
Level 3
Level 3
Posts: 189
Joined: Mon Jan 20, 2014 6:48 pm

Re: Evolution & Claws email - error message

Post by t42 »

I just tested pop.mail.yahoo.com port 995 and imap.mail.yahoo.com port 993 with claws-mail 3.17.5-2 on Debian Bullseye.
claws-mail version 3.17.5-2 cannot login to yahoo.mail with both IMAP and POP3.
I tested the same account with thunderbird and IMAP is working fine. Thunderbird POP3 can't login to this account, but this is not significant as yahoo POP3 functionality is not stable for years.
-=t42=-

SilenceIsG0lden
Level 1
Level 1
Posts: 29
Joined: Thu Mar 12, 2020 3:50 pm

Re: Evolution & Claws email - error message

Post by SilenceIsG0lden »

Thanks, t42, for testing!

And: argh! Seriously? There goes my hope... Yahoo is such a pain...
~~~~~~~
Falling out of love with Windows7 and looking for new ways to use my PC (which I built myself, in 2008).
Testing with Linux Mint 19.3 cinnamon. Trying to use my old DOS knowledge, but not getting very far.

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution & Claws email - error message

Post by xenopeek »

t42 wrote:
Wed May 20, 2020 11:03 am
I just tested pop.mail.yahoo.com port 995 and imap.mail.yahoo.com port 993 with claws-mail 3.17.5-2 on Debian Bullseye.
claws-mail version 3.17.5-2 cannot login to yahoo.mail with both IMAP and POP3.
I tested the same account with thunderbird and IMAP is working fine. Thunderbird POP3 can't login to this account, but this is not significant as yahoo POP3 functionality is not stable for years.
Will you make a bug report for this on Debian?

Could you please also test with Evolution 3.36.2 on Debian Bullseye?
(I'd do it myself but Yahoo for some reason won't let me register an account so I can't test.)

I've reported the Ubuntu bug for Evolution as also affecting Claws Mail, given reports here (on Linux Mint) about it. If you make any Debian bug reports I'll link them.
Image

t42
Level 3
Level 3
Posts: 189
Joined: Mon Jan 20, 2014 6:48 pm

Re: Evolution & Claws email - error message

Post by t42 »

xenopeek wrote:
Wed May 20, 2020 1:54 pm
Could you please also test with Evolution 3.36.2 on Debian Bullseye?
Debian Bullseye evolution 3.36.2-1 - same result as claws-mail 3.17.5-2 - Login rejected.

I sent Claws-mail bug report to debian bug reporting system
https://bugs.debian.org/cgi-bin/bugrepo ... 1173;msg=5
acknowledged with "If you wish to submit further information on this problem, please send it to 961173@bugs.debian.org"

About Yahoo POP3 service, the test for me is inconclusive - several years ago you will need a Yahoo paid account to allow pop3 mail delivery, for the free accounts only specific countries were allowed to use pop3. I don't know if it is still the case, but indeed at the time only my former xxxx@yahoo.co.uk account could use POP3. Here is the old page on the subject http://www.techiecorner.com/126/free-ya ... sg-and-hk/
-=t42=-

t42
Level 3
Level 3
Posts: 189
Joined: Mon Jan 20, 2014 6:48 pm

Re: Evolution & Claws email - error message

Post by t42 »

No luck with my debian bug report, sorry...
...the error seems to be 'Invalid credentials'.
Of course this is not a Claws Mail bug, closing.
regards,
--
Ricardo Mones
-=t42=-

andreac
Level 1
Level 1
Posts: 2
Joined: Mon May 04, 2020 4:35 am

Re: Evolution email - error message

Post by andreac »

wpshooter wrote:
Mon May 04, 2020 6:38 am
andreac wrote:
Mon May 04, 2020 4:38 am
wpshooter wrote:
Thu Apr 30, 2020 7:13 pm
How do we even know that they are aware of it ? It is practically impossible to get in touch with the people that write this and other Linux based software !!!
This statement is just wrong. https://wiki.gnome.org/Apps/Evolution clearly explain how and where you can get support. You cannot state that is "practically impossible to get in touch" if you have never tried to get in touch.
Who says I have never tried to get in touch with them ???
Feel free to link to your mailing list post or ticket. It's not needed to understand all technical knowledge as people would explain how to gather more information.

My point was that your statement that "it is practically impossible to get in touch" is just plain wrong. Now you yourself wrote that your statement is wrong.

User avatar
bearzlos
Level 2
Level 2
Posts: 53
Joined: Sun Sep 02, 2018 10:13 pm
Location: Space Coast Florida

Re: Evolution & Claws email - error message

Post by bearzlos »

Xenopeek and all... Success! The problem I was having with the TLS/SSL signature failure and bellsouth.net has been resolved! :D

Reminding everyone that I'm using Mint 19.0 (cinnamon) 64 bit and had been using Claws-Mail 3.16.0.

I grabbed Claws-Mail 3.17.5 from Flatpack and installed it.

The problem went away and I can now get mail from bellsouth.net.

Thanks, everyone, for guiding me to this solution.
bearzlos

MEHA
Level 1
Level 1
Posts: 3
Joined: Wed May 27, 2020 1:47 am

Re: Evolution & Claws email - error message

Post by MEHA »

I have the same error «Error performing TLS handshake:
I use yahoo email and show this error from 3 weeks ago.
My evolution client email is 3.28.5-0ubuntu0.18.04.2 and I use Linux mint 19

I installed thunderbird and this error not appears in yahoo email account.

Could be only Evolution as software who offers this issue?

greetings

MintPuppy
Level 1
Level 1
Posts: 33
Joined: Sat May 30, 2020 11:17 am

Re: Evolution & Claws email - error message

Post by MintPuppy »

Hello all,

Landed here on this thread after just installing Evolution and getting the error (Yahoo IMAP in my case)
"Error performing TLS handshake : Internal error in memory allocation"

Went through the responses in the thread. In my case , it lets me create the account and the error pops up immediately when the first Send/Receive happens. And so far it hasn't asked me for a password at all for my Yahoo account.

So is this part of the same problem everyone else is facing (in which case, I will just wait till it is resolved), or am I missing some other component due to which I am not even being asked for the password ( to my Yahoo mail) to begin with ?

Thanks !!

cabbage
Level 1
Level 1
Posts: 2
Joined: Sat May 16, 2020 1:25 pm

Re: Evolution & Claws email - error message

Post by cabbage »

Yes, TLS Handshake error was/is a problem, and installing the latest flatpak version should get it going.

MEHA
Level 1
Level 1
Posts: 3
Joined: Wed May 27, 2020 1:47 am

Re: Evolution & Claws email - error message

Post by MEHA »

yes I did. I did follow up the instructions
in my case,
1. Do it backup from evolution
2. Install flatpak but when installed I cant' see at linux mint, after I see flatpak into linux mint software manager for default I don't know its name at english because I use linux mint in spanish.
3. From Flatpak install evolutions version 3.36.0 (by Flathub.org)
4. Reinstall backup.
5. continue the error messages «Error performing TLS handshake>> at evolution client email then delete my yahoo account from evolution client email.
6. reinstall again my yahoo account at evolution client email.
7. I did test again to yahoo acount and yes worked it.
8. No more error messages «Error performing TLS handshake>>

by the way, this evolution is changed, appear it as a new version. reloaded.
someone to warn gnome team that this new update or upgrade causes error at evolution.

MintPuppy
Level 1
Level 1
Posts: 33
Joined: Sat May 30, 2020 11:17 am

Re: Evolution & Claws email - error message

Post by MintPuppy »

cabbage wrote:
Wed Jun 10, 2020 1:29 am
Yes, TLS Handshake error was/is a problem, and installing the latest flatpak version should get it going.
Thanks for your reply cabbage !

I actually meant to ask if a NON-flatpack resolution has become avalable.

User avatar
AndyMH
Level 12
Level 12
Posts: 4187
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Evolution & Claws email - error message

Post by AndyMH »

MintPuppy wrote:
Thu Jun 18, 2020 6:17 pm
I actually meant to ask if a NON-flatpack resolution has become avalable.
What version is in the repos for LM20.0 (I don't know because I'm not one of those brave/foolhardy people who try out beta versions)? Fingers crossed that is not a flatpak.

Did have a quick google and found this instead:
Evolution is maintained by just one person: Milan Crha. And its code base is ancient. Upstream GNOME is working hard to replace it with Geary.
here https://discourse.ubuntu.com/t/evolutio ... ient/15457.
Don't know if true, but makes me slightly uneasy.

EDIT - did a bit more searching, evolution V3.36 is available as a deb here for ubuntu 20.04, so would expect that version in LM20.0:
https://pkgs.org/download/evolution
from what others have been posting, this is the same as the version in the flatpak.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution & Claws email - error message

Post by xenopeek »

You can look up package versions for Linux Mint 20 of software not developed by Linux Mint here: https://packages.ubuntu.com/. Select to search in focal distribution. Evolution is version 3.36.1. That is probably meaningless as it was early on confirmed the issue is with TLS libraries it uses—seeing as other email clients have the same issue.

On the upstream issue https://bugs.launchpad.net/ubuntu/+sour ... ug/1876286 it says the TLS library is fixed for focal so it should work on Linux Mint 20. Reading back from the end, it looks like it will also be fixed for bionic (Mint 19.x) and xenial (Mint 18.x). The root cause being older versions of TLS library not supporting something correctly that Yahoo recently implemented on its servers.
Image

User avatar
bearzlos
Level 2
Level 2
Posts: 53
Joined: Sun Sep 02, 2018 10:13 pm
Location: Space Coast Florida

Re: Evolution & Claws email - error message

Post by bearzlos »

xenopeek wrote:
Fri Jun 19, 2020 2:36 am
The root cause being older versions of TLS library not supporting something correctly that Yahoo recently implemented on its servers.
Yes, and sadly but not unexpected AT&T tech support denies that there were changes made end of May/start of June to any of its
e-mail systems. And in any event, "We only support Windows and Mac. You'll have to call Linux." :roll:

Post Reply

Return to “Software & Applications”