Evolution & Claws email - error message

Questions about applications and software
Forum rules
Before you post please read how to get help
wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email memory issue

Post by wpshooter »

B Dewi 321 wrote:
Fri May 01, 2020 9:29 am
AndyMH wrote:
Fri May 01, 2020 5:59 am
Seems to be dependent on your email service provider. I'm not having problems (do have problems from time to time with google calendar which appear and then go away). You could try timeshifting back to the previous kernel, or boot to the earlier kernel but suspect it won't fix the problem.

Note - see you are running LM18.3. Evolution was one of the primary reasons I upgraded to LM19.x - for a later less buggy version. Think LM18.3 is running evolution 3.18, LM19 is 3.28.
just for info :
did check it right now :
LMDE4 / kernel 4.19.0-8 / evolution 3.28.5 => no problems
Linux Mint 19.2 Mate / kernel 4.15.0-99 / evolution 3.28.5 => no problems
Linux Mint 19.3 Cinnamon / kernel 4.15.0-99 / evolution 3.28.5 => no problems
the usual packages ( not flatpack )

what you also could eventually do ... in case you did add the password to the keyring ?
remove them with the terminal command : rm -v ~/.local/share/keyrings/*.keyring
1/ send a new e-mail
2/ you'll be prompt to restart the initial procedure :
a) password for your e-mailadres
b) confirm if want to store a new keyring password ( encrypting ) ... leave it blank ... continue
c) the first time you'll send a mail after this procedure : you'll be prompt again to give your password , it's normal but only once

for what it is worth :shock:
Could it be that all of this problem is related to the linux kernel version because I notice that the
versions that you quote which you say are working are all OLDER than the 5.0 version that is the
latest version of kernel available for Linux Mint 19.3 mate 64 bit that I am running ?

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition

User avatar
Amii_Leigh
Level 5
Level 5
Posts: 700
Joined: Fri Mar 25, 2016 10:58 pm
Location: Somewhere in the middle of nowhere, Missouri

Re: Evolution email - error message

Post by Amii_Leigh »

I know you mean well, but I just didn't want to fiddle with it. I just installed Thunderbird and uninstalled Evolution. It works, after all. Thanks anyway.
नमस्ते = Namaste
I honor the place in you in which the entire universe dwells.
I honor the place in you in which is of love, of truth, of light, and of peace.
When you are in that place in you, and I am in that place in me, we are one.

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

Went back to older 4.??? kernel, did not solve problem.

Have also, tried eliminating Evolution password entries in Seahorse but did not solve the problem, am going to give it another shot right now.

Just finished the retry. After eliminating the sending key in Seahorse and then opening Evolution, it had recreated the sending key but still not key for the receiving function.

Thanks.
Last edited by wpshooter on Fri May 01, 2020 1:45 pm, edited 1 time in total.
Mint 20 mate 64 bit.
SERVICE > competition

LinuxStuff
Level 1
Level 1
Posts: 8
Joined: Thu Apr 30, 2020 1:42 pm

Re: Evolution email - error message

Post by LinuxStuff »

Pretty sure this is related to the certs. Here is what I've tried. I have a firewall that allows all traffic to be decrypted and inspected by the firewall before it is re-encrypted and relayed to my internal machines. To accomplish this Firefox (the browser I'm using and Seahorse) need to be updated with the firewall's cert. My mail to Evolution works fine if I have the DPI-SSL on. So the mail server at the ISP is talking to my firewall and it's cert. and my Evolution is talking to my firewall's cert. If I turn DPI-SSL off, I have to do this sometimes for Zoom (free version), Evolution no longer works. So it has to do with Evolution's communication with the cert. at the ISP. I'm using Evolution 3.28.5 (3.28.5-3.fc28) on Fedora 28 so I'm not current. I have no issues with Outlook or Thunderbird because I believe their certs are dynamically updated. Hopefully someone who is really knowledgeable can work with this info..... Evolution folks maybe... Hope this helps.

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

LinuxStuff wrote:
Fri May 01, 2020 1:40 pm
Pretty sure this is related to the certs. Here is what I've tried. I have a firewall that allows all traffic to be decrypted and inspected by the firewall before it is re-encrypted and relayed to my internal machines. To accomplish this Firefox (the browser I'm using and Seahorse) need to be updated with the firewall's cert. My mail to Evolution works fine if I have the DPI-SSL on. So the mail server at the ISP is talking to my firewall and it's cert. and my Evolution is talking to my firewall's cert. If I turn DPI-SSL off, I have to do this sometimes for Zoom (free version), Evolution no longer works. So it has to do with Evolution's communication with the cert. at the ISP. I'm using Evolution 3.28.5 (3.28.5-3.fc28) on Fedora 28 so I'm not current. I have no issues with Outlook or Thunderbird because I believe their certs are dynamically updated. Hopefully someone who is really knowledgeable can work with this info..... Evolution folks maybe... Hope this helps.
My guess is that you are spot on with your analysis. And I have tried to get AOL technical support to get in touch with Evolution developers or vis-versa and neither one seems to have the least bit of interest in communicating with each other to solve this problem. It's almost like there is a GREAT VOID which neither of them can or are willing to traverse to solve this problem. With AOL it's sort of like they are saying if you are not happy in using our webmail site interface, then the HE?? with you.
Mint 20 mate 64 bit.
SERVICE > competition

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

wpshooter wrote:
Fri May 01, 2020 9:27 am
I have heard of flatpak but that is about it.

How would I do that ?

Thanks.
Sorry missed your question earlier.

From Linux Mint 18.3 there is builtin support flatpaks, which are an alternative source for installing programs on your computer. The benefit of flatpaks are that you get the latest stable version of the program and it runs on any modern Linux distro, updates automatically when there is a new stable release and it can't affect stability of your system as it is self-contained—it includes all the libraries it needs so you don't have to say add a PPA to install newer library versions. You can find a Flatpak category in Software Manager. You can also browse the default available flatpaks on https://flathub.org.

To test the Evolution flatpak please first make a backup of your Evolution data, if you haven't already. Just in case. Then you can either install it from Software Manager by going to the Flatpak category and browsing to find it there or from the terminal you can issue this command to install it (do not add sudo):
flatpak install flathub org.gnome.Evolution
It will take a bit of time to install if this is the first Flatpak on your system as it will need to install the common Gnome runtime for Flatpaks, which is about 1 GB in size I believe.

Afterwards you can start it by running:
flatpak run org.gnome.Evolution

It should also be added to your menu I think but I'm not sure how well that was handled on Linux Mint 18.3.

I suggest to use the Flatpak as a TEST to confirm whether this is a generic issue between Evolution and AOL—in which case this issue can be reported to Evolution developers on Gitlab, because the first thing they'll ask if you report an issue for 3.18 is if you can please retest with the current stable release 3.36.1 that you can get through Flatpak.
Image

User avatar
Amii_Leigh
Level 5
Level 5
Posts: 700
Joined: Fri Mar 25, 2016 10:58 pm
Location: Somewhere in the middle of nowhere, Missouri

Re: Evolution email - error message

Post by Amii_Leigh »

I am going to keep watching this thread just in case there turns out to be a solution.
नमस्ते = Namaste
I honor the place in you in which the entire universe dwells.
I honor the place in you in which is of love, of truth, of light, and of peace.
When you are in that place in you, and I am in that place in me, we are one.

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Fri May 01, 2020 1:56 pm
wpshooter wrote:
Fri May 01, 2020 9:27 am
I have heard of flatpak but that is about it.

How would I do that ?

Thanks.
Sorry missed your question earlier.

From Linux Mint 18.3 there is builtin support flatpaks, which are an alternative source for installing programs on your computer. The benefit of flatpaks are that you get the latest stable version of the program and it runs on any modern Linux distro, updates automatically when there is a new stable release and it can't affect stability of your system as it is self-contained—it includes all the libraries it needs so you don't have to say add a PPA to install newer library versions. You can find a Flatpak category in Software Manager. You can also browse the default available flatpaks on https://flathub.org.

To test the Evolution flatpak please first make a backup of your Evolution data, if you haven't already. Just in case. Then you can either install it from Software Manager by going to the Flatpak category and browsing to find it there or from the terminal you can issue this command to install it (do not add sudo):
flatpak install flathub org.gnome.Evolution
It will take a bit of time to install if this is the first Flatpak on your system as it will need to install the common Gnome runtime for Flatpaks, which is about 1 GB in size I believe.

Afterwards you can start it by running:
flatpak run org.gnome.Evolution

It should also be added to your menu I think but I'm not sure how well that was handled on Linux Mint 18.3.

I suggest to use the Flatpak as a TEST to confirm whether this is a generic issue between Evolution and AOL—in which case this issue can be reported to Evolution developers on Gitlab, because the first thing they'll ask if you report an issue for 3.18 is if you can please retest with the current stable release 3.36.1 that you can get through Flatpak.
I attempted to report this problem on github but it was just under a section entitled - Github - Linux Mint. So will the proper persons see that if it was posted in the wrong category ? Thanks.
Mint 20 mate 64 bit.
SERVICE > competition

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

Synaptic shows packages from APT repositories. Flatpak repositories are separate. Only Software Manager shows both.
Image

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

The issue has been reported to Ubuntu maintainers of Evolution: https://bugs.launchpad.net/ubuntu/+sour ... ug/1876286

That issue is for Ubuntu 18.04. Evolution on Linux Mint 18.3 comes from Ubuntu 16.04 so it appears to affect multiple versions.

I would suggest those affected to click the button to say the bug affects you and maybe make a comment you're on Ubuntu 16.04 (if you're using Linux Mint 18.3) and mention your email provider as that looks like it plays a role. Add whether you're using IMAP or POP to receive email? You'll need to register an account if you don't have one.
Image

donnstewart
Level 1
Level 1
Posts: 5
Joined: Thu Apr 30, 2020 2:41 pm

Re: Evolution email - error message

Post by donnstewart »

Does starting Evolution from terminal with this command help or make no difference?
export G_TLS_GNUTLS_PRIORITY="NORMAL:%COMPAT:+VERS-TLS1.0" ; evolution
Just for the record, this does not help with my Evolution -- Verizon/AOL account problem. Same error message.

User avatar
AndyMH
Level 12
Level 12
Posts: 4186
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Evolution email - error message

Post by AndyMH »

A drastic solution, but if you like the look of evolution and only want email try mailspring (was nylas mail). I'm staying with evolution because there is no calendar in mailspring. If they introduce one, then I would seriously consider switching.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

May I ask if anyone who is having this problem with Evolution not being able to receive emails
are using email services from any provider other than AOL who several years ago took over
email accounts which formerly belonged to/serviced by Verizon ?

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition

LinuxStuff
Level 1
Level 1
Posts: 8
Joined: Thu Apr 30, 2020 1:42 pm

Re: Evolution email - error message

Post by LinuxStuff »

I'm having problems with accounts run by ATT, Yahoo and Yahoo Small Business. Gmail works.

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

AOL, AT&T, Yahoo and formerly Verizon are all the same email provider. I tried registering an account with all 3 but they won't accept my mobile number for some reason and that's required for verification :?

I suspect that those with issues don't have the packages evolution-data-server-online-accounts and/or libnss3-nssdb installed. Could anyone with the problem confirm? You can search for these packages in Synaptic Package Manager or on the terminal run the following and check the first two characters on each line, 'ii' means its installed:
dpkg -l evolution-data-server-online-accounts libnss3-nssdb

Whichever of the 2 isn't installed go ahead and install it in Synaptic or from the terminal with:
apt install evolution-data-server-online-accounts
apt install libnss3-nssdb

Afterwards you should shut down Evolution and start it anew. You may need to log out of Linux Mint or reboot for Evolution to pick up the changes. Let me know if this makes a difference.

I have a fresh install of Linux Mint 18.3 for further testing but I'd need an AOL, AT&T or Yahoo email account for testing. If anybody has ideas for that PM me.
Image

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Sat May 02, 2020 4:31 am
AOL, AT&T, Yahoo and formerly Verizon are all the same email provider. I tried registering an account with all 3 but they won't accept my mobile number for some reason and that's required for verification :?

I suspect that those with issues don't have the packages evolution-data-server-online-accounts and/or libnss3-nssdb installed. Could anyone with the problem confirm? You can search for these packages in Synaptic Package Manager or on the terminal run the following and check the first two characters on each line, 'ii' means its installed:
dpkg -l evolution-data-server-online-accounts libnss3-nssdb

Whichever of the 2 isn't installed go ahead and install it in Synaptic or from the terminal with:
apt install evolution-data-server-online-accounts
apt install libnss3-nssdb

Afterwards you should shut down Evolution and start it anew. You may need to log out of Linux Mint or reboot for Evolution to pick up the changes. Let me know if this makes a difference.

I have a fresh install of Linux Mint 18.3 for further testing but I'd need an AOL, AT&T or Yahoo email account for testing. If anybody has ideas for that PM me.
I installed the first one from Synaptic, the second one was not found in Synaptic and when I tried it at the terminal it said that it was not found.

Installing the first one made no difference, the error still shows in Evolution.

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

Have another look at libnss3-nssdb, it is available on Linux Mint 18.3 for sure. Or just run:
apt install libnss3-nssdb

Did anybody that has the issue test with Flatpak yet?

I can't be of more help after this as I need a AOL / AT&T / Yahoo mail account for anything more. Whatever I try, they plain refuse me to register a new account :?
Image

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Sat May 02, 2020 7:24 am
Have another look at libnss3-nssdb, it is available on Linux Mint 18.3 for sure. Or just run:
apt install libnss3-nssdb

Did anybody that has the issue test with Flatpak yet?

I can't be of more help after this as I need a AOL / AT&T / Yahoo mail account for anything more. Whatever I try, they plain refuse me to register a new account :?
On my 19.3 mate 64 bit it says this:

[sudo] password for wpshooter:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libnss3-nssdb
Mint 20 mate 64 bit.
SERVICE > competition

User avatar
xenopeek
Level 24
Level 24
Posts: 24747
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

I thought you were on 18.3... mixup.
Image

wpshooter
Level 6
Level 6
Posts: 1069
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Sat May 02, 2020 8:19 am
I thought you were on 18.3... mixup.
If I would download 18.3 and run it from a USB live version could I test Evolution on that live version
to see if the receive function would work correctly on my AOL email account ?

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition

Post Reply

Return to “Software & Applications”