Page 5 of 7

Re: Why are my applications not the latest possible version?

Posted: Mon Jan 26, 2015 3:47 am
by lmuserx4849
hinto wrote:If you always want latest, install LMDE, change the repos to track sid and let it roll.
-Hinto
But...
"As previously announced, LMDE is switching to Debian Stable and a frozen cycle similar to Linux Mint.
... (28 Aug 2014)" http://segfault.linuxmint.com/2014/08/u ... med-betsy/

Re: Why are my applications not the latest possible version?

Posted: Thu Apr 09, 2015 2:39 am
by Lessss
Why are my applications not the latest possible version?
No the better question is why are there broken versions of software in the repositories?

For instance the version of FreeOrion0.4.3-2 will only work for the first 30 turns or so and then instead of turns taking only a minute or two to process they take 30 minutes or more. This is a known issue with this older version.

There are others.....

Re: Why are my applications not the latest possible version?

Posted: Wed Jun 24, 2015 9:21 am
by Kholargol
Lessss wrote:
Why are my applications not the latest possible version?
No the better question is why are there broken versions of software in the repositories?

For instance the version of FreeOrion0.4.3-2 will only work for the first 30 turns or so and then instead of turns taking only a minute or two to process they take 30 minutes or more. This is a known issue with this older version.

There are others.....
Exactly. What's the point of having so many different versions of an app from so many sources. I dream of a real store (like Android) where you could get the latest version of your software..

Re: Why are my applications not the latest possible version?

Posted: Sat Jul 11, 2015 3:52 pm
by kukamuumuka
The newest is not always the best .. :wink:

Re: Why are my applications not the latest possible version?

Posted: Sun Jul 12, 2015 9:07 am
by tek_heretik
administrollaattori wrote:The newest is not always the best .. :wink:
Agreed, sometimes newer versions are almost like a total rewrite GUI wise and some useful things removed, cheeses me off to no end.

Re: Why are my applications not the latest possible version?

Posted: Tue Jul 14, 2015 9:42 am
by fruitkiller
I read the first posts explaining the general problem.

But very confident sites like this here :http://www.omgubuntu.co.uk/2013/10/bans ... 0-released

Will tell me that will install Banshee 2.90. It doesn't,

Banshee is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. (the 1 not upgraded is on purpose)

I'm still with Mint 17.1 MATE 64 bits. Haven't updated to 17.2 yet, I'll wait a little while before doing the upgrade.

I'm bamboozled, I'm able to install newer versions of stuff that isn't available through the basic repos

(the SVN version of kVIRC) for example, I compiled myself the 4.3.1 version, only sucks I can't do checkinstall with it and create a deb for it, I have to use cmake to build it, and I so detest anything requiring cmake when it comes time to compile something.

I built my own ffmpeg according to an excellent guide. Let's say not having a female partner anymore, and a stockpile of ADD meds made me want to learn learn learn for a couple years, came from afraid of linux to compiling, when required.Although compiling Banshee 2.9.0 is beyond my grasp, I get to a dead-end error where I have never been able to get any help, even on the #banshee chatroom where devs are present. Anyway..that's my issue, if you have Banshee 2.9.0 running, help me (no I'm not asking for an amd64banshee290.deb file, although that would be kind of awesome...Let's say I haven't seen Banshee correctly find the BPM of a song correctly since well, my first Linux install, Ubuntu 11.10, 12.04 didn't want to play nice with gnome classic so I switched to Mint afterwards, I think it was Mint 13 then. Alright, I said enough.


Anybody here has Banshee 2.90 running on LM17.1 MATE 64 bits?

Re: Why are my applications not the latest possible version?

Posted: Fri Jul 24, 2015 2:54 pm
by Lessss
waht are you waiting for?
mint 17.2 XFCE 32 bit :-)

Re: Why are my applications not the latest possible version?

Posted: Mon Aug 24, 2015 2:18 am
by mehimu
nice information emorrp1, Keep posting. Thanks.

Re: Why are my applications not the latest possible version?

Posted: Thu Sep 10, 2015 1:23 pm
by Tuxon86
I guess the reason we don't have the latest version of software on Linux is about the same as to why we don't have them on windows either. It isn't the role of the distro to manage 3rd party releases.
Of course in a more closed/controlled environment like OSX where most 3rd party distribute their software through the Apple Store it is easier to be notified.
Maybe we do need a central pool of 3rd party registered PPA that the Software Manager application and the software update service can scan and notify us of new versions available. This would save us the multiple sudo apt-add-repository commands that we have to type.

Re: Why are my applications not the latest possible version?

Posted: Thu Sep 10, 2015 3:39 pm
by gmorehouse
dear god Chromium 45 tho.

I'm drooling over the massive improvement in memory management. Or is that Chrome only? :/

Re: Why are my applications not the latest possible version?

Posted: Fri Oct 30, 2015 10:43 am
by NChewie
How can my Libreoffice be so up to date so quickly? :lol:

Barely time for me to roll 5.03-rc2 out to Windows when you guys have it available on Mint.

Obviously too much time on your hands...

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 7:44 am
by Rob99
I read the first post but it hasn’t mentioned about the key issue: why using Software Manager or even terminal I find so many out-of-data or obsolete software. A simple example is R program. You can check it out:

Code: Select all

sudo apt-get install r-base
After installation I have ver. 3.0.2 which was released in 2013! Another example is QtCreator.
Does anybody is able to explain why. Of course I can go to a website, download and install manually but making use of terminal/SM seems to be questionable.

I started playing around with Linux (Mint) 2 days ago.

Robert

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 8:01 am
by killer de bug
Rob99 wrote:

Code: Select all

sudo apt-get install r-base
After installation I have ver. 3.0.2 which was released in 2013!

I started playing around with Linux (Mint) 2 days ago.
Which version of Linux Mint have you installed?

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 8:21 am
by Rob99
killer de bug wrote:
Rob99 wrote: Which version of Linux Mint have you installed?
The latest: LM Cinnamon 17.2, x64.

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 8:30 am
by killer de bug
Rob99 wrote:The latest: LM Cinnamon 17.2, x64.
Well, this version is based on the LTS version of Ubuntu: 14.04. Which means that the base was frozen in April 2014. Therefore if you make the link with the first post, you understand that you can only have a R version older than April 2014.

According to this page: https://en.wikipedia.org/wiki/R_%28prog ... anguage%29 you can only have version 3.0.x as 3.1 was released in April 2014. And as you may guess it, the base is frozen several weeks before the release of Ubuntu, in order to tackle all the bugs they found. The base was probably frozen in January/February 2014.

This was for the explanation part. Now my personal feeling: Being a huge R user, I honestly think that you can work without problem with this 'old' version of R. I know since I'm doing it. I have a recent version at work, and an older one on my linux system and they work without troubles. If you really want to take the risk to update it, you can find an how-to by googleing "R ubuntu".

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 9:03 am
by Rob99
@killer de bug: I'm immensely indebted to you for explanations. Now I'm aware why it happened.
But I'm little confused, why should I expect any trouble installing the newest ver. of R. It's advisable to do it because some packages, as you probably know, require newer one. I encountered that problem when I installed the recommended ver. 3.0.1. Try, for example, to install plyr package (in a description file is Depends: R (>= 3.1.0)).

It's off topic but as R user you might be familiar how to change a default language in R console into English. In Windows it's pretty easy. As a workaround in Linux I add the line Sys.setlocale("LC_MESSAGES", "en_US.UTF-8") into Rprofile.site. Unfortunately starting messages is not in English.

Re: Why are my applications not the latest possible version?

Posted: Sun Nov 01, 2015 9:47 am
by killer de bug
Rob99 wrote:But I'm little confused, why should I expect any trouble installing the newest ver. of R.
If you install a new version, you may have to install new libraries also. This may impact other softwares installed on your system. You may introduce new bugs, or regressions. This is at your own risks. Don't ask me about the probability. It's probably low, but I have not tried. So I have no idea. You just need to be aware that this is a possibility.

This said, I understand your need, and I would probably attempt to upgrade R if I were in your position.
I have Linux Mint Debian Edition and therefore I have already R 3.1, so I don't face this issue.
Rob99 wrote:It's off topic but as R user you might be familiar how to change a default language in R console into English. In Windows it's pretty easy. As a workaround in Linux I add the line Sys.setlocale("LC_MESSAGES", "en_US.UTF-8") into Rprofile.site. Unfortunately starting messages is not in English.
No idea. I have never tried to change this. It's in french for me and that's perfect. :)

Re: Why are my applications not the latest possible version?

Posted: Wed Mar 30, 2016 8:37 pm
by fruitkiller
Sometimes you can compile them to the latest version and it'll be possible to have the dependencies, like how I did with kvirc's svn and my own ffmpeg.

But some you just can't, like Banshee 2.9.1, it's uninstallable on LM17.x no matter what the guides you find say, especially those having you download banshee2.9.1~really2.6.2.amd64.deb

Re: Why are my applications not the latest possible version?

Posted: Mon Aug 22, 2016 11:27 am
by michellebrooks
It would be nice to get VLC v3 beta installed. Even though it's a Beta, it worked fine for me with openSuse and was an improvement over the latest stable release as far as videos playing more smoothly. The pre-installed player in Mint plays better then the stable release of VLC but is still pretty choppy on bigger files.

Re: Why are my applications not the latest possible version?

Posted: Wed Oct 12, 2016 2:21 pm
by ravenshadow
That depends on the distro as i see it, distros that include the most new software are optimized to run with the newest software.

If the user wants a new version of a software the user can use a ppa (if it is a ppa for the software) to keep the software upgraded.

But add a ppa with caution and only upgrade the software that the user wants to upgrade, ppas can contain other software or other versions that can make things break in the system.