Steam won't start after installation

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Steam won't start after installation

Post by eppok »

Hey guys,

yesterday i installed Steam for the first time on my PC and i just can't get it to run. When i open steam via terminal i get following errors.
eppok@eppok-desktop:~$ steam
Running Steam on linuxmint 19.3 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
/home/eppok/.steam/ubuntu12_32/steam
[2020-05-19 08:16:54] Startup - updater built May 15 2020 03:04:07
SteamUpdateUI: An X Error occurred
X Error of failed request: GLXBadContext
SteamUpdateUI: An X Error occurred
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 45
xerror_handler: X failed, continuing
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 46
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2020-05-19 08:16:54] Checking for update on startup
[2020-05-19 08:16:54] Checking for available updates...
[2020-05-19 08:16:54] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-05-19 08:16:55] Download skipped: /client/steam_client_ubuntu12 version 1589513816, installed version 1589513816
[2020-05-19 08:16:55] Nothing to do
[2020-05-19 08:16:55] Verifying installation...
[2020-05-19 08:16:55] Performing checksum verification of executable files
[2020-05-19 08:16:55] Verification complete
Drivers should be up-to-date. I tried installing the version from software manager and also the one directly downloaded from steam.

Any ideas to fix it?

User avatar
mikaelrask
Level 4
Level 4
Posts: 237
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Steam won't start after installation

Post by mikaelrask »

hey steam seems to needed an update from this lines maybe you should let it.
[2020-05-19 08:16:54] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-05-19 08:16:55] Download skipped: /client/steam_client_ubuntu12 version 1589513816, installed version 1589513816

second did you get the same error if you run the version direct downloaded from steam homepage?
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.33-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 19.3
Kernel 4.15.0.101-generic
Ram 4 gb

eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Re: Steam won't start after installation

Post by eppok »

mikaelrask wrote:
Tue May 19, 2020 4:10 am
hey steam seems to needed an update from this lines maybe you should let it.
[2020-05-19 08:16:54] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2020-05-19 08:16:55] Download skipped: /client/steam_client_ubuntu12 version 1589513816, installed version 1589513816

second did you get the same error if you run the version direct downloaded from steam homepage?
Yes, it's the same error.

What do you mean by "let it"? It's not like I'm stopping it at that exact moment. It's just skipping it. Can I download it manually somehow?

User avatar
mikaelrask
Level 4
Level 4
Posts: 237
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Steam won't start after installation

Post by mikaelrask »

hmm the log say it wants to download a manifest but got skipped a fast google search gave me this it might be connected to that meaby not https://www.youtube.com/watch?v=RyBNEdnaiGU.
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.33-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 19.3
Kernel 4.15.0.101-generic
Ram 4 gb

eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Re: Steam won't start after installation

Post by eppok »

No, that's not it since I am unable to start steam at all.

User avatar
mikaelrask
Level 4
Level 4
Posts: 237
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Steam won't start after installation

Post by mikaelrask »

okey can you provide with some system spec by running this command from the terminal

Code: Select all

inxi -Fxxrzc0
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.33-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 19.3
Kernel 4.15.0.101-generic
Ram 4 gb

eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Re: Steam won't start after installation

Post by eppok »

mikaelrask wrote:
Tue May 19, 2020 11:49 am
okey can you provide with some system spec by running this command from the terminal

Code: Select all

inxi -Fxxrzc0

Code: Select all

System:
  Host: eppok-desktop Kernel: 5.3.0-51-generic x86_64 bits: 64 compiler: gcc 
  v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop Mobo: ASRock model: B450 Pro4 serial: <filter> 
  UEFI: American Megatrends v: P1.80 date: 12/18/2018 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 95816 
  Speed: 1374 MHz min/max: 1550/4000 MHz Core speeds (MHz): 1: 1372 2: 1374 
  3: 1374 4: 1371 5: 1375 6: 1372 7: 1375 8: 1373 9: 1378 10: 1372 11: 1375 
  12: 1375 
Graphics:
  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: eVga.com. driver: nvidia 
  v: 440.59 bus ID: 27:00.0 chip ID: 10de:13c0 
  Display: x11 server: X.Org 1.20.5 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa 
  resolution: 1920x1080~60Hz, 1920x1080~144Hz 
  OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59 
  direct render: Yes 
Audio:
  Device-1: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK CMI8786 
  driver: snd_oxygen v: kernel bus ID: 24:04.0 chip ID: 13f6:8788 
  Device-2: NVIDIA GM204 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 27:00.1 chip ID: 10de:0fbb 
  Device-3: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 29:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k5.3.0-51-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: c000 bus ID: 26:00.0 
  chip ID: 10ec:8168 
  IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad 
  bus ID: 3-3:3 chip ID: 045e:0719 
  IF-ID-1: br-106a46b73143 state: down mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.16 TiB used: 16.07 GiB (1.3%) 
  ID-1: /dev/nvme0n1 model: Sabrent size: 953.87 GiB speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> 
  ID-2: /dev/sda vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> temp: 34 C 
Partition:
  ID-1: / size: 22.79 GiB used: 10.51 GiB (46.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 191.88 GiB used: 5.55 GiB (2.9%) fs: ext4 dev: /dev/sda4 
  ID-3: swap-1 size: 18.63 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 43.2 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/git-core-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/git-core/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/microsoft-prod.list 
  1: deb [arch=amd64,arm64,armhf] https://packages.microsoft.com/ubuntu/19.10/prod eoan main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages tricia main upstream import backport
  2: deb http://artfiles.org/ubuntu.com bionic main restricted universe multiverse
  3: deb http://artfiles.org/ubuntu.com bionic-updates main restricted universe multiverse
  4: deb http://artfiles.org/ubuntu.com bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/spotify.list 
  1: deb http://repository.spotify.com stable non-free
  Active apt repos in: /etc/apt/sources.list.d/steam.list 
  1: deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
  2: deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
  Active apt repos in: /etc/apt/sources.list.d/vscode.list 
  1: deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
Info:
  Processes: 299 Uptime: 9h 51m Memory: 15.63 GiB used: 2.95 GiB (18.9%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 

User avatar
mikaelrask
Level 4
Level 4
Posts: 237
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Steam won't start after installation

Post by mikaelrask »

hmm begin to run out of ides's but meaby try a reinstall of steam, second check the firewall and see so no rule is set so the firewall is blocking steam.
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.33-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 19.3
Kernel 4.15.0.101-generic
Ram 4 gb

eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Re: Steam won't start after installation

Post by eppok »

Well i think this is the end of my short and rough ride with Linux Mint. It's just all too buggy and the small pros over Windows for programming stuff isn't really worth the struggle.

I may give Ubuntu one last shot though.

User avatar
jp14
Level 3
Level 3
Posts: 166
Joined: Wed May 01, 2019 4:47 pm
Location: Zud-Afrika

Re: Steam won't start after installation

Post by jp14 »

eppok wrote:
Tue May 19, 2020 12:25 pm
Well i think this is the end of my short and rough ride with Linux Mint. It's just all too buggy and the small pros over Windows for programming stuff isn't really worth the struggle.

I may give Ubuntu one last shot though.
it's not all too buggy , iv'e installed LM about a year ago coming from windows and had about zero problems ,apart from asking for help now and again ,just because linux is new to me and it's a little learning curve.
i wouldn't put down LM as buggy cause you fail to get steam working. I also installed steam awhile back with no problem.
BTW,out of curiosity,seeing as so many people here have troubles with this and that,i wondered over to windows 10 forums...people there have just as much problems :mrgreen: just saying...
LM 19.3 Xfce


Cause I like things neat and simple

User avatar
jp14
Level 3
Level 3
Posts: 166
Joined: Wed May 01, 2019 4:47 pm
Location: Zud-Afrika

Re: Steam won't start after installation

Post by jp14 »

Image
LM 19.3 Xfce


Cause I like things neat and simple

eppok
Level 1
Level 1
Posts: 15
Joined: Fri May 15, 2020 9:00 am

Re: Steam won't start after installation

Post by eppok »

jp14 wrote:
Tue May 19, 2020 2:25 pm
it's not all too buggy , iv'e installed LM about a year ago coming from windows and had about zero problems ,apart from asking for help now and again ,just because linux is new to me and it's a little learning curve.
i wouldn't put down LM as buggy cause you fail to get steam working. I also installed steam awhile back with no problem.
BTW,out of curiosity,seeing as so many people here have troubles with this and that,i wondered over to windows 10 forums...people there have just as much problems :mrgreen: just saying...
Not everything and it sure has its upsides but not being able to use the full .NET Framework (knew that beforehand though) and now Steam is kind of a dealbreaker for me :( Not much of a help seeing Windows user having the same problems :mrgreen:

Code: Select all

ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2020-05-19 21:12:36] Startup - updater built Nov 23 2016 01:05:42
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
That's the error i get after trying it your way.

User avatar
mikaelrask
Level 4
Level 4
Posts: 237
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: Steam won't start after installation

Post by mikaelrask »

try with this and see if this fix it: public/steambootstraploader_english.txt errors.
-downloaded & ran Steam.deb fro the homepage
-enabled nvidia restricted drivers and repository
-installed the xfonts-100dpi package via Synaptic
from this thread

https://steamcommunity.com/app/221410/d ... 617372623/
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: nvidia 2070 super
Ram 16 GB
Kernel: 5.4.0.33-generic
kubuntu 20.04

Laptop:
CPU Intel(R) Core(TM) i5-245m
cinnamon 19.3
Kernel 4.15.0.101-generic
Ram 4 gb

User avatar
FabioMorales
Level 1
Level 1
Posts: 38
Joined: Wed May 20, 2020 11:44 pm
Location: aguascalientes mexico
Contact:

Re: Steam won't start after installation

Post by FabioMorales »

You try get steam page: https://store.steampowered.com/about/
I was start steam show up work fine :wink:

Post Reply

Return to “Software & Applications”