Cannot get Rhythmbox to become my default player at all.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Cannot get Rhythmbox to become my default player at all.

Post by Duysterwald »

Hello everyone,

I have stumbled across a peculiar issue that should have been easy to remedy (even for me as a newbie to Linux Mint), but which for some reason has appeared to be impossible to fix so far. :?

The problem is as follows: upon install, Totem was the default player for mp3 files. I soon found Rhythmbox to be a much more pleasant music player, however - so I decided to turn that program into my default player. Thus, I went to Control Center -> Preferred Applications and set Rhythmbox as my default player in the Multimedia tab. Unfortunately, after doing so, when I clicked on a mp3 file in my Music folder, the mp3 would be opened with Totem, not with Rhythmbox. :? So, then, I tried an other way (which I have used regularly in Windows XP as well): I right-clicked the mp3 file and then selected "Open with" and then I selected "Open with a different application" and then I selected Rhythmbox from the list of applications. But unfortunately, after doing so, any mp3 I clicked on would still open with Totem rather than Rhythmbox. I even tried right-clicking -> "Open with" -> "Open with Rhythmbox", but that would just open the mp3 with Rhythmbox and not make Rhythmbox the default player for all mp3's.

I have looked into the Preferences for both Rhythmbox and Totem, but I have failed to find an option where I can check a box for "Make [insert name of the music player] as my default player."

I was also unable to find a solution to this problem on Google, so now I'm turning to you guys in the hope that you know how I can fix this. :) Perhaps there is a special command for it that I can type in the Terminal? I know simply uninstalling Totem might be a solution, by the way, but I would rather keep it for playing videos - I just don't want it to be my default player for music. :)

By the way, I use the 64-bit version of Linux Mint 7 "Gloria" (with Gnome), if that is any help. :)

Well, thank you very much in advance for any advice and tips that you can offer. :)
User avatar
lagagnon
Level 7
Level 7
Posts: 1879
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Cannot get Rhythmbox to become my default player at all.

Post by lagagnon »

Menu, Computer, Edit, Preferences, Media, (set Rhythmbox in the appropriate places)
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: Cannot get Rhythmbox to become my default player at all.

Post by Duysterwald »

lagagnon wrote:Menu, Computer, Edit, Preferences, Media, (set Rhythmbox in the appropriate places)
Thank you for your suggestion, but this unfortunately did not work also. :( I selected Rhythmbox for everything that was related to audio, but my mp3's are still opened with Totem whenever I click on any of them. :?
User avatar
optimize me
Level 5
Level 5
Posts: 625
Joined: Wed Jun 03, 2009 5:25 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by optimize me »

I had the same problem a while back with trying to make VLC my default video player. For the life of me I couldn't make it work. Then, one day, quite out of nowhere, all my files started opening in VLC. I hadn't restarted X, hadn't rebooted... To this day I don't know why it works.

One thing I did back then, that you haven't indicated whether you've tried it or not, was to edit /etc/gnome/defaults.list by finding all instances of the extensions I wanted played by VLC and replacing totem.desktop with vlc.desktop.

After you try that (replacing vlc.desktop with your player of choice, obviously), throw in a reboot just for good measure, and see what happens.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by DrHu »

If you prefer using Rhythmbox, why not just uninstall the one you don't want to use :Totem

If it didn't work, remember you have to re-login for the next desktop session to take effect, and use your settings.
User avatar
optimize me
Level 5
Level 5
Posts: 625
Joined: Wed Jun 03, 2009 5:25 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by optimize me »

DrHu wrote:If you prefer using Rhythmbox, why not just uninstall the one you don't want to use :Totem

If it didn't work, remember you have to re-login for the next desktop session to take effect, and use your settings.
IIRC, uninstalling Totem causes problems all across the board - the most noticeable being no more Firefox media (video & audio playback) plugins. I think it's all tied in to mplayer and gstreamer.

I could be remembering wrong.. it's been a while since I tried it, but I think Totem (and mplayer) are wound into the gnome desktop pretty tightly.

I suppose it never hurts to try, though.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
gibbs1984
Level 5
Level 5
Posts: 802
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: Cannot get Rhythmbox to become my default player at all.

Post by gibbs1984 »

All I do is right click the file (.mp3), Properties > Open With tab > Then select Rhythmbox from there, this then makes Rhythmbox my default player for that associated file, granted I have to repeat this with each different type of file, not that I have many different ones.
Linux Mint 19.0 (Cinnamon) 64bit.
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by DrHu »

You can take out (uninstall) totem and totem-plugins without affecting mint meta main, which would be removed if you take out totem-xine or totem-common; also affects mplayer
--since I don't use totem; I decided to remove these two items; prefer vlc, instead of mplayer or xine..
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: Cannot get Rhythmbox to become my default player at all.

Post by Duysterwald »

optimize me wrote:I had the same problem a while back with trying to make VLC my default video player. For the life of me I couldn't make it work. Then, one day, quite out of nowhere, all my files started opening in VLC. I hadn't restarted X, hadn't rebooted... To this day I don't know why it works.

One thing I did back then, that you haven't indicated whether you've tried it or not, was to edit /etc/gnome/defaults.list by finding all instances of the extensions I wanted played by VLC and replacing totem.desktop with vlc.desktop.

After you try that (replacing vlc.desktop with your player of choice, obviously), throw in a reboot just for good measure, and see what happens.
Thank you for the tip - I hadn't heard of that possibility yet! :D One problem arised while carrying out your advice, however - when it was time for me to save the changes made in defaults.list, I got an error message saying that I did not have the rights to make any changes to defaults.list. I was never asked for a password (so it's not like the file was protected), so I suppose I'm going to have to try to become root via the terminal and then edit defaults.list via the terminal. I unfortunately don't know how to go about that - I guess it's going to be gksudo something (path to the file?). :o :oops:
DrHu wrote:If you prefer using Rhythmbox, why not just uninstall the one you don't want to use :Totem
Like I already mentioned in my beginning post, I don't want to uninstall Totem because I would like to use it for playing videos. :)
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by DrHu »

Duysterwald wrote:Like I already mentioned in my beginning post, I don't want to uninstall Totem because I would like to use it for playing videos
I didn't see that, but nevertheless..
That (removing totem, totem-plugins), doesn't affect totem-xine, the totem movie player..
User avatar
optimize me
Level 5
Level 5
Posts: 625
Joined: Wed Jun 03, 2009 5:25 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by optimize me »

Duysterwald wrote:Thank you for the tip - I hadn't heard of that possibility yet! :D One problem arised while carrying out your advice, however - when it was time for me to save the changes made in defaults.list, I got an error message saying that I did not have the rights to make any changes to defaults.list. I was never asked for a password (so it's not like the file was protected), so I suppose I'm going to have to try to become root via the terminal and then edit defaults.list via the terminal. I unfortunately don't know how to go about that - I guess it's going to be gksudo something (path to the file?). :o :oops:
You're on the right track:

Code: Select all

gksudo gedit /etc/gnome/defaults.list
It's a good habit to form to be sure and make a backup of it (and, really, any system file) before you start editing.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: Cannot get Rhythmbox to become my default player at all.

Post by Duysterwald »

optimize me wrote:
Duysterwald wrote:Thank you for the tip - I hadn't heard of that possibility yet! :D One problem arised while carrying out your advice, however - when it was time for me to save the changes made in defaults.list, I got an error message saying that I did not have the rights to make any changes to defaults.list. I was never asked for a password (so it's not like the file was protected), so I suppose I'm going to have to try to become root via the terminal and then edit defaults.list via the terminal. I unfortunately don't know how to go about that - I guess it's going to be gksudo something (path to the file?). :o :oops:
You're on the right track:

Code: Select all

gksudo gedit /etc/gnome/defaults.list
It's a good habit to form to be sure and make a backup of it (and, really, any system file) before you start editing.
Thank you for the code. ;) I was now able to edit and save everything, but after a reboot and doing exactly what you did (when you were trying to get VLC to be your default player), every mp3 I click on is still opened with Totem. :evil: I think I'm going to give up, as I don't know what else I've got left to do. I hope, though, that the Linux Mint team will fix this bug via the automatic system update or in the next Linux Mint release. :) At the very least, both Rhythmbox and Totem should have a tab in their Preferences menu where one can select which file types must be associated with the player, as for example Winamp has by default.
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by DrHu »

http://content.techrepublic.com.com/234 ... 598-6.html
http://linuxowns.wordpress.com/2008/05/ ... lications/
Is there anything in gconf-edit, for mp3 that assigns it to totem ?
  • alt F2
  • gksu gconf-edit
    --Edit TAB, find mp3
Hill Street Blues "Let's be careful out there"
User avatar
linuxviolin
Level 8
Level 8
Posts: 2082
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Re: Cannot get Rhythmbox to become my default player at all.

Post by linuxviolin »

DrHu wrote:Hill Street Blues "Let's be careful out there"
Hill Street Blues ? Hey, good reference! :lol:
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: Cannot get Rhythmbox to become my default player at all.

Post by Duysterwald »

Thank you for the links, I'm going to give them a try when I have more time later this week. :)
DrHu wrote:Is there anything in gconf-edit, for mp3 that assigns it to totem ?
  • alt F2
  • gksu gconf-edit
    --Edit TAB, find mp3
Hill Street Blues "Let's be careful out there"
I wouldn't know, actually, since gconf-edit doesn't start up for me, even if I open it in a terminal. :? And yes, I followed your exact instructions. :) Perhaps I need to be root for it to open?
User avatar
optimize me
Level 5
Level 5
Posts: 625
Joined: Wed Jun 03, 2009 5:25 pm

Re: Cannot get Rhythmbox to become my default player at all.

Post by optimize me »

Duysterwald wrote:
Thank you for the links, I'm going to give them a try when I have more time later this week. :)
DrHu wrote:Is there anything in gconf-edit, for mp3 that assigns it to totem ?
  • alt F2
  • gksu gconf-edit
    --Edit TAB, find mp3
Hill Street Blues "Let's be careful out there"
I wouldn't know, actually, since gconf-edit doesn't start up for me, even if I open it in a terminal. :? And yes, I followed your exact instructions. :) Perhaps I need to be root for it to open?
it's gconf-editor. don't use gksu, either. if you do, you end up editing settings for the root user.
AMD Phenom II X6 1045T 2.8GHz 8GB DDR3 RAM ATI Radeon HD6970
User avatar
DonPolo883
Level 1
Level 1
Posts: 17
Joined: Wed Mar 25, 2009 8:50 am
Location: Fuerteventura, Spain

Re: Cannot get Rhythmbox to become my default player at all.

Post by DonPolo883 »

As posted earlier, it is quite simple, I tried for an age to get VLC as my default MP$ player then: rght click over an mp4, properties, and check the box you prefer. If it ain't there add it.works for me....
User avatar
atlef
Level 4
Level 4
Posts: 306
Joined: Sun Nov 18, 2007 8:20 am
Location: Stavanger NORWAY

Re: Cannot get Rhythmbox to become my default player at all.

Post by atlef »

There is also the "preferred applications" in the Preferences menu. Try that as well.

atlef.
Post Reply

Return to “Software & Applications”