[SOLVED] Login Manually

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

[SOLVED] Login Manually

Post by macbeto »

Hi,
Is there a way yo login manually with Linux Mint that only you have to input your password, not the user name?
I only have one username, and it is a nonsense to type it any time when I login.
My Mac only requests me the password, not the username, and I was wondering if there is a way to skip it
Thanks.
Last edited by Moem on Sun Jun 28, 2020 5:15 am, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: Login Manually

Post by fromWinToLin »

I believe that's the default method? Which version of Linux Mint?

Check under Settings > Administrator > Login Window > Users

"Allow manual login" and "Hide the user list" should both be disabled.

Whomever was the most recently signed-in user should be selected by default, and all you need to enter is your password. There's no need to enter the username as well.
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

Hi,
I am using LM 19.2 Cinnamon.
I have both parameters unabled and my username is selected in the default username field, but with that setup after a boot it start automatically without need to type user/pass. Only when I delete the default username the system asks my for user/pass when booting, not just the password.
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

I have to tell that when Ininstalled the OS I selected the automatic start, and I have been working that way for long, login automatically, but sometimes I tryed to change it to start manually, but typing both user and password is a stopper for my, if that were only tye password I will accept.
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: Login Manually

Post by fromWinToLin »

login-settings.png
Do your settings look exactly like this?
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

Yes, it is my setup except the username is not empty. With tjis setup my system boot automatocally.
If I empty the username field I have to login typing username and password, not just the password.
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: Login Manually

Post by fromWinToLin »

Can you paste the contents of: /etc/lightdm/users.conf


You can view it in the default text editor with this command:

Code: Select all

xed /etc/lightdm/users.conf

Mine looks like this:

Code: Select all

[UserList]
minimum-uid=500
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin

This is going to sound obvious, but have you rebooted since making the above changes? Your login screen should look like so:
Image
Last edited by fromWinToLin on Sat Jun 27, 2020 3:56 pm, edited 2 times in total.
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

Actually I dont have any file called users.conf in that path, only a file named 70-linuxmint.conf.
Yes, any change done in this configurations was followed by a reboot, but is good to ask, most of the issues are small things like not rebooting.
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: Login Manually

Post by fromWinToLin »

macbeto wrote:
Sat Jun 27, 2020 2:48 pm
Actually I dont have any file called users.conf in that path
My mistake! The correct path is: /etc/lightdm/users.conf

While you're at, in terms of pasting contents, can you paste the contents of the following file as well: /etc/lightdm/lightdm.conf
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

Firstly I have to say thank you very much for all this support, I really appreciate it.
My users.conf is this one:

Code: Select all

[UserList]
minimum-uid=500
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin
And here is the file lightdm.conf

Code: Select all

/etc/lightdm$ more /etc/lightdm/lightdm.conf
[Seat:*]
autologin-guest=false
autologin-user-timeout=0
greeter-show-manual-login=false
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: Login Manually

Post by fromWinToLin »

macbeto wrote:
Sat Jun 27, 2020 6:11 pm
And here is the file lightdm.conf

Code: Select all

/etc/lightdm$ more /etc/lightdm/lightdm.conf
[Seat:*]
autologin-guest=false
autologin-user-timeout=0
greeter-show-manual-login=false
Delete the two autologin lines, and reboot. See if that helps.

When you say you need to type in the username and password, can you explain it further? Are you clicking on a button that prompts for a username? Are these TWO fields that you type into on the same screen without a "step by step" process?

This is peculiar, as it's not acting how the default login process works.

UPDATE: Maybe take a photo of the login screen immediately after a reboot?
macbeto
Level 2
Level 2
Posts: 50
Joined: Tue Jan 29, 2019 5:04 am

Re: Login Manually

Post by macbeto »

Thank you very much fromWintoLin, that did the trick. I deleted the lightdm.conf file and created again with the same info and after restarting it didnt ask for the user (it shows the default one), just for the password, which it helps me a lot.
Yes, before in the input box it showed the leyend username, and when you typed it and was ok, the same box changed the leyend to password, and after typing it entered the system. Now it shows the username by default (like your screenshot) and in the input box asks straight for the password.
Linux is amasing.
Really appreciate all your support and patience.
Cheers.
fromWinToLin
Level 2
Level 2
Posts: 87
Joined: Thu Nov 19, 2009 11:53 am

Re: [SOLVED] Login Manually

Post by fromWinToLin »

You're most welcome, macbeto!

I usually don't post here often, mostly lurk. Though I must say that the Linux Mint community is one of the nicest out there. We understand we're all here to use and enjoy our computers: not to show off our level of knowledge, or condescend over each other, or dismiss questions and problems, or expect end-users to grasp cryptic scripting and programming.

Glad it's working for you now! Perhaps changing user/login settings left residual lines in your config files, which caused the strange login screen behavior. Hopefully it doesn't happen with Linux Mint 20 and beyond. At least we now know where to investigate if it does occur again. ;)
Post Reply

Return to “Software & Applications”