Graphic is laggy in Linux Mint 20 Cinnamon

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
vanphong1310
Level 1
Level 1
Posts: 8
Joined: Mon Feb 26, 2018 1:52 am

Graphic is laggy in Linux Mint 20 Cinnamon

Post by vanphong1310 »

VLC (flatpak) and Celluloid random freeze a bit when I play video (only video, not program).
I run glmark2 to test GPU and all animations have same problem like playing video.
Same problem with Supertuxkart (flatpak).
Unigine Heaven 4.0 with GPU (Nvidia), when I set graphic to ultra, it is smoothly at ~50fps. If I set graphic to low, fps run at ~100 but it will random freeze a bit like playing video.
I tested all program above with GPU Intel and Nvidia, in all GPU profile (power saving/performance/on-demand).
My laptop infomation: https://termbin.com/yk9w

User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2538
Joined: Mon Aug 27, 2012 10:17 pm

Re: Graphic is laggy in Linux Mint 20 Cinnamon

Post by Kadaitcha Man »

vanphong1310 wrote:
Fri Jul 10, 2020 6:47 am
I tested all program above with GPU Intel and Nvidia, in all GPU profile (power saving/performance/on-demand).
Does it make any difference in performance mode if you go to nVidia Settings > X Server Display Configuration > Advanced... and enable Force Full Composition Pipeline"?
It's pronounced kad-eye-cha, not kada-itcha.

vanphong1310
Level 1
Level 1
Posts: 8
Joined: Mon Feb 26, 2018 1:52 am

Re: Graphic is laggy in Linux Mint 20 Cinnamon

Post by vanphong1310 »

I don't have this option!?!
Attachments
Screenshot from 2020-07-10 20-19-17.png
Screenshot from 2020-07-10 20-19-09.png

vanphong1310
Level 1
Level 1
Posts: 8
Joined: Mon Feb 26, 2018 1:52 am

Re: Graphic is laggy in Linux Mint 20 Cinnamon

Post by vanphong1310 »

Kadaitcha Man wrote:
Fri Jul 10, 2020 7:08 am
vanphong1310 wrote:
Fri Jul 10, 2020 6:47 am
I tested all program above with GPU Intel and Nvidia, in all GPU profile (power saving/performance/on-demand).
Does it make any difference in performance mode if you go to nVidia Settings > X Server Display Configuration > Advanced... and enable Force Full Composition Pipeline"?
Thank you for your suggestion. Although I don't have this option, I notice that the selection PRIME Display have a attribute Synchronization=Off, I research in Google and find this post PRIME and PRIME Synchronization, after read it, I think I need turn on PRIME Synchronization. Creating .conf file in /etc/modprobe.d follow this answer https://askubuntu.com/a/1024499/949042 isn't work, but adding the parameter nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT like this https://askubuntu.com/a/1048488/949042 work.
After reboot, it make a hugo difference.
With Synchronization=Off
Screenshot from 2020-07-10 23-47-34.png
With Synchronization=On
Screenshot from 2020-07-10 21-57-47.png
Now I can play everything smoothly with Nvidia card (performance mode).
Additionally, I need to confirm my Intel card in power saving mode is work fine, the only problem is it don't have enough power to play 4k@60fps video (it can do that in windows 10) or supertuxkart max settings.

Post Reply

Return to “Software & Applications”