Can't remove foreign package libffi6 after Ulyana upgrade

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Russels Silverware
Level 1
Level 1
Posts: 1
Joined: Sat Jul 11, 2020 6:11 pm

Can't remove foreign package libffi6 after Ulyana upgrade

Post by Russels Silverware »

I've upgraded my 19.3 installation to 20, but there's one remaining foreign package that I can't safely remove: libffi6. If I do, then when I reboot and login I get a black screen.

I have the package libffi7 installed. apt and Update Manager say all installed packages are up to date. I've run apt autoremove. apt install -f shows no problems. Software Sources lists no more foreign packages that can be downgraded.

Here's a partial inxi:

Code: Select all

System:    Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.6 
           wm: muffin 4.6.2 dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           1: deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner
Post Reply

Return to “Software & Applications”