Solved Lost windows 10/mint 19.3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Solved Lost windows 10/mint 19.3

Post by Steampipe »

running perfectly for 2 years on both OS. Lost grub2 and could not boot into either system. Finally got windows running again and am using mint on bootable usb drive. Tried all the fixes I could find, still cant get grub2 and mint back. I did have to rebuild windows mbr if that helps. would appreciate any help
http://paste.ubuntu.com/p/s3ZNytxtyY/
Last edited by Steampipe on Wed Aug 19, 2020 9:32 am, edited 1 time in total.
User avatar
AndyMH
Level 14
Level 14
Posts: 5469
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Lost windows 10/mint 19.3

Post by AndyMH »

Check your BIOS boot order, looks like grub and mint are on sdc
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

thanks, but i did that. Get absolutely nothing .
User avatar
AndyMH
Level 14
Level 14
Posts: 5469
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Lost windows 10/mint 19.3

Post by AndyMH »

So sdc is the first device in your boot list and you have boot mode set to legacy?
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

Yes, adc boots first. UEFI
User avatar
AndyMH
Level 14
Level 14
Posts: 5469
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Lost windows 10/mint 19.3

Post by AndyMH »

mint is installed in legacy mode on sdc
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

I'll have to double check that. So try it in legacy and see. Will that affect windows booting ?
Thank you
linux-rox
Level 5
Level 5
Posts: 840
Joined: Sun Jul 19, 2020 9:17 pm

Re: Lost windows 10/mint 19.3

Post by linux-rox »

Steampipe wrote:
Mon Aug 03, 2020 3:32 pm
Will that affect windows booting ?
Well, Mint in BIOS mode can't chain boot Windows in UEFI mode. OTOH, if you only plug in the USB drive when you to boot that, maybe not a problem. Depends on whether the firmware adapts on the fly, based on what's trying to boot.
User avatar
AndyMH
Level 14
Level 14
Posts: 5469
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Lost windows 10/mint 19.3

Post by AndyMH »

Win is installed in UEFI mode, you have an EFI partition on sda2. The only way you will be able to boot win is pressing whatever key it is on boot to get into the bios boot screen (F10 on a thinkpad) to select the windows boot loader. grub will not find win when linux has been installed in legacy.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

Thanks for your reply. The part that confuses me is that I have been dual booting that way for almost 2 years.And its worked perfectly. Grub2 showed both OS.......
linux-rox
Level 5
Level 5
Posts: 840
Joined: Sun Jul 19, 2020 9:17 pm

Re: Lost windows 10/mint 19.3

Post by linux-rox »

Obviously you're doing something differerntly, or broke something in the course of the repairs.
You've not described anything, really, so no way to tell why you're having trouble now. Good luck.
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

Sorry about that. I have lost the ability to dual boot into my mint 19.3 . I have tried many of the online Grub2 repairs (SuperGrub2 & Rescatux). EasyBcd dosnt even show a Linux installation. Gparted shows the dedicated linux drive and its partions. What i'am trying to do is be able to boot into mint without having to reinstall and lose all my software. PS, was getting the black screen "minimal Bash Like line" error at first not even getting that now. Also, got this error when I ran fdisk -l
Partition 1 does not start on physical sector boundary.
Thanks for your help.....
User avatar
AndyMH
Level 14
Level 14
Posts: 5469
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Lost windows 10/mint 19.3

Post by AndyMH »

Steampipe wrote:
Fri Aug 07, 2020 10:49 am
Sorry about that. I have lost the ability to dual boot into my mint 19.3 .
Partition 1 does not start on physical sector boundary.
Thanks for your help.....
Do you get grub and then not boot mint, can you still boot into win from grub?
What is the boot mode currently set in BIOS - legacy or UEFI. If UEFI then mint won't boot - installed in legacy and vice-versa for win.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
BG405
Level 8
Level 8
Posts: 2415
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Lost windows 10/mint 19.3

Post by BG405 »

Think you'd need to enable UEFI + CSM for that to work. Your Mint (from the report) is installed on a MBR disk whereas both others are GPT. AFAIK you can't install or run Mint in UEFI mode on an MBR disk.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

I don't see the grub,boots straight into windows even if i set the Linux drive first
Steampipe
Level 1
Level 1
Posts: 17
Joined: Sun Apr 08, 2018 1:21 pm

Re: Lost windows 10/mint 19.3

Post by Steampipe »

Bit the bullet and reinstalled mint. All is calm again... :) Thanks for everyone's help.
User avatar
BG405
Level 8
Level 8
Posts: 2415
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Solved Lost windows 10/mint 19.3

Post by BG405 »

Sorry didn't see a reply notification. Glad it's now OK; think reinstall was the best option in this case as it would have been a complicated process transferring the Mint install to a GPT disk & then converting it to use (U)EFI mode.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Post Reply

Return to “Software & Applications”