Can't install programs - dependency errors

Questions about applications and software
Forum rules
Before you post please read how to get help
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Can't install programs - dependency errors

Post by evrndw »

I'm new to the Linux world, sorry if this is a noob question.

Apparently, my Linux Mint won't allow me to install the dependencies needed for some programs, namely Cherrytree and Audacity. I tried via command-line and .deb packages, and followed the correct steps for each.

The outputs are these:

Code: Select all

cherrytree : Depends: python-dbus but it is not going to be installed
              Depends: python-enchant but it is not installable
              Depends: python-chardet but it is not going to be installed
              Depends: python-gtk2 (>= 2.16) but it is not installable
              Depends: python-gtksourceview2 but it is not installable
              Recommends: python-appindicator but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Code: Select all

audacity : Depends: audacity-data (= 2.3.3-1build1) but it is not going to be installed
            Depends: libflac++6v5 (>= 1.3.1) but it is not going to be installed
            Depends: libid3tag0 (>= 0.15.1b) but it is not going to be installed
            Depends: libmad0 (>= 0.15.1b-3) but it is not going to be installed
            Depends: libportaudio2 (>= 19+svn20101113-2~) but it is not going to be installed
            Depends: libportsmf0v5 but it is not going to be installed
            Depends: libsuil-0-0 (>= 0.8.0~dfsg0) but it is not going to be installed
            Depends: libvamp-hostsdk3v5 (>= 2.9.0) but it is not going to be installed
            Depends: libwxbase3.0-0v5 (>= 3.0.4+dfsg) but it is not going to be installed
            Depends: libwxgtk3.0-gtk3-0v5 (>= 3.0.4+dfsg-10~) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Anyone know how to fix this? Thanks in advance.
RIH
Level 5
Level 5
Posts: 816
Joined: Sat Aug 22, 2015 3:47 am

Re: Can't install programs - dependency errors

Post by RIH »

Have you tried doing what the error message suggests, i.e. putting

Code: Select all

apt --fix-broken install
into a terminal.
If so, what did that produce??

p.s. any special reason that you did not install these from the Software Manager??
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

Yes, it just returns the "help" results - this doesn't seem to be a recognizable command by apt or apt-get.

The Software Manager shows the same dependency errors.
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

I think that command needs sudo:

Code: Select all

 sudo apt --fix-broken install 
Or try:

Code: Select all

 sudo dpkg --configure -a 

Code: Select all

 sudo apt install -f 
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

sleeper12 wrote:
Sat Aug 08, 2020 11:13 pm

Code: Select all

 sudo apt --fix-broken install 
This one still doesn't work.
sleeper12 wrote:
Sat Aug 08, 2020 11:13 pm

Code: Select all

 sudo dpkg --configure -a 
This returned:

Code: Select all

sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of cherrytree:
 cherrytree depends on python-dbus; however:
  Package python-dbus is not installed.
 cherrytree depends on python-enchant; however:
  Package python-enchant is not installed.
 cherrytree depends on python-chardet; however:
  Package python-chardet is not installed.
 cherrytree depends on python-gtk2 (>= 2.16); however:
  Package python-gtk2 is not installed.
 cherrytree depends on python-gtksourceview2; however:
  Package python-gtksourceview2 is not installed.

dpkg: error processing package cherrytree (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cherrytree
sleeper12 wrote:
Sat Aug 08, 2020 11:13 pm

Code: Select all

 sudo apt install -f 
And this returned:

Code: Select all

sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  cherrytree
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 3.107 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 339315 files and directories currently installed.)
Removing cherrytree (0.39.4-0) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
Apparently there were Cherrytree files in the system that were removed with this last command. I tried reinstalling it, but still nothing.
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

See this post for installing CherryTree on Mint 20.

EDIT: There's a newer Testing version than is available in that link, here: https://www.giuspen.com/software/cherry ... _amd64.deb
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

Try this for Cherrytree:

Code: Select all

sudo apt-get purge cherrytree 
apt-get clean 
apt-get install cherrytree 
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

sleeper12 wrote:
Sat Aug 08, 2020 11:48 pm
Try this for Cherrytree:
There's still no focal version available via the repos. I think it'll be there soon.
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

MrEen wrote:
Sat Aug 08, 2020 11:50 pm
sleeper12 wrote:
Sat Aug 08, 2020 11:48 pm
Try this for Cherrytree:
There's still no focal version available via the repos. I think it'll be there soon.
Ok, I'm not familiar with either cherrytree or audacity. Would that be the case for audacity too?
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

MrEen wrote:
Sat Aug 08, 2020 11:45 pm
See this post for installing CherryTree on Mint 20.

EDIT: There's a newer Testing version than is available in that link, here: https://www.giuspen.com/software/cherry ... _amd64.deb
Yes, that's where I downloaded the .deb package from. It seems to be an issue with python, look at what it says:

Code: Select all

dpkg: dependency problems prevent configuration of cherrytree:
 cherrytree depends on python-dbus; however:
  Package python-dbus is not installed.
 cherrytree depends on python-enchant; however:
  Package python-enchant is not installed.
 cherrytree depends on python-chardet; however:
  Package python-chardet is not installed.
 cherrytree depends on python-gtk2 (>= 2.16); however:
  Package python-gtk2 is not installed.
 cherrytree depends on python-gtksourceview2; however:
  Package python-gtksourceview2 is not installed.
  
It can't find these packages python-dbus, python-enchant, python-chardet, python-gtk2 and python-gtksourceview2.
And this is just the case for Cherrytree, with Audacity it shows other packages that can't be found.

And the system is freshly installed and up-to-date, I followed all necessary steps after installation.
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

No. Audacity has a version in the focal repos. Of course, it's not the newest version available that so many people seem to think they need, but it should be stable.
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

evrndw wrote:
Sat Aug 08, 2020 11:59 pm

It can't find these packages python-dbus, python-enchant, python-chardet, python-gtk2 and python-gtksourceview2.
And this is just the case for Cherrytree, with Audacity it shows other packages that can't be found.

And the system is freshly installed and up-to-date, I followed all necessary steps after installation.
I don't have 20 installed, so what does this return:

Code: Select all

apt policy python-dbus python-enchant python-chardet python-gtk2 python-gtksourceview2
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

sleeper12 wrote:
Sat Aug 08, 2020 11:48 pm
Try this for Cherrytree:

Code: Select all

sudo apt-get purge cherrytree 
apt-get clean 
apt-get install cherrytree 
Same result. Cleansed files in the system but couldn't install due to dependencies
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

evrndw wrote:
Sun Aug 09, 2020 12:03 am
sleeper12 wrote:
Sat Aug 08, 2020 11:48 pm
Try this for Cherrytree:

Code: Select all

sudo apt-get purge cherrytree 
apt-get clean 
apt-get install cherrytree 
Same result. Cleansed files in the system but couldn't install due to dependencies
Ok, so try what MrEen said for cherrytree.
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

MrEen wrote:
Sun Aug 09, 2020 12:01 am
evrndw wrote:
Sat Aug 08, 2020 11:59 pm

It can't find these packages python-dbus, python-enchant, python-chardet, python-gtk2 and python-gtksourceview2.
And this is just the case for Cherrytree, with Audacity it shows other packages that can't be found.

And the system is freshly installed and up-to-date, I followed all necessary steps after installation.
I don't have 20 installed, so what does this return:

Code: Select all

apt policy python-dbus python-enchant python-chardet python-gtk2 python-gtksourceview2
Returned:

Code: Select all

apt policy python-dbus python-enchant python-chardet python-gtk2 python-gtksourceview2
python-dbus:
  Installed: (none)
  Candidate: 1.2.16-1build1
  Version table:
     1.2.16-1build1 500
        500 http://ubuntu.c3sl.ufpr.br/ubuntu focal/universe amd64 Packages
python-enchant:
  Installed: (none)
  Candidate: (none)
  Version table:
python-chardet:
  Installed: (none)
  Candidate: 3.0.4-4build1
  Version table:
     3.0.4-4build1 500
        500 http://ubuntu.c3sl.ufpr.br/ubuntu focal/universe amd64 Packages
        500 http://ubuntu.c3sl.ufpr.br/ubuntu focal/universe i386 Packages
python-gtk2:
  Installed: (none)
  Candidate: (none)
  Version table:
python-gtksourceview2:
  Installed: (none)
  Candidate: (none)
  Version table:
  
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

Maybe this will help for audacity:

Code: Select all

sudo apt-get purge audacity
apt-get clean 
apt-get install audacity 
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

Okay, what version is the .deb file you're using. You can use your file manager to copy it, then paste in the terminal and that will give the full name (along with the unneeded path.)

And did you try the Software Manager for Audacity? Or Synaptic Package Manager?
User avatar
MrEen
Level 22
Level 22
Posts: 15097
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

sleeper12 wrote:
Sun Aug 09, 2020 12:09 am
Maybe this will help for audacity:

Code: Select all

sudo apt-get purge audacity
apt-get clean 
apt-get install audacity 
I'm hoping that'll work! :wink:
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

sleeper12 wrote:
Sun Aug 09, 2020 12:09 am
Maybe this will help for audacity:

Code: Select all

sudo apt-get purge audacity
apt-get clean 
apt-get install audacity 
Worked for Audacity! Thanks :)
sleeper12
Level 13
Level 13
Posts: 4687
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

evrndw wrote:
Sun Aug 09, 2020 12:12 am
sleeper12 wrote:
Sun Aug 09, 2020 12:09 am
Maybe this will help for audacity:

Code: Select all

sudo apt-get purge audacity
apt-get clean 
apt-get install audacity 
Worked for Audacity! Thanks :)
Ok, good. That's half the battle. :lol:
Post Reply

Return to “Software & Applications”