Can't install programs - dependency errors

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 22
Level 22
Posts: 15319
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

That link I gave in my EDIT has these as the depends:

Code: Select all

Depends: libgtkmm-3.0-1v5 (>= 3.24.0), libgtksourceviewmm-3.0-0v5 (>= 3.18.0), libxml++2.6-2v5 (>= 2.40.0), libsqlite3-0 (>= 3.5.9), libgspell-1-2 (>= 1.8.2), libcurl4 (>= 7.16.2), libatkmm-1.6-1v5 (>= 2.24.0), libc6 (>= 2.14), libcairo2 (>= 1.15.8), libcairomm-1.0-1v5 (>= 1.12.0), libgcc-s1 (>= 3.0), libglib2.0-0 (>= 2.39.4), libglibmm-2.4-1v5 (>= 2.54.0), libgtk-3-0 (>= 3.16.2), libpango-1.0-0 (>= 1.14.0), libpangomm-1.4-1v5 (>= 2.42.0), libsigc++-2.0-0v5 (>= 2.8.0), libstdc++6 (>= 9), libxml2 (>= 2.7.4)
I don't think you're using the correct .deb file.
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

MrEen wrote:
Sun Aug 09, 2020 12:10 am
Okay, what version is the .deb file you're using. You can use your file manager to copy it, then paste in the terminal and that will give the full name (along with the unneeded path.)
The .deb is the most recent version from Cherrytree website, "cherrytree_0.39.4-0_all.deb". Is this what you asked?

I tried copying it's name to the terminal and the same happened, a Python dependency problem when installing. It shows this when trying to open it:

Code: Select all

cherrytree
bash: /usr/bin/cherrytree: /usr/bin/python: bad interpreter: No such file or directory
And yet it says Python is already installed and up-to-date
User avatar
MrEen
Level 22
Level 22
Posts: 15319
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

That's the wrong .deb file. As it says on the site, that doesn't work for Ubuntu 20.04 (which Mint 20 is based on.)

Use the direct link from the forum page I linked to, or the one in my EDIT earlier. Here is mine again:
https://www.giuspen.com/software/cherry ... _amd64.deb
evrndw
Level 1
Level 1
Posts: 9
Joined: Sat Aug 08, 2020 9:15 pm

Re: Can't install programs - dependency errors

Post by evrndw »

MrEen wrote:
Sun Aug 09, 2020 12:27 am
That's the wrong .deb file. As it says on the site, that doesn't work for Ubuntu 20.04 (which Mint 20 is based on.)

Use the direct link from the forum page I linked to, or the one in my EDIT earlier. Here is mine again:
https://www.giuspen.com/software/cherry ... _amd64.deb
Worked :)

Damn, that was right in my face... When I opened your previous link, as it redirected me to the download page I thought it was the same file.
This Linux world is still a bit alien to me haha

Thanks for your help guys, and for your patience

Best wishes ;)
User avatar
MrEen
Level 22
Level 22
Posts: 15319
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

I'm glad everything is sorted out now.

Enjoy! :D
sleeper12
Level 13
Level 13
Posts: 4769
Joined: Thu May 25, 2017 3:22 pm

Re: Can't install programs - dependency errors

Post by sleeper12 »

Teamwork, luv it! :D
User avatar
MrEen
Level 22
Level 22
Posts: 15319
Joined: Mon Jun 12, 2017 8:39 pm

Re: Can't install programs - dependency errors

Post by MrEen »

sleeper12 wrote:
Sun Aug 09, 2020 12:41 am
Teamwork, luv it! :D
Ditto.

Now I gotta hit the sack. Turn the lights out when you leave please. :mrgreen:
User avatar
I2k4
Level 5
Level 5
Posts: 688
Joined: Thu Feb 02, 2012 8:33 pm

Re: LM20 and Cherrytree - dependency errors

Post by I2k4 »

Don't see it mentioned anywhere, but as of October the LM20-compatible Cherrytree v. 0.99x .deb package has been upgraded from beta to the stable version.

PPA is:
sudo add-apt-repository ppa:giuspen/ppa

.deb for LM20. Important: read the Changelog and comments for this new 0.99.x regarding earlier versions of Mint/Ubuntu e.g. LM19.x
https://www.giuspen.com/cherrytree/#downl

The new stable 0.99.16 installed from the above PPA to update the beta 0.99.6 with no problem on LM20 XFCE
Last edited by I2k4 on Thu Oct 22, 2020 8:57 pm, edited 1 time in total.
TRUST BUT VERIFY any advice from anybody, including me. Mint/Ubuntu user since 10.04 LTS. LM20 64 bit XFCE (Dell 1520). Dual booting LM20 XFCE / Win7 (Lenovo desktop and Acer netbook).
User avatar
AndyMH
Level 14
Level 14
Posts: 5025
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Can't install programs - dependency errors

Post by AndyMH »

Your problem is that mint 20 has abandoned python2 so any application that depends on python2 packages is going to fail. Audacity is not one of them, it can be installed from software manager. Cherrytree cannot be installed in LM20 from sw manager. Generally the solution is to hunt down the missing dependences and download them from the bionic repositories (using wget) and install them. fslint is another example, depends on python-gtk2 and python-glade2.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Post Reply

Return to “Software & Applications”