Page 1 of 1

STUCK with ACL and unreadable files

Posted: Wed Aug 12, 2020 6:47 am
by fernandocabral
Once upon a time I tried setting privileges using ACL. It did work as intended. Latter I revoked the privileges running setfacl -bn *. Life went on. Three days ago I tried to install a software package I had in that particular directory I had set the ACL privileges to. Than I found out no matter what I do, neither sudo apt install ./package, nor sudo dpkg -i ./package will be able to read the deb file.

apt-get output:

Code: Select all

Impossible to find package X.deb (*)
dpkg output:

Code: Select all

dpkg: error: cannot access file 'X.deb': No permission (*)

(*) messages translated back into English, so they might be a little different from the original message.

The same error occurs with every .deb file I try. Now, if I copy them to a different directory, then it works.

PS1 - It seems I can't get rid of the xxxxxxxxx+ (plus) sign on the files. I copy them out, the plus sign goes aways; I copy them in, the plus sign comes back.

PS -- Could it be an issue with gocryptfs or Sirikali? The troublesome directory is a gocryptfs-mounted directory.

Re: STUCK with ACL and unreadable files

Posted: Wed Aug 12, 2020 8:16 am
by Hoser Rob
Don't know but this is the 1st hit from searching "ubuntu acl":