Page 1 of 1

[SOLVED] cinnamon-session update broke a start up app. err: Failed to change directory

Posted: Thu Aug 13, 2020 1:47 pm
by shockedquartz
EDIT: Fix was update *.desktop Path=<home path>

Hello all. Mint 19.3 cinnamon user.

I just updated (using the GUI system update manager (mintUpdate 5.5.9)) cinnamon-session from
cinnamon-session:amd64/tricia 4.4.1+tricia
cinnamon-session:amd64/tricia 4.4.2+tricia

..and now one of my startup apps is failing to launch.

me@me:/var/log/apt# egrep "cinnamon" history.log

Code: Select all

Upgrade: cinnamon-session:amd64 (4.4.1+tricia, 4.4.2+tricia), libnemo-extension1:amd64 (4.4.2+tricia, 4.4.3+tricia), gir1.2-meta-muffin-0.0:amd64 (4.4.2+tricia, 4.4.4+tricia), nemo-data:amd64 (4.4.2+tricia, 4.4.3+tricia), nemo:amd64 (4.4.2+tricia, 4.4.3+tricia), muffin-common:amd64 (4.4.2+tricia, 4.4.4+tricia), cinnamon-session-common:amd64 (4.4.1+tricia, 4.4.2+tricia), libmuffin0:amd64 (4.4.2+tricia, 4.4.4+tricia), nemo-dbg:amd64 (4.4.2+tricia, 4.4.3+tricia), muffin:amd64 (4.4.2+tricia, 4.4.4+tricia), gir1.2-nemo-3.0:amd64 (4.4.2+tricia, 4.4.3+tricia), muffin-dbg:amd64 (4.4.2+tricia, 4.4.4+tricia)
me@me:/var/log/# egrep lmc syslog | tail -1

Code: Select all

Aug 13 09:53:49 me cinnamon-session[31668]: WARNING: t+11.52826s: Could not launch application 'lmc.desktop': Unable to start application: Failed to change to directory “” (No such file or directory)
Now one of my auto start apps (lan messenger (lmc)) will not start that is in ~/.config/autostart
I created this autostart *.desktop file using the "Startup Applications" applet in Mint.

This has been working fine for about a year now. I tested the same thing in a Mint 19.3 Virtualbox VM and got the same results.
It seems that downgrading back to cinnamon-session 4.4.1 is a dependency nightmare and fails.

Any assistance would be appreciated.
Thank you.

Re: cinnamon-session update broke a start up app. err: Failed to change directory ""

Posted: Thu Aug 13, 2020 2:16 pm
by shockedquartz
Well I solved it by updating the path var in the *.desktop file.

Code: Select all

vi /home/me/.config/autostart/lmc.desktop
I noticed that Path= had no argument
I tried tilde ~ but it didn't like that either. or anything with double or single qoutes
So I put the literal path of my user home directory. No idea if it will take ENV or bash_rc/profile variables.

Code: Select all

and that solved it going forward.

I'll leave this post up so if some one else has this issue going forward they can try the above.
It seems the new cin-session daemon is a bit more picky than the last one :lol: