Mint 20 & HPLIP

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
lsemmens
Level 11
Level 11
Posts: 3547
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Mint 20 & HPLIP

Post by lsemmens »

My printer is an Hp1312nfi which is connected to my network. I think I had it printing properly after the upgrade to mint 20 but cannot be certain of that (shows how often I print stuff). It was scanning properly, that I do know. I tried to print a two page report and ended up with pages of gibberish. So, back to square one. I tried a test print and got more of the same. OK, restart computer and printer, no joy. Re-installed HPLIP and now I can't even see the printer! Do I have to downgrade to 19.3 as this is the only issue that I am having with mint 20?

I'll have to download 19.3 again, but that is not a biggie.

Code: Select all

System:
  Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ProBook 470 G2 
  v: A3009DD10303 serial: <filter> 
  Mobo: Hewlett-Packard model: 2249 v: KBC Version 67.24 serial: <filter> 
  BIOS: Hewlett-Packard v: M74 Ver. 01.09 date: 01/26/2015 
Battery:
  ID-1: BAT0 charge: 46.7 Wh condition: 47.5/47.5 Wh (100%) 
  model: Hewlett-Packard Primary status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19155 
  Speed: 986 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 887 2: 853 
  3: 942 4: 931 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: AMD Topaz PRO [Radeon R5 M255] vendor: Hewlett-Packard 
  driver: amdgpu v: kernel bus ID: 0a:00.0 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.0-42-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 08:00.0 
  IF: enp8s0 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM43228 802.11a/b/g/n driver: wl 
  v: kernel port: 4000 bus ID: 09:00.0 
  IF: wlo1 state: up mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 53.23 GiB (22.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS250G2B0A size: 232.89 GiB 
Partition:
  ID-1: / size: 227.74 GiB used: 53.23 GiB (23.4%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 38.5 C mobo: N/A gpu: amdgpu temp: 127 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 215 Uptime: 39m Memory: 7.19 GiB used: 1.26 GiB (17.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38
Fully mint Household
Out of my mind - please leave a message
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Mint 20 & HPLIP

Post by pbear »

Unlikely to be a compatibility problem. My guess would be that it's something in your network setup.* Not confident downgrading will solve that, so hang tight for a day or so to see whether someone who can help troubleshoot notices the thread.

* I know next-to-nothing about networks, but have observed this scenario in prior threads about HPLIP.
User avatar
diapason
Level 4
Level 4
Posts: 375
Joined: Mon Apr 09, 2018 5:31 pm
Location: Montevideo, Uruguay

Re: Mint 20 & HPLIP

Post by diapason »

There have been a number of threads about LM20 and HP printers. In the main, the indication is that in LM20 there is no longer any need for HPLIP as the printer will now work without drivers and as plug and play when connected via a USB port.

I have a HP Office Jet 150 all in one which needed the HPLIP drivers to work in LM18 and LM19. Now in LM20, it works without HPLIP and it looks as though during the upgrade process from LM19.3 to LM20, the HPLIP drivers were, in fact, removed. Maybe they're no longer compatible.

I would be inclined to completely remove HPLIP and the printer then reboot and try it as plug and play. If that doesn't help then, as pbear said, hang around until someone with the right diagnostic skills jumps in.
diapason
Linux Mint 20 Cinnamon
Evolution Mail Client 3.38.0
Post Reply

Return to “Software & Applications”