Python-gtk Problems After Mint 20 Upgrade

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
zaileion
Level 4
Level 4
Posts: 286
Joined: Sun Jan 25, 2015 6:01 pm

Python-gtk Problems After Mint 20 Upgrade

Post by zaileion »

So I don't know about Python and how it affects the OS.

I upgraded to Mint 20 Mate from 19.3 and am getting some errors regarding Python-gtk when I try to launch CodeWeavers Corssover, and Screenlets.

I found a site that says how to fix this issue https://linuxconfig.org/install-python- ... ossa-linux but wanted to make sure it isn't going to break anything if i follow the instructions and subsequently follow these instructions to switch to Python 2 https://linuxconfig.org/ubuntu-20-04-py ... ch-manager

Here is the error i get when i try to run Corssover:

Code: Select all

Some errors may prevent CrossOver Linux from working correctly:
* Could not load the D-Bus Python modules.
* Could not load the GTK+ Python modules.

You may be able to fix them by running one of the following commands as root:
Arch Linux             	pacman -Syu pygtk python2-dbus
Debian <= 6            	apt-get install python-dbus python-gtk2
Debian <= 7            	apt-get install python-dbus python-gtk2
Fedora                 	dnf install dbus-python pygtk2
Mandriva               	/usr/sbin/urpmi dbus-python pygtk2.0
openSUSE               	zypper install dbus-1-python python-gtk
Post Reply

Return to “Software & Applications”