Android Studio license issue and failure to recognise installation

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
WM20
Level 1
Level 1
Posts: 1
Joined: Sat Oct 17, 2020 6:46 pm

Android Studio license issue and failure to recognise installation

Post by WM20 »

Hi there, I am running Flutter on a Linux Mint 19.1. I have installed both Flutter and Android Studio via Snap. As I search for errors I get the following issues, which I am struggling to find a solution for:

$ flutter doctor -v
[✓] Flutter (Channel stable, 1.22.2, on Linux, locale en_US.UTF-8)
• Flutter version 1.22.2 at /home/thiago/snap/flutter/common/flutter
• Framework revision 84f3d28555 (2 days ago), 2020-10-15 16:26:19 -0700
• Engine revision b8752bbfff
• Dart version 2.10.2

[!] Android toolchain - develop for Android devices (Android SDK version 30.0.2)
• Android SDK at /home/thiago/Android/Sdk
• Platform android-30, build-tools 30.0.2
• Java binary at: /usr/bin/java
• Java version Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
✗ Android license status unknown.
Run `flutter doctor --android-licenses` to accept the SDK licenses.
See https://flutter.dev/docs/get-started/in ... roid-setup for
more details.

[!] Android Studio (not installed)
• Android Studio not found; download from
https://developer.android.com/studio/index.html
(or visit https://flutter.dev/docs/get-started/in ... roid-setup
for detailed instructions).

[!] Connected device
! No devices available

! Doctor found issues in 3 categories.

So how do I fix that license issue? Why the Android Studio is said to be not installed when as matter of fact it is?
Post Reply

Return to “Software & Applications”