BUG in Thunderbird, probably. What now?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
SaintDanBert
Level 4
Level 4
Posts: 317
Joined: Sat Feb 20, 2010 4:04 pm
Location: Austin, TX USA

BUG in Thunderbird, probably. What now?

Post by SaintDanBert »

I'm playing with Google™ email address tricks and think that I found a bug with Thunderbird™. I cannot discover how to post it to a T'bird or Mozilla® page so I'm posting the details here. see Google Tricks.

Using T'bird v68.10.0 (64-bit), I select Kirk's account and send a message to Scotty. Both are Gmail addresses.

Code: Select all

     FROM:  Kirk <kirk@gmail.com>
     TO:      "scotty+stuff@gmail.com"
     ...
     
I used the T'bird GUI but my example reads like a terminal session.
I needed to quotation marks in the TO address so that T'bird would ignore the plus sign.

After a brief delay, I'm told that there is a new message for Scotty.
I open that message and see:

Code: Select all

     FROM:  kirk@gmail.com
     TO:      scotty+stuff@gmail.com
     ...

This is exactly what I expected. I also look at Kirk's SentMail folder
and see the same FROM and TO information.

On detailed inspection, Scotty's inbox shows the new message as:

Code: Select all

     Correspondent:  scotty+stuff@gmail.com
Huh? What?

Since Kirk sent the message, shouldn't his email or address book entry show as the Correspondent?

Looking at Kirk's other SentMessage data
  • none are empty(blank)
  • all contain the TO email address or address book Contact Name
As a further test, I send a message using not-tricky email addressing:

Code: Select all

     FROM:  kirk@gmail.com
     TO:      scotty@gmail.com
     ...
     
Kirks SentMail folder shows a blank(empty) Correspondent field.
Scotty Inbox also shows a blank(empty) Correspondent field.
REPLY etc all direct messages correctly.
Huh?
What?

DISCUSSION
What is going on with the Correspondent field contents. Is it something to do with the fact that both Kirk@gmail.com and Scotty@gmail.com are configured as accounts in the same T'bird session? Is something else going on?

Does the email trick "scotty+stuff@gmail.com" cause the message to be stored so that any REPLY comes back to Scotty -- because of the embedded plus-sign?

Clearly, the email trick is causing something to go haywire. Sadly, the what is going on is not clear beyond "it's not working" beyond message delivery.

Thanks in advance,
~~~ 0;-Dan
Covington, LA
All government spending, regardless of the motives, uses YOUR money!
Any government extensive enough to give you anything that you want is also
powerful enough to take everything that you have.
User avatar
JoeFootball
Level 9
Level 9
Posts: 2894
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: BUG in Thunderbird, probably. What now?

Post by JoeFootball »

SaintDanBert wrote: I cannot discover how to post it to a T'bird or Mozilla® page ...
https://bugzilla.mozilla.org
Post Reply

Return to “Software & Applications”