Page 1 of 1

[SOLVED]PAN Newsreader - spelling check stopped working

Posted: Fri Nov 20, 2020 7:48 am
by JLC17
As per subject, really.

Pan 0.143

Have logged as a bug with Pan central, but wondered if anyone else had noticed it, or knew of a fix/workaround ???

Re: PAN Newsreader - spelling check stopped working

Posted: Wed Dec 02, 2020 7:40 am
by JLC17
Time for a bump :(

Re: [SOLVED]PAN Newsreader - spelling check stopped working

Posted: Thu Dec 03, 2020 7:30 am
by JLC17
So a lot to unpick here. I will post a copy of this with the bug report at PAN towers - not that anyone read it.

1) By design PAN is pretty pants. No suggestion anywhere in the preferences that you need optional modules for additional functionality. No modules. No function. So just ticking "check spelling" does absolutely nothing if you haven't got the modules installed. Of course you don't get any warning (and why isn't the checkbox greyed out if the module isn't available ????)

2) You need "gtkspelling" installed. Good luck with getting your distros version. Mint doesn't seem to come with it - which is why my PAN didn't spellcheck.

3) Ah ! Not quite so easy tiger. Don't mess around trying to install from synaptic - it still won't work (no matter what combinations you try as there are GTK2 and 3 versions, plus python-gtkspelling etc etc).

4) I fixed mine by downloading building and installing gtkspell-2.0.16 (you will probably need to install intltool from synaptic). Read the output of configure carefully - you may need a few dependencies.

5) then download and build Pan-0.146. Make sure you've uninstalled Pan from synaptic if it's still installed (personally I'd be amazed you stuck with it this long).

6) install Pan from the built version.

Now when you load and run it, you should find the spellchecker works.

I'm well aware that I probably could have found a way to install gtkspell and delve into the guts of the system to make the installed Pan see it. However it only took 10 minutes to do it my way.