[Solved] mintUpdate error code (2)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
timbol
Level 1
Level 1
Posts: 37
Joined: Tue Sep 05, 2017 2:27 pm

[Solved] mintUpdate error code (2)

Post by timbol »

Hello

(Marking this one SOLVED-seems to be a network/server issue, thanks)

LM 20.1 mintUpdate 5.7.3 failed to make an update this morning (sorry, I didn't note the error)
I acknowledged the error dialogue and then it told me that the system is up to date, which it wasn't because it couldn't obtain/open the packages properly
history.log says (my bold),
Start-Date: 2021-02-16 04:42:16
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 88080392 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmpo08r0cei
Requested-By: tim (1000)
Upgrade: gnupg-utils:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), friendly-recovery:amd64 (0.2.41, 0.2.41ubuntu0.20.04.1), gpg-wks-client:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gnupg-l10n:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpg-wks-server:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpg:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), dirmngr:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpgv:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gnupg:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpg-agent:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpgconf:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1), gpgsm:amd64 (2.2.19-3ubuntu2, 2.2.19-3ubuntu2.1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2021-02-16 04:42:19
I reinstalled the packages in Synaptic, which hasn't prompted mintUpdate to change
Thanks for any help
Last edited by timbol on Thu Feb 18, 2021 1:00 am, edited 2 times in total.
mikeflan
Level 5
Level 5
Posts: 887
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: mintUpdate error code (2)

Post by mikeflan »

I don't see the problem here. Yes, I do see the unhelpful error code.
Please explain this:
it couldn't obtain/open the packages properly
Do you get the normal output entering this in a terminal? :

Code: Select all

dpkg -s xviewer
timbol
Level 1
Level 1
Posts: 37
Joined: Tue Sep 05, 2017 2:27 pm

Re: mintUpdate error code (2)

Post by timbol »

Thanks mikeflan
Please explain this:
it couldn't obtain/open the packages properly
Unfortunately I didn't make a note of the error dialogue, but it amounted to mintUpdate couldn't obtain/open the packages properly
Do you get the normal output entering this in a terminal?
Lots of lines with package details, dependencies, description, etc, but I guess that this is the one, "Status: install ok installed"
User avatar
Pjotr
Level 22
Level 22
Posts: 16145
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: mintUpdate error code (2)

Post by Pjotr »

Try this:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
If there are any errors in the output, post them in your reply.
Tip: 10 things to do after installing Linux Mint 20.1 Ulyssa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
timbol
Level 1
Level 1
Posts: 37
Joined: Tue Sep 05, 2017 2:27 pm

Re: mintUpdate error code (2)

Post by timbol »

I've completely removed the two packages (gpgv and friendly-recovery) that should have been updated this morning, shut down and cold boot restarted
Using Synaptic I reinstalled both and no problems reported
I then ran mintUpdate, clicked "refresh" and got this,
Failed to fetch http://packages.linuxmint.com/dists/ulyssa/InRelease Could not resolve ‘packages.linuxmint.com’Failed to fetch http://archive.ubuntu.com/ubuntu/dists/focal/InRelease Could not resolve ‘archive.ubuntu.com’Failed to fetch http://archive.ubuntu.com/ubuntu/dists/ ... /InRelease Could not resolve ‘archive.ubuntu.com’Failed to fetch http://archive.ubuntu.com/ubuntu/dists/ ... /InRelease Could not resolve ‘archive.ubuntu.com’Failed to fetch http://security.ubuntu.com/ubuntu/dists ... /InRelease Could not resolve ‘security.ubuntu.com’Failed to fetch http://archive.canonical.com/ubuntu/dis ... /InRelease Could not resolve ‘archive.canonical.com’Some index files failed to download. They have been ignored, or old ones used instead.
My network is working, so maybe a server problem with archive.ubuntu.com?
Last edited by timbol on Tue Feb 16, 2021 2:56 pm, edited 1 time in total.
timbol
Level 1
Level 1
Posts: 37
Joined: Tue Sep 05, 2017 2:27 pm

Re: mintUpdate error code (2)

Post by timbol »

Thanks Pjotr

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for tim:         
Hit:1 http://archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://archive.canonical.com/ubuntu focal InRelease
Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]        
Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]      
Get:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]     
Ign:6 http://packages.linuxmint.com ulyssa InRelease                           
Hit:7 http://packages.linuxmint.com ulyssa Release                             
Get:8 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [807 kB]
Get:10 http://archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [421 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [549 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [740 kB]
Fetched 2,841 kB in 2s (1,144 kB/s)                      
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libqt5designer5 libqt5help5 libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite
  libqt5test5 libqt5xml5 linux-hwe-5.8-headers-5.8.0-40
  python3-dbus.mainloop.pyqt5 python3-pyqt5 python3-sip
Use 'sudo apt autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
apt-get has ignored(??) the archive at 6 (above) but seems to be fine otherwise. Should I remove the excess packages? sudo apt autoremove gives me a choice
sleeper12
Level 15
Level 15
Posts: 5604
Joined: Thu May 25, 2017 3:22 pm

Re: mintUpdate error code (2)

Post by sleeper12 »

Yes, do:

Code: Select all

 sudo apt autoremove 
timbol
Level 1
Level 1
Posts: 37
Joined: Tue Sep 05, 2017 2:27 pm

Re: mintUpdate error code (2)

Post by timbol »

Thanks sleeper12
Done
Post Reply

Return to “Software & Applications”