Error installing and removing Midnight Commander

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 5
Joined: Tue Sep 22, 2009 3:31 am

Error installing and removing Midnight Commander

Postby evfung » Sun Oct 25, 2009 4:48 am

i tried installing Midnight Commander via Synaptic, but i got an error. However, the package was still marked as installed and when I tried to remove it, i get this error.

Setting up mc (2:4.6.2~git20080311-4ubuntu1) ...
update-alternatives: unable to make /usr/share/man/fr.UTF-8/man1/view.1.gz.dpkg-tmp a symlink to /etc/alternatives/ No such file or directory
dpkg: error processing mc (--configure):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

And the package stays marked, and whenever i try to install or remove other software this errors always shows up.
I'm using Gloria. Any ideas on how to remove this.

Level 23
Level 23
Posts: 18704
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Error installing and removing Midnight Commander

Postby Husse » Sun Nov 01, 2009 3:24 pm

/etc/alternatives/ No such file or directory

That's odd - I have it :) and it's a link to /usr/share/man/fr.UTF-8/man1/vim.1.gz
So first try - make that (sym)link - root permissions are needed of course
Second try and (more than) a bit dangerous

Code: Select all

apt purge -f mc
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Software & Applications”

Who is online

Users browsing this forum: austin.texas, candoursystems, pegasis and 12 guests