Sudden black theme on Chrome

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
vansloneker
Level 5
Level 5
Posts: 673
Joined: Sat Mar 17, 2018 6:10 am

Sudden black theme on Chrome

Post by vansloneker »

Since today Google Chrome browser -on my notebook with Mint 20.1- is displaying a black theme: black bars, black background to menu etc. I have not set it to this nor updated the system or Chrome prior.
When I open the settings the theme is normal. Changing the theme in settings or use system bars does not change it. I always start in and use incognito mode. Open a non-incognito window is as it always was. Could it be related to the incognito mode? As said, it didn't do this before.
I really don't like the black theme and want the normal theme to appear.
Unless stated otherwise Mint 20.1-64 XFCE
User avatar
vansloneker
Level 5
Level 5
Posts: 673
Joined: Sat Mar 17, 2018 6:10 am

Re: Sudden black theme on Chrome

Post by vansloneker »

Thanks for all the suggestions!

The inevitable just happened on my 20.2 desktop. Nobody seems to want the light theme so I searched for enabling dark theme and this got me to this workaround.

First installed a theme close to my preference: Pro Grey as the workaround does not work with Classic.
In the address bar enter chrome://flags
Search for and disable:
Allow widgets to inherit native theme from its parent widget.
and
Enable Incognito brand consistency in desktop.

This got me a normal address and tab bar, although still wit a black top bar. But at least it's less ghastly.
Unless stated otherwise Mint 20.1-64 XFCE
meistertek
Level 1
Level 1
Posts: 4
Joined: Wed Jan 08, 2020 3:24 pm

Re: Sudden black theme on Chrome

Post by meistertek »

This was driving me nuts as well. I have sort of a workaround. Right click in the top left corner next to your tabs. Click Use system title bar and borders. This helps in every mode except maximized, where the window frame disappears.

However if you go to chrome settings and type theme in the search bar you will see an button "Use GTK+" under Appearance, Theme. That fixed this issue on my system Linux Mint 20.3 Cinnamon
User avatar
trytip
Level 14
Level 14
Posts: 5235
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sudden black theme on Chrome

Post by trytip »

vansloneker wrote:
Fri Dec 03, 2021 9:09 am
since this is bumped, would be nice to see what it looks like now to see if there is script errors or just theme conflict.
chrome://flags/#enable-force-dark <<< this is what i used, second selection from bottom (selective inversion of everything) but not working quite well. some sites have perfect contrast, some are not readable.
reset your flags to default
Image
User avatar
vansloneker
Level 5
Level 5
Posts: 673
Joined: Sat Mar 17, 2018 6:10 am

Re: Sudden black theme on Chrome

Post by vansloneker »

meistertek wrote:
Fri Jan 14, 2022 9:01 pm
This was driving me nuts as well. I have sort of a workaround. Right click in the top left corner next to your tabs. Click Use system title bar and borders. This helps in every mode except maximized, where the window frame disappears.

However if you go to chrome settings and type theme in the search bar you will see an button "Use GTK+" under Appearance, Theme. That fixed this issue on my system Linux Mint 20.3 Cinnamon
I took me a lot of right clicking before I realized I should try to unmaximize the window and there this Use system title bar and borders showed up indeed. But it didn't change a thing for me.
Unless stated otherwise Mint 20.1-64 XFCE
meistertek
Level 1
Level 1
Posts: 4
Joined: Wed Jan 08, 2020 3:24 pm

Re: Sudden black theme on Chrome

Post by meistertek »

vansloneker is correct. I am sorry vansloneker, I didn't realize from the thread title that this issue only shows up in incognito mode. It must be a bug. Here is a screen capture of the issue, normal chrome on left, incognito on right. incognito continues to use dark theme widgets no matter what is set in chrome://flags

https://photos.app.goo.gl/qVgUavgiFzchSV3QA
User avatar
vansloneker
Level 5
Level 5
Posts: 673
Joined: Sat Mar 17, 2018 6:10 am

Re: Sudden black theme on Chrome

Post by vansloneker »

vansloneker wrote:
Fri Dec 03, 2021 9:09 am
Thanks for all the suggestions!

The inevitable just happened on my 20.2 desktop. Nobody seems to want the light theme so I searched for enabling dark theme and this got me to this workaround.

First installed a theme close to my preference: Pro Grey as the workaround does not work with Classic.
In the address bar enter chrome://flags
Search for and disable:
Allow widgets to inherit native theme from its parent widget.
and
Enable Incognito brand consistency in desktop.

This got me a normal address and tab bar, although still wit a black top bar. But at least it's less ghastly.
I just updated my notebook and now the above mentioned flags are gone and the incognito window is all black again.
Unless stated otherwise Mint 20.1-64 XFCE
User avatar
vansloneker
Level 5
Level 5
Posts: 673
Joined: Sat Mar 17, 2018 6:10 am

Re: Sudden black theme on Chrome

Post by vansloneker »

I just tested Chrome on Mint 21 for the dark incognito theme and yes it's still there.
I found the Material Incognito Light Theme that sheds some light on this issue by explaining google is forcing the black theme through it's entire range:
A theme that removes the dark Incognito Mode colour scheme from Chrome.

This theme is deprecated as Google has blocked all official capability to theme the Incognito window.

Chrome's incognito mode (lower-case i) has been turn into Incognito (upper-case I), treated as a Google brand, not just used in Chrome but across other products like Google Maps, Gboard and others. In order to maintain a strong brand consistency, Google uses the same grey motif to indicate that you are in Incognito, and they've taken this one step further by disabling all theme customisation for Incognito.

For the time being, you can temporarily reverse this by going to chrome://flags/#incognito-brand-consistency-for-desktop and setting the flag to Disabled. This will enable this theme to work once more. However, this flag will not stick around forever, and in the future when Google removes the flag, the theme will be disabled from working permanently.
On a Mint 20.3 system with a not recently updated Chrome I was able to install that theme and enable said flag and have a normal incognito window. This only for as long as it works and I don't update the system. Chrome is not my default browser but it comes in handy when Waterfox reaches it limitations.
On Mint 21 I'll probably drop Chrome entirely and use Firefox (with it's current ghastly Windows 10 theme...) as backup browser.
Unless stated otherwise Mint 20.1-64 XFCE
Post Reply

Return to “Software & Applications”