Opera as prefered browser in Mint 8 not working right.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
cdysthe
Level 3
Level 3
Posts: 111
Joined: Sun Oct 05, 2008 12:18 pm

Opera as prefered browser in Mint 8 not working right.

Post by cdysthe »

Hi,

I have Opera set as prefered browser in the "Preffered Applications" settings. When I click on links in other programs Opera is opened if it isn't already running. However, if Opera is running (like it is most of the time), nothing happens. No new tab is opened as I have it set to be. What could be wrong, and is there something I could do?

Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Opera as prefered browser in Mint 8 not working right.

Post by Husse »

No new tab is opened as I have it set to be
I don't know much about Opera but could the open a new tab be the problem and open a new window would work?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
cdysthe
Level 3
Level 3
Posts: 111
Joined: Sun Oct 05, 2008 12:18 pm

Re: Opera as prefered browser in Mint 8 not working right.

Post by cdysthe »

Husse wrote:
No new tab is opened as I have it set to be
I don't know much about Opera but could the open a new tab be the problem and open a new window would work?
I have figured this one out: To get Opera 10.x to look integrated in the Mint 8 desktop you need to open it like this:

'opera -systemstyle'

If the Opera is already opened with this switch the command for Opera in the Preffered Applications settings doesn't work. I have now set it to custom for browser using this command: opera '-systemstyle -newtab %s'

Post Reply

Return to “Software & Applications”