Unable to fix broken packages problem

Questions about applications and software
Forum rules
Before you post please read how to get help
mattsid1
Level 1
Level 1
Posts: 6
Joined: Wed Nov 18, 2009 11:35 pm

Unable to fix broken packages problem

Postby mattsid1 » Mon Jan 11, 2010 3:40 am

I just ran update manager and get the following message "Could not apply changes! Fix broken packages first" So I Googled the problem and tried the following fixes.

$ sudo dpkg --configure -a
Setting up glines (1:2.28.0-0ubuntu1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing glines (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up gnome-blackjack (1:2.28.0-0ubuntu1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing gnome-blackjack (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up libggz2 (0.0.14.1-1build1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing libggz2 (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up glchess (1:2.28.0-0ubuntu1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing glchess (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of ggzcore-bin:
ggzcore-bin depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
dpkg: error processing ggzcore-bin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libggzcore9:
libggzcore9 depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
dpkg: error processing libggzcore9 (--configure):
dependency problems - leaving unconfigured
Setting up gnobots2 (1:2.28.0-0ubuntu1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing gnobots2 (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of iagno:
iagno depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
iagno depends on libggzcore9 (>= 0.0.14.1); however:
Package libggzcore9 is not configured yet.
dpkg: error processing iagno (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libggzmod4:
libggzmod4 depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
libggzmod4 depends on libggzcore9 (>= 0.0.14.1); however:
Package libggzcore9 is not configured yet.
dpkg: error processing libggzmod4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnibbles:
gnibbles depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
gnibbles depends on libggzcore9 (>= 0.0.14.1); however:
Package libggzcore9 is not configured yet.
gnibbles depends on libggzmod4 (>= 0.0.14.1); however:
Package libggzmod4 is not configured yet.
dpkg: error processing gnibbles (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnect:
gnect depends on libggz2 (>= 0.0.14.1); however:
Package libggz2 is not configured yet.
gnect depends on libggzcore9 (>= 0.0.14.1); however:
Package libggzcore9 is not configured yet.
gnect depends on libggzmod4 (>= 0.0.14.1); however:
Package libggzmod4 is not configured yet.
dpkg: error processing gnect (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
glines
gnome-blackjack
libggz2
glchess
ggzcore-bin
libggzcore9
gnobots2
iagno
libggzmod4
gnibbles
gnect

AND

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
foobillard
0 upgraded, 0 newly installed, 1 to remove and 43 not upgraded.
12 not fully installed or removed.
After this operation, 1,384kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 142942 files and directories currently installed.)
Removing foobillard ...
dpkg (subprocess): unable to execute installed post-removal script: Exec format error
dpkg: error processing foobillard (--remove):
subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
foobillard
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I don't know where to go from here. Anyone?

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: Unable to fix broken packages problem

Postby Brian49 » Mon Jan 11, 2010 6:09 am

If you go into recovery mode at boot time, one of the menu items is "Try to repair broken packages". I have used this with success several times when my system was behaving strangely.


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 9 guests