How to install a LAMP server in Helena

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

How to install a LAMP server in Helena

Post by ckosloff »

How can I install a LAMP server on Helena Gnome?


ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Re: How to install a LAMP server in Helena

Post by ckosloff »

OK, I tried those instructions and those here too:
http://tuxtweaks.com/2009/10/install-la ... mic-koala/
basically I ran this command:
sudo apt-get install lamp-server^
which is supposed to do everything for you.
It did it on my netbook running Helena Gnome 32-bit.
However, on my laptop running Helena Gnome x64 it failed.
It does not install PHP properly, I get this error:
Fatal error: Call to undefined function phinfo() in /var/www/testing.php on line 1
Apache does work.
Yes, I did restart apache2.
Tried several reinstalls but nothing doing, always same error.
Does somebody know what is causing this?
PS. I used to have XAMPP for Linux installed on the x64 machine, but I uninstalled it completely, ran autoremove too.

BrianD
Level 4
Level 4
Posts: 313
Joined: Fri Feb 12, 2010 12:22 am
Location: Tallahassee, Florida, USA

Re: How to install a LAMP server in Helena

Post by BrianD »

ckosloff wrote:Fatal error: Call to undefined function phinfo() in /var/www/testing.php on line 1
...is that an exact quote of the error message, or did you type it into the message (and possibly make a mistake)? I ask because, if that's exactly what the error reads, then the problem is that there's a typo in the /var/www/testing.php program (on line 1): the function is called phpinfo() ...
need I say more??

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Re: How to install a LAMP server in Helena

Post by ckosloff »

of all the stupid embarrassing mistakes :oops:

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Re: How to install a LAMP server in Helena

Post by ckosloff »

Ok, so now everything is installed and working like a charm, including phpmyadmin.
However, I see that PHP version is 5.2.10-2ubuntu6.4
I would like to install PHP 5.3.2 recently released, how do I do that?

User avatar
RedWagon
Level 5
Level 5
Posts: 632
Joined: Tue May 26, 2009 6:41 pm

Re: How to install a LAMP server in Helena

Post by RedWagon »

However, I see that PHP version is 5.2.10-2ubuntu6.4
I would like to install PHP 5.3.2 recently released, how do I do that?
Unless there's a specific feature in 5.3.2 you really need, I'd just wait for the package in the repos to be updated.

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Re: How to install a LAMP server in Helena

Post by ckosloff »

Well, since this is a testing and development environment I am trying to anticipate ISPs moving forward to PHP 5.3.x, which is quite different from the 5.2.x branch.
I understand that most are still on 5.2.x, but I want to develop sites and make them backwards-compatible so I won't have sites breaking.

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Re: How to install a LAMP server in Helena

Post by ckosloff »

How can I install and enable mod_rewrite on this server?
Found it.
It is:
sudo a2enmod rewrite.
sudo /etc/init.d/apache2 restart
apache2ctl -M

User avatar
DataMan
Level 6
Level 6
Posts: 1234
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Midwest USA at /var/www
Contact:

Re: How to install a LAMP server in Helena

Post by DataMan »

The only way that I know of to install 5.3 is to recompile php and do a full install (not a fun type of activity). You can be pretty much assured that most hosting services will not roll out 5.3 in a timely fashion.

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015

User avatar
markfiend
Level 4
Level 4
Posts: 310
Joined: Wed Apr 15, 2009 2:56 pm
Location: Leeds, UK

Re: How to install a LAMP server in Helena

Post by markfiend »

DataMan wrote:The only way that I know of to install 5.3 is to recompile php and do a full install (not a fun type of activity). You can be pretty much assured that most hosting services will not roll out 5.3 in a timely fashion.

-DataMan
Believe it or not, I'm forced to use (at work) one hosting service that's still using php4 :evil:
Omnia mutantur, nihil interit.

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

Recompiling PHP with GD

Post by ckosloff »

You should recompile PHP --with-gd using the bundled GD library. See http://www.php.net/manual/en/image.setup.php.

I am getting this warning after installing Drupal on this local server.
Have been to php.net but it didn't help much.
What syntax should I use?

ckosloff
Level 3
Level 3
Posts: 149
Joined: Tue Jul 21, 2009 8:54 pm

File info extension

Post by ckosloff »

Want a reason to install 5.3?
Regarding the fileinfo() extension, from the PHP manual:
This extension is enabled by default as of PHP 5.3.0. Before this time, fileinfo was a PECL extension but is no longer maintained there.
Any ideas how to enable this extension?

Post Reply

Return to “Software & Applications”