*.txt files

Questions about applications and software
Forum rules
Before you post please read how to get help
sprocket_dk
Level 1
Level 1
Posts: 5
Joined: Fri Sep 21, 2007 8:39 am

*.txt files

Postby sprocket_dk » Fri Sep 21, 2007 10:34 am

Hej I can't seem to open txt files. When I double click on a txt file nothing happens. Am I missing some program here?

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: *.txt files

Postby scorp123 » Fri Sep 21, 2007 11:08 am

sprocket_dk wrote:Hej I can't seem to open txt files. When I double click on a txt file nothing happens. Am I missing some program here?
That's weird. Are you sure those files aren't empty? e.g. do they have a file length? Maybe it's just the file associations that got messed up? Do you use KDE or GNOME?

sprocket_dk
Level 1
Level 1
Posts: 5
Joined: Fri Sep 21, 2007 8:39 am

Postby sprocket_dk » Sat Sep 22, 2007 10:31 am

I'm using gnome. when I right click my desktop, make document and chose text file I can't enter it.

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Sun Sep 23, 2007 12:12 pm

Files with a .txt file association tend to be treated as executable text files but certainly something should happen....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sun Sep 23, 2007 12:43 pm

Husse wrote:Files with a .txt file association tend to be treated as executable text files
Huh??? On which OS and from which parallel Universe?

sprocket_dk
Level 1
Level 1
Posts: 5
Joined: Fri Sep 21, 2007 8:39 am

Postby sprocket_dk » Sun Sep 23, 2007 2:30 pm

I can get it to open with open office, but is'nt there a more ligt text editor. The one in my applications does'nt work. Maby I should reinstall it, but what the name of it?

User avatar
linuxviolin
Level 8
Level 8
Posts: 2071
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Postby linuxviolin » Sun Sep 23, 2007 3:10 pm

I have no problem to open the .txt files with the text editor...:wink: your problems are surprising, or I misunderstand you (that is always possible)
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Sun Sep 23, 2007 4:04 pm

scorp123 wrote:
Husse wrote:
Files with a .txt file association tend to be treated as executable text files
Huh??? On which OS and from which parallel Universe?

:):)
Most something.txt on my Mint, but much something.txt comes from my ntfs partition so that may be it...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sun Sep 23, 2007 4:10 pm

linuxviolin wrote: your problems are surprising, or I misunderstand you (that is always possible)
Pas de f***ing kidding, I had the very same thought :lol:

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sun Sep 23, 2007 4:13 pm

Husse wrote: something.txt comes from my ntfs partition so that may be it...
Yes, because there those files (and everything else) get the execute bit set unless you set the "noexec" parameter or use a proper Linux filesystem which is able to report the correct bit settings (rwx ..) to the system. This has not really something to do with the *.txt files being really 'executable' but rather how Linux is interpreting stuff from non-Linux filesystems.

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Mon Sep 24, 2007 6:38 am

Yaeh - that's it, but I've got some .txt files not coming from ntfs being like that too....
So much so that it's been annoying - but normal .txt don't - just checked
It was so much that I was beginning to think it was something with the .txt - and you don't use file extensions much in Linux....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Mon Sep 24, 2007 7:00 am

Husse wrote: Yaeh - that's it, but I've got some .txt files not coming from ntfs being like that too....
Maybe they originate from Windows or some other non-UNIX-like OS? Could be then that somehow that execute bit got preserved.

Husse wrote: So much so that it's been annoying

Code: Select all

 find . -name *.[Tt][Xx][Tt] -type f -print -exec chmod 644 {} \;


Return to “Software & Applications”

Who is online

Users browsing this forum: erko326 and 5 guests