SOLVED gnome-hearts under Daryna

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

SOLVED gnome-hearts under Daryna

Postby pashabear » Sat Nov 17, 2007 3:11 pm

I installed the gnome-hearts package using Synaptic, but it won't run. When I try from a terminal, here's what I get:

Code: Select all

** ERROR **: file hearts.c: line 859 (load_card_styles): assertion failed: (directory != NULL)
aborting...
Aborted (core dumped)

Any ideas?
Thanks
pb
Last edited by pashabear on Sun Nov 25, 2007 3:21 pm, edited 1 time in total.

Husse
Level 23
Level 23
Posts: 19595
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: gnome-hearts under Daryna

Postby Husse » Tue Nov 20, 2007 8:22 am

What does line 859 in hearts.c say?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Tue Nov 20, 2007 8:53 am

Husse wrote:What does line 859 in hearts.c say?


Don't know, can't find that file
pb

Husse
Level 23
Level 23
Posts: 19595
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: gnome-hearts under Daryna

Postby Husse » Tue Nov 20, 2007 11:28 am

Ok - then I'll have to study - found some other file ending in .c that does not exist
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: gnome-hearts under Daryna

Postby nick » Wed Nov 21, 2007 1:44 pm

Hi

Just a hunch, have you tried installing gnome-games data

"This package contains the data files, sound and pictures used by the
GNOME games."


Your line "load_card_styles" ?

Nick

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Wed Nov 21, 2007 5:04 pm

Have that package installed already. The gnome-games-extra-data package wasn't, but installing that didn't help.
pb

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: gnome-hearts under Daryna

Postby nick » Thu Nov 22, 2007 1:37 pm

Hi

Its posted as a bug in Gutsy:


http://www.mail-archive.com/ubuntu-bugs ... 43459.html

With the message...........** ERROR **: file hearts.c: line 859 (load_card_styles): assertion failed:
(directory != NULL)
aborting...
And Feisty

https://bugs.launchpad.net/ubuntu/+sour ... bug/108889

I can only suggest you "try" the source code

Sorry - (on Debian box at moment works OK)

Nick

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Fri Nov 23, 2007 10:11 am

Well, I'm trying the source code, but having trouble compiling.

First I needed to install g++ to get around the "C compiler cannot create executables" error.

Now I'm getting a "Can't find X includes. Please check your installation and add the correct paths!" error...

I'm googling around to see what I need to do with this, but don't find an easy answer.
pb

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Fri Nov 23, 2007 10:22 am

Well, installing the xorg-dev package got by that error, but am running into other errors... am on the verge of giving up.
pb

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: gnome-hearts under Daryna

Postby nick » Sat Nov 24, 2007 5:14 am

Hi

Try x-dev libx11-dev and (dont laugh), kdebase-dev (yes I think that is what you need :) ) Just been through it with another program with same message :)

Edit-Whoops, never saw your second post where you got by error message

Nick

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Sat Nov 24, 2007 9:07 am

I installed the packages you mentioned anyway, but still no go. Here's the error I get with ./configure now:

Code: Select all

checking for GNOME_HEARTS... configure: error: Package requirements (libgnomeui-2.0 gtk+-2.0 libglade-2.0 glib-2.0 gmodule-2.0) were not met:

No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'libglade-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_HEARTS_CFLAGS
and GNOME_HEARTS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

And I can't seem to resolve these. None of these (libgnomeui-2.0 gtk+-2.0 libglade-2.0 glib-2.0 gmodule-2.0) are available in Synaptic, at least under these names.
pb

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: gnome-hearts under Daryna

Postby nick » Sat Nov 24, 2007 11:40 am

Hi pb

Am on Debian box until I repair Mint box, But you could try
libgnomeui-devel package, not sure why GTK is not there

You could try config --"with set path to package" if they are not
in normal place.

Have you pkg-configure installed?

Nick

User avatar
pashabear
Level 3
Level 3
Posts: 109
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Re: gnome-hearts under Daryna

Postby pashabear » Sat Nov 24, 2007 4:08 pm

OK, that took care of that error, now on to another... This time it's a problem with python (it seems):

Code: Select all

checking for a Python interpreter with version >= 2.4... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking how to run the C preprocessor... gcc -E
checking for headers required to compile python extensions... not found
configure: error: could not find Python headers

Installed the package python2.4-dev, which is "Header files and a static library for Python" but that didn't help.
In answer to your query, I do have pkg-configure installed
pb

Edit: oops, I realised I installed the 2.4-dev package, whereas it was using the 2.5 version (not sure why they're both there and installed). Anyway, installing the python2.5-dev package did the trick.

So, a make and a make install later, and I'm in! Thanks a lot for the help. Hope this might be a help to someone, the process has been a learning experience for me, anyway! Hopefully they'll get the bugs worked out so it will be a simple synaptic install in the future.
pb

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Re: gnome-hearts under Daryna

Postby nick » Sat Nov 24, 2007 4:23 pm

HI

Glad you got there, have fun :)

Nick


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 4 guests