new - could not refresh the list of packages

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

new - could not refresh the list of packages

Post by boysha »

Hi,
I spent hours searching other posts with the same subject. I tries a few and I am back here to ask for help.
I am using Linux Mint 10 since it came out. Everything works great except that in the last week I am getting
a message: could not refresh the list of packages
I saved the result:
Failed to fetch http://ppa.launchpad.net/user/gwibber-d ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/gwibber-d ... ackages.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-gwibb ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-gwibb ... ackages.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-name/ ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-name/ ... ackages.gz 404 Not Found
Some index files failed to download, they have been ignored, or old ones used instead.

Can someone, please help me? Thank you in advance.

Also, although I use Mint fro several years, I am not in any way knowledgeable with Linux. I would like someone to help me and teach me
how can I remove those packages that are failing to be fetched. Thank you!

Cheers!

Neb
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

Try by changing the mirror.
Open UpdateManager (I guess it is called MintUpdate), then Edit > Software Sources > Download from: > other > select best server.

By doing that it will chose the best one for you, however it may be that it will chose the one you are already using. In this case select one from the list manually. After that check if it still gives errors.
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: new - could not refresh the list of packages

Post by boysha »

Thanks! I tried that before and I tried it now again. This is what I get again:

Failed to fetch http://ppa.launchpad.net/user/gwibber-d ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/gwibber-d ... ackages.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-gwibb ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-gwibb ... ackages.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-name/ ... Sources.gz 404 Not Found
Failed to fetch http://ppa.launchpad.net/user/ppa-name/ ... ackages.gz 404 Not Found
Some index files failed to download, they have been ignored, or old ones used instead.

If I could learn how to get rid of these packages, mint wouldn't look for them right?
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

As you can see here, the problem is that they do not exist, actually, the path is wrong:
http://ppa.launchpad.net/
Can you please give me the output of:

Code: Select all

cat /etc/apt/sources.list
we simply have to change the path with the correct one.
If you do not need them you can simply uncheck them at Software Sources > Other Software.
Last edited by exaeresis on Sun Jun 19, 2011 5:14 pm, edited 1 time in total.
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
Elisa

Re: new - could not refresh the list of packages

Post by Elisa »

If your mirror doesn't work, check/download the latest gwibber stuff, just use google or look here: http://packages.ubuntu.com/search?keywo ... ection=all
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: new - could not refresh the list of packages

Post by boysha »

What I did just a few minutes ago - I just unchecked those non existing sources...
Here is the result from the list:

neb@neb-mint10 ~ $ cat /etc/apt/sources.list
deb ftp://gd.tuwien.ac.at/linux/mint/packages/ julia main upstream import
deb http://archive.ubuntu.com/ubuntu/ maverick main restricted multiverse
deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted multiverse
deb http://security.ubuntu.com/ubuntu/ maverick-security main restricted multiverse
deb http://archive.canonical.com/ubuntu/ maverick partner
deb http://packages.medibuntu.org/ maverick free non-free

# deb http://archive.removed/ubuntu maverick-removed apps
# deb http://archive.removed/ubuntu maverick-removed games

# deb http://ppa.launchpad.net/corenominal/ubuntu gutsy main
# deb-src http://ppa.launchpad.net/corenominal/ubuntu gutsy main

deb-src ftp://gd.tuwien.ac.at/linux/mint/packages/ julia main upstream import
deb http://archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
# deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
# deb http://security.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
# deb http://archive.canonical.com/ubuntu/ maverick partner
# deb-src http://archive.canonical.com/ubuntu/ maverick partner
# deb http://packages.medibuntu.org/ maverick free non-free
# deb-src http://packages.medibuntu.org/ maverick free non-free

I assume I should get the right path to be able to download the ones that previously didn't work?
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

Uhm, even if you unchecked them it still gives an error?
I was talking about the gwibber one, the correct path should be:

Code: Select all

http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/maverick/main/binary-i386/Packages.gz
and

Code: Select all

http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/maverick/main/source/Sources.gz
The fact is that they are not in the list, probably because you unchecked them. But it should not give you an error at this point if they are not more considered.
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: new - could not refresh the list of packages

Post by boysha »

I think that you are right. I don't get an error any more because I unchecked those from the list.
However, I tried to ad them from your post as you are saying that it is the right path. It gave me an error when refreshed...
I am not sure what is going on.
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

My bad, I was thinking about the "old style" method. It was the correct path, but not what you had to add.
Undo what I said, go back to Software sources > other software > press add and write into it:

Code: Select all

ppa:gwibber-daily/ppa 
Last edited by exaeresis on Sun Jun 19, 2011 6:00 pm, edited 1 time in total.
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: new - could not refresh the list of packages

Post by boysha »

BINGO! That's good. Thank you. Now please, tell me where can I find what you just found for me if I need to in the future.
Thank you again!
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

They probably changed the PPA, therefore yours addressed to something that did not exist. I simply searched "PPA gwibber daily ubuntu maverick" on google and it brought me there:
https://launchpad.net/~gwibber-daily/+archive/ppa
and there you find it. The old style method consists simply by adding it to /etc/apt/sources.list, in this case what you should do is run:

Code: Select all

sudo gedit /etc/apt/sources.list
and add these lines:

Code: Select all

deb http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu maverick main 
deb-src http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu maverick main 
But actually, the way you did it is faster.

PS: did you notice that I modified the code? I copied the wrong one, what you had (that caused the 404 error) was "gwibber daily" not "gwibber team".
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
User avatar
boysha
Level 3
Level 3
Posts: 130
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: new - could not refresh the list of packages

Post by boysha »

Yes I did. But really - thank you so much. It was bothering me for a while and even that everything was working fine,
I knew that something was not quiet right. Those things keep me awake sometimes - weird.
Have a good one!
Neb
User avatar
exaeresis
Level 1
Level 1
Posts: 40
Joined: Sat May 21, 2011 4:34 am

Re: new - could not refresh the list of packages

Post by exaeresis »

Eheh, most of the times they are just little things, but until you do not understand what causes the problem, yes, these things keep you awake. :)
See you around!
We can only see a short distance ahead, but we can see plenty there that needs to be done - Alan Mathison Turing
Post Reply

Return to “Software & Applications”