wxWidgets ./configure error with Amule

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Yuhed
Level 1
Level 1
Posts: 12
Joined: Sat Jul 02, 2011 4:27 pm

wxWidgets ./configure error with Amule

Post by Yuhed »

Hello guys. I got some error after try ./configure for amule:

Code: Select all

checking for wx-config... no
configure: error: 
		wxWidgets must be installed on your system but wx-config
		script couldn't be found. Please check that wx-config is
		in path or specified by --with-wx-config=path flag, the
		directory where wxWidgets libraries are installed (returned
		by 'wx-config --libs' command) is in LD_LIBRARY_PATH or
		equivalent variable and wxWidgets version is 2.8.8 or above.
Any solution? ty...
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: wxWidgets ./configure error with Amule

Post by xenopeek »

It is looking for the application wx-config, and can not find it. Either you have it installed, but ./configure is looking in the wrong spot, or you do not have it installed.

Type "which wx-config" in the terminal to see if it is installed:

Code: Select all

$ which wx-config
On my system that gives an empty response, indicating it is not installed. Easy way to find the package it can be installed with, is just type wx-config in the terminal:

Code: Select all

$ wx-config
The program 'wx-config' can be found in the following packages:
 * libwxbase2.6-dbg
 * libwxbase2.6-dev
 * libwxbase2.8-dbg
 * libwxbase2.8-dev
 * libwxgtk2.6-dbg
 * libwxgtk2.6-dev
 * libwxgtk2.8-dbg
 * libwxgtk2.8-dev
Try: sudo apt-get install <selected package>
Your error message was saying it needed 2.8.8 or above, let's check for that:

Code: Select all

$ apt-cache show libwxbase2.8-dev
...output cut for brevity...
Version: 2.8.11.0-0ubuntu8
...output cut for brevity...
Looks good, so install this package and libwxgtk2.8-dev and try again:

Code: Select all

$ sudo apt-get install libwxgtk2.8-dev libwxbase2.8-dev
Try ./configure after that.
Image
Yuhed
Level 1
Level 1
Posts: 12
Joined: Sat Jul 02, 2011 4:27 pm

Re: wxWidgets ./configure error with Amule

Post by Yuhed »

That solved wxWidgets problem, but another problem appeared...

Code: Select all

checking for libupnp version >= 1.6.6... no (try to use --with-libupnp-prefix=PREFIX)
configure: WARNING:
        UPnP code has been disabled because libupnp >= 1.6.6 not found (try to use --with-libupnp-prefix=PREFIX).
checking for crypto++ version >= 5.1... no
configure: error: 
	Could not find crypto++ header file "cryptlib.h".
	Please try again with --with-crypto-prefix=/my_crypto_prefix
	(replace /my_crypto_prefix with a valid path to your crypto++
	installation directory).
:(
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: wxWidgets ./configure error with Amule

Post by xenopeek »

Check to see if you have that installed:

Code: Select all

$ dpkg -l | grep libupnp
ii  libupnp3                              1:1.6.6-5
You can see I have version 1.6.6-5 installed.
Image
Yuhed
Level 1
Level 1
Posts: 12
Joined: Sat Jul 02, 2011 4:27 pm

Re: wxWidgets ./configure error with Amule

Post by Yuhed »

xenopeek wrote:Check to see if you have that installed:

Code: Select all

$ dpkg -l | grep libupnp
ii  libupnp3                              1:1.6.6-5
You can see I have version 1.6.6-5 installed.
I have the same versions installed...
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: wxWidgets ./configure error with Amule

Post by xenopeek »

Perhaps you need the development libraries for this;

Code: Select all

sudo apt-get install libupnp3-dev
Image
Yuhed
Level 1
Level 1
Posts: 12
Joined: Sat Jul 02, 2011 4:27 pm

Re: wxWidgets ./configure error with Amule

Post by Yuhed »

xenopeek wrote:Perhaps you need the development libraries for this;

Code: Select all

sudo apt-get install libupnp3-dev
That fixed libupnp problem , now the only error (hope) is the crypto++ error:

Code: Select all

checking for libupnp version >= 1.6.6... yes (version 1.6.6)
checking for crypto++ version >= 5.1... no
configure: error: 
	Could not find crypto++ header file "cryptlib.h".
	Please try again with --with-crypto-prefix=/my_crypto_prefix
	(replace /my_crypto_prefix with a valid path to your crypto++
	installation directory).
Ty alot for helping me... :D
Post Reply

Return to “Software & Applications”