How to make Opera the default browser?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
igoru-san
Level 1
Level 1
Posts: 10
Joined: Mon Jul 14, 2008 9:30 am
Location: Rio de Janeiro - Brazil
Contact:

How to make Opera the default browser?

Post by igoru-san »

I'm using Opera for a few weeks but it doesn't appear in the "Prefered Applications" window.

How can I enforce this config?
There's no "custom" option.

And I've already tried the command "sudo update-alternatives --config x-www-browser", but it did nothing.
User avatar
Leit
Level 4
Level 4
Posts: 237
Joined: Tue May 04, 2010 3:05 am
Location: Germany
Contact:

Re: How to make Opera the default browser?

Post by Leit »

to use it as favorite in the mintmenu, open the mintmenu, rightclick on the program and select "add to favorites" (or something similar, i'm not using the english version).
to make it the default browser.... mhm i haven't used gnome since a while but it should be in the system-configuration "preferred software" or something.
It is interesting the way we create complex and powerful tools to save us
from the complex and powerful tools we created previously.
User avatar
odo5435
Level 4
Level 4
Posts: 372
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: How to make Opera the default browser?

Post by odo5435 »

If you're using Gnome, go to Mintmenu > Control Centre then within the 'Personal' grouping click on 'Preferred Applications'. If Opera is installed it should show in the dropdown box under 'Web Browser' in the 'Internet' tab. Click on Opera and close the window and then it should show on your Mintmenu 'Favourites'.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon
User avatar
igoru-san
Level 1
Level 1
Posts: 10
Joined: Mon Jul 14, 2008 9:30 am
Location: Rio de Janeiro - Brazil
Contact:

Re: How to make Opera the default browser?

Post by igoru-san »

THAT'S the problem.
It's installed but it doesn't appear in that menu in the Preferred Apps settings.
And also, there's no "custom" option anymore, so I can't add it manually.
:|
User avatar
Terryphi
Level 4
Level 4
Posts: 208
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: How to make Opera the default browser?

Post by Terryphi »

I don't understand why Opera does not appeared in Preferred Applications if it is installed correctly. This may be a workaround. The setting is in ~/.gconf/desktop/gnome/url-handlers/http/%gconf.xml
Note the stringvalue.

I have Opera set as default browser and here is mine:

Code: Select all

<?xml version="1.0"?>
<gconf>
	<entry name="command" mtime="1313853607" type="string">
		<stringvalue>opera %s</stringvalue>
	</entry>
</gconf>
and also in ~/.gconf/desktop/gnome/url-handlers/https/%gconf.xml

Code: Select all

<?xml version="1.0"?>
<gconf>
	<entry name="command" mtime="1284997190" type="string">
		<stringvalue>opera %s</stringvalue>
	</entry>
</gconf>
I hope this helps.
Version: LM 20.1 64bit Mate "If something is worth doing, it is worth doing for free."
Post Reply

Return to “Software & Applications”