Page 1 of 1

[Solved] Mint 12 - Browsers make no sounds

Posted: Fri Dec 02, 2011 6:09 pm
by BobSongs
Mint 12 - No Sound in any Browser

Problem: Firefox 8, Chromium Web Browser, Epiphany Web Browser, Seamonkey Web Browser: none of these play sounds through Flash plugins. Sites that offer media display images but are mute (example: homestarrunner.com).

This post explains how I activated sound for VLC Media Player, GNOME MPlayer and Audacity. So sound does work on my system.

System:
Kernel: 3.0.0-13-generic i686 (32 bit)
Desktop: Gnome Distro Linux Mint 12 Lisa
Machine: System Dell product Dell DM051
Mobo: Dell model 0KF623 Bios Dell version A02 date 10/13/2005
CPU: Single core Intel Pentium 4 CPU (-HT-) cache 2048 KB flags (lm nx sse sse2 sse3)
Clock Speeds: (1) 2800.00 MHz (2) 2800.00 MHz

Graphics:
Card: nVidia GF108 [GeForce GT 430]
X.Org: 1.10.4 drivers nvidia unloaded: fbdev,vesa,nouveau Resolution 1680x1050@51.0hz
GLX Renderer: GeForce GT 430/PCI/SSE2 GLX Version 4.1.0 NVIDIA 280.13

Audio:
Card-1 nVidia GF108 High Definition Audio Controller driver HDA Intel Sound: ALSA v: 1.0.24 (Set to OFF in Sound Preferences)
Card-2 Creative Labs SB Live! EMU10k1 driver EMU10K1_Audigy (Set to 5.1 Output and working perfectly in all non-browser applications)
Card-3 Asahi Kasei Microsystems AK5370 I/F A/D Converter driver snd-usb-audio (Set to OFF in Sound Preferences)

Suggestions are welcome. This SoundBlaster card, though older, has full support in Linux. Movies in Totem play 5.1 beautifully (Mint, in fact, plays the sound better than I've ever head in any Linux distro).

Questions welcome if not enough details supplied.

Re: [Solved] Mint 12 - Browsers make no sounds

Posted: Fri Dec 02, 2011 8:11 pm
by BobSongs
Solved my problem again. Yay. Feels good to be my own system administrator.

Problem is, I'm not entirely sure which solution worked. Neither one did at the time they were performed. But upon rebooting the system, the browser speaks.

These were the two system changes done.

#1: Opened Synaptic Package Manager and selected adobe-flashplugin that suggested the removal of both mint-flashplugin and mint-meta-codecs.

That had no effect. So I followed through with:

#2: Opened Synaptic Package Manager and selected ubuntu-restricted-extras and agreed with what it wanted to remove and add.

Again, that had no effect.

But after rebooting, as stated above, the browser offered sound.

Re: [Solved] Mint 12 - Browsers make no sounds

Posted: Sun Dec 04, 2011 2:57 am
by BobSongs
Upon rebooting, Firefox went silent again.

Tried something different. Booted by the Mint DVD. Opened the browser, all worked well. Re-installed Mint, logged in, opened the browser, sound failed.

Re: [Solved] Mint 12 - Browsers make no sounds

Posted: Sun Dec 04, 2011 12:01 pm
by BobSongs
Upon trying other user accounts on this system, sound works in browsers.

Any suggestion as to what hidden home folder to remove in order to bring sound back?

Re: [UnSolved] Mint 12 - Browsers make no sounds

Posted: Sun Dec 04, 2011 12:36 pm
by Roken
I'm guessing here, but the fact that it works intermittently after reboots suggests that you have a device mapping issue. On some boots the cards are mapped as expected, but on others they may not be (this is completely random at boot). There are a couple of possible solutions to this, but I've only found one that is reliable, and that is to blacklist drivers that you don't need. For example, if you are using the Creative card, blacklist the HD and USB Audio cards. This will leave ONLY the Creative card (ca0106 driver) in use at boot and it will always be device 0.

You can check if this may be an issue in advance by checking the output of:

Code: Select all

cat /proc/asound/cards
After successive boots and see if the order changes.

There are supposed to be configuration changes that you can make to ~/.asoundrc to enable the cards to mapped according to name, but I found this unreliable. My own observation suggests that the USB will always receive a lower mapping priority than built in or PCI, so you may be able to get away with just blacklisting the HD Audio if you need the USB from time to time.

Re: [Solved] Mint 12 - Browsers make no sounds

Posted: Sun Dec 04, 2011 2:48 pm
by BobSongs
Roken wrote:I'm guessing here, but the fact that it works intermittently after reboots suggests that you have a device mapping issue. On some boots the cards are mapped as expected, but on others they may not be (this is completely random at boot). There are a couple of possible solutions to this, but I've only found one that is reliable, and that is to blacklist drivers that you don't need. For example, if you are using the Creative card, blacklist the HD and USB Audio cards. This will leave ONLY the Creative card (ca0106 driver) in use at boot and it will always be device 0.

You can check if this may be an issue in advance by checking the output of:

Code: Select all

cat /proc/asound/cards
After successive boots and see if the order changes.
The list remains the same boot after boot.

Code: Select all

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                     HDA NVidia at 0xefdfc000 irq 17
 1 [Live           ]: EMU10K1 - SB Live! 5.1
                     SB Live! 5.1 (rev.7, serial:0x80641102) at 0xcca0, irq 18
 2 [AK5370         ]: USB-Audio - AK5370
                     AKM AK5370 at usb-0000:00:1d.0-2, full speed
Roken wrote:There are supposed to be configuration changes that you can make to ~/.asoundrc to enable the cards to mapped according to name, but I found this unreliable. My own observation suggests that the USB will always receive a lower mapping priority than built in or PCI, so you may be able to get away with just blacklisting the HD Audio if you need the USB from time to time.
The audio that comes with the NVidia card is set to off in the sound preferences. And again, the odd ball thing is: if I log out of my account and log into any other account (heck, even the "guest" account), the browsers play sounds as do all sound apps (VLC, Totem, GNOME Mplayer).

A solution I'm toying with (I resorted to this in the past) is either creating a new account and moving my files from the old account to the new, or simply logging in to the new account, opening up all the ~ files of this defective account in order to dump all config files (keeping, of course, personal documents, etc.).

Re: [Solved] Mint 12 - Browsers make no sounds

Posted: Mon Dec 05, 2011 2:37 am
by BobSongs
PROBLEM:
The Creative SoundBlaster card was clearly not the problem.

THE HIDDEN:
There was something crucial I failed to mention.

My /home/bob folder has existed under Ubuntu for a number of versions. I don't put much stock into "upgrading" Ubuntu. Instead I wipe the system (while keeping my /home/bob folder on a separate partition) then install the latest. This may have caused a few issues. My Firefox has had plug-ins added and removed a number of times. And while Linux Mint is very close to Ubuntu, it may have just enough differences to produce a few glitches when dealing with aging settings folders.

Also, when I first tried to install Mint, I did the following: I booted to the DVD and then explored it a bit first. As I explored I tried changing the desktop theme. This had an odd effect on the Live session. When I started the installation of Mint the setup box had an odd pink stripe along the top as well as the bottom. Where I was in the setup was unclear. And I selected to upgrade my current Ubuntu 11.10 to Mint 12. The setup process seemed endless, the pink bar showed me nothing (I realize now it was probably downloading updates), so I tried to exit. Exiting failed, so I rebooted. Ubuntu 11.10 was wiped and Mint 12 installed.

SOLUTION:
Firefox bookmarks (most essential part) were backed up to a single file one the desktop.
Created a new administrative account, logged in and started a copy of Nautilus with root authority:
  • Code: Select all

    gksudo nautilus
    Note to casual users: Using this can be dangerous as it has full root authority. Handle with care.
My home folder was picked clean of all hidden files and folders I could live without. (Incredible the amount of JUNK that was there: config files for apps I don't use any more, etc.). The focus was on ridding /home/bob of all GNOME and Mozilla references. Once sent to the trash, I exited that account and logged in under the "defective" account.
NOTE: Again, I'm aware of what hidden files & folders are necessary and what are not. It is not recommended to do this casually.

RESULTS:
  • Started up the browser and sound works perfectly.
  • My Applications menu is cleaned up too. No more dead links that were added manually. True, I'll need to restore a few that exist in my /home/bin folder, but that's an easy task.
[/color]