firewall

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
chris gainsford
Level 1
Level 1
Posts: 1
Joined: Tue Dec 27, 2011 12:11 am

firewall

Post by chris gainsford » Tue Dec 27, 2011 12:43 am

First, I am very impressed with mint12, Lisa. It is now my operating system. I love it. I have a question though. How do you keep the firewall activated. Every time I boot up the firewall is off. Isn't there a preset firewall that should stay on when activated? I don't understand anything about firewalls.Do I have to use my password to activate the firewall every time I turn my computer on? Use the password and it activates. Turn computer off and on next time ways firewall off. Use pass word and it comes on. I don't get it. Could someone please sent answer to blackice181@aapt.net.au. This worries me a lot. Thank you for your help.

User avatar
viking777
Level 14
Level 14
Posts: 5121
Joined: Mon Dec 01, 2008 11:21 am

Re: firewall

Post by viking777 » Tue Dec 27, 2011 7:44 am

Open a terminal and type:

Code: Select all

sudo ufw enable
You should get the reply:

Code: Select all

Firewall is active and enabled on system startup
Then see if it starts next time by typing:

Code: Select all

sudo ufw status
It should say active.

If it is not started after that then maybe you need to disable autologin on system startup, but I am not 100% sure that affects it.

BTW I hope that is a temporary email address you posted above - unless you like reading emails about penis enlargements and viagra :lol:
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

User avatar
Oscar799
Level 19
Level 19
Posts: 9985
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: firewall

Post by Oscar799 » Tue Dec 27, 2011 9:36 am

Moved here by moderator
Image

User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4581
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: firewall

Post by Aging Technogeek » Tue Dec 27, 2011 11:43 am

Could it be that you are being confused by the requirement to enter your password to unlock the firewall control window?

When you first call the firewall configuration app, the window is completely grayed out. This does not mean the firewall is disabled, it only means the controls are locked to prevent unintended changes.

Clicking on the lock icon and entering your password unlocks the controls to allow you to make changes. If the firewall on/off switch says "on" when the window first activates, that mean the firewall is and has been enabled since the first time you turned it on.

I also second viking777's comment about the email address in your original post. You should never publish your email address on an open forum unless it is a temporary address for that use only, or you are prepared to handle the spam flood that will most likely ensue.
Registered Linux User 483387

lmintnewb
Level 7
Level 7
Posts: 1568
Joined: Fri Apr 01, 2011 5:13 pm

Re: firewall

Post by lmintnewb » Tue Dec 27, 2011 5:20 pm

Scoops up email address ! In the interests of saving some time chris gainsford, can I interest you in some generic viagra ? :D

If you reboot, run that terminal command viking gave you and the firewall is inactive, might check out this thread. Had a similar headache with ufw myself and managed with my usual combination of RAW TALENT and DUMB LUCK to figure it out. :D

Post Reply

Return to “Software & Applications”