Sound Muted on every boot Mint 19.2 Cinnamon

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
InYd
Level 1
Level 1
Posts: 14
Joined: Thu Nov 21, 2019 12:16 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by InYd » Wed Nov 27, 2019 7:05 am

MrEen wrote:
Tue Nov 26, 2019 7:53 pm
Once the terminal showed that output, alsamixer should have changed, and output should have been available on the headphones.

As there's no way to see if there was an error, try changing the command to sh -c "amixer sset Headphone 100% toggle"

If that also doesn't work, increase the delay to at least 15 seconds. I would have thought 10 would be more than enough though.

Did that, still nothing.
i really think that an unfixable issue..

User avatar
trytip
Level 12
Level 12
Posts: 4019
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by trytip » Wed Nov 27, 2019 10:54 am

guess what, my system boots and when i turn on my bluetooth speaker connected with headphone cable i also have no sound, very annoying routine just to turn on pc and watch some youtube. i have to turn on my speaker, go to sound settings in volume tray icon, and then click between the outputs to "kickstart" the audio.
if my speaker is ON at the time of boot i have sound but not if it is OFF
your issue may be the same or entirely different.
Last edited by trytip on Thu Nov 28, 2019 7:55 am, edited 1 time in total.
Image

User avatar
Flemur
Level 17
Level 17
Posts: 7403
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by Flemur » Wed Nov 27, 2019 11:59 am

MrEen wrote:
Tue Nov 26, 2019 7:53 pm
Once the terminal showed that output, alsamixer should have changed, and output should have been available on the headphones.
I bet pulseaudio is causing the problem. Does pulse have an 'unmute' command similar to that of alsa, to run at boot or login?

I have a key assigned to mute using 'amixer', but un-muting using amixer didn't work: I had to unmute with the pavucontrol GUI.

Until I uninstalled pulseaudio, that is, now (un)mute with amixer works properly.

OP: DON'T try to uninstall pulseaudio!
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
MrEen
Level 15
Level 15
Posts: 5913
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by MrEen » Wed Nov 27, 2019 4:25 pm

Flemur wrote:
Wed Nov 27, 2019 11:59 am
MrEen wrote:
Tue Nov 26, 2019 7:53 pm
Once the terminal showed that output, alsamixer should have changed, and output should have been available on the headphones.
I bet pulseaudio is causing the problem. Does pulse have an 'unmute' command similar to that of alsa, to run at boot or login?

I have a key assigned to mute using 'amixer', but un-muting using amixer didn't work: I had to unmute with the pavucontrol GUI.

Until I uninstalled pulseaudio, that is, now (un)mute with amixer works properly.

OP: DON'T try to uninstall pulseaudio!
That's a great point regarding pulse, but when the OP ran the command in the terminal, it DID unmute and raise volume in alsa, which means the startup command didn't work, or wasn't necessary on that boot which I doubt. Pulse itself may have still been mute after running it though, but usually the OP just needs to raise the volume in Gnome alsamixer after booting.

I think it's beyond time to get some clarification here.

@InYd
Are you actually using headphones? Or are you just raising the headphone volume as that is what makes the sound work for the speakers? If you always have headphones plugged in and that's where you're always trying to get sound to play, then I'm betting this is a reverse jack detection issue, that should be fixable.

We'll want to delete the startup script and I'll wait for your reply before giving instruction for reversing the jack detection.

InYd
Level 1
Level 1
Posts: 14
Joined: Thu Nov 21, 2019 12:16 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by InYd » Mon Dec 02, 2019 4:55 am

I am not using headphones. thats just what makes the speakers make sound.

User avatar
MrEen
Level 15
Level 15
Posts: 5913
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by MrEen » Mon Dec 02, 2019 8:46 am

Okay. It's not reversed jack detection. Let's see if this tames that bugger:

First have your sound working before applying these steps.

In the terminal enter xed admin:///usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf and when the file opens find this section:

Code: Select all

; This profile path is intended to control the speaker, let's mute headphones
; else there will be a spike when plugging in headphones
[Element Headphone]
switch = off
volume = off
Change it to this:

Code: Select all

; This profile path is intended to control the speaker, let's mute headphones
; else there will be a spike when plugging in headphones
[Element Headphone]
switch = mute
volume = merge
Save and close the file, ignore the warnings from the terminal, then reboot

I'm hopeful that might work for you.

InYd
Level 1
Level 1
Posts: 14
Joined: Thu Nov 21, 2019 12:16 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by InYd » Mon Dec 02, 2019 4:24 pm

Thanks for your help!
Now it is working perfectly i have sound and it remembers the '%' it was before reboot!
but one prob there is that when i plug my headpones i can hear both from the speakers and the headphones and none of alsamixers bars is controling only the speakers but them both at the time.. if there any option to fix it that would be great.
i wonder why the develpoers didnt fix all these sound issues up to now.. thats really weird...
again thanks alot

User avatar
MrEen
Level 15
Level 15
Posts: 5913
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by MrEen » Mon Dec 02, 2019 5:06 pm

I'm glad that got things working (mostly) for you.

Your system has some issue that most users don't have. I know I've helped users using the Asus eee PC before and they didn't have the same issue. This is most likely a BIOS issue where it's misreporting what's available and where.

The only thing I can think of to try to fully solve this is to try retasking the pins that control the headphones and/or speakers. Maybe with different pins in use, the machine will operate properly.

If you want to try retasking the pins, just say so and I'll try to guide you through that process. There's no guarantee it will make things any better, but it might.

Reinstalling the operating system could also possibly fix this.

InYd
Level 1
Level 1
Posts: 14
Joined: Thu Nov 21, 2019 12:16 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by InYd » Tue Dec 03, 2019 4:33 pm

MrEen wrote:
Mon Dec 02, 2019 5:06 pm
I'm glad that got things working (mostly) for you.

Your system has some issue that most users don't have. I know I've helped users using the Asus eee PC before and they didn't have the same issue. This is most likely a BIOS issue where it's misreporting what's available and where.

The only thing I can think of to try to fully solve this is to try retasking the pins that control the headphones and/or speakers. Maybe with different pins in use, the machine will operate properly.

If you want to try retasking the pins, just say so and I'll try to guide you through that process. There's no guarantee it will make things any better, but it might.

Reinstalling the operating system could also possibly fix this.
Thanks alot but ill keep it that way, ill be listening through bluetooth instead of aux.
again thanks alot for helping me with this issue! you're the man! :D

User avatar
MrEen
Level 15
Level 15
Posts: 5913
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Muted on every boot Mint 19.2 Cinnamon

Post by MrEen » Tue Dec 03, 2019 7:23 pm

You're quite welcome. I'm glad the workaround is good enough for you.

Have fun. :D

Post Reply

Return to “Sound, Multimedia, & Codecs”