Internal microphone not working.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Internal microphone not working.

Post by Flagy »

Hello everyone, it's a while I'm struggling to make my internal microphone working but it looks like there is no way for me.
I've followed many different answers related to this topic that actually worked for other users but it looks like not for me.
I changed different times the kernel (the current is 4.15-0-75-generic) and even Cinnamon versions. Now I have Linux Mint 19.3 Cinnamon 4.4.6. My laptop is a Acer Aspire V Nitro. I have dual boot and in Windows the internal microphone works. Please, help. :?: :D

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6328
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Internal microphone not working.

Post by kukamuumuka »

Are you sure that microphone is not muted?

Code: Select all

alsamixer

Code: Select all

aplay -l

Code: Select all

inxi -A

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

Yes, it's not muted.
But even changing these parameters is not actually solving the problem

Code: Select all

alsamixer
AlsaMixer.png

Code: Select all

aplay -l
https://termbin.com/gghs9

Code: Select all

inxi -A
https://termbin.com/4cwb

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6328
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Internal microphone not working.

Post by kukamuumuka »

How about command

Code: Select all

dmesg | grep Mic

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

Also, your alsamixer screen shot doesn't show the Capture controls that you access by pressing F4.

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

kukamuumuka wrote:
Tue Jan 14, 2020 3:51 pm
How about command

Code: Select all

dmesg | grep Mic
This doesn't return anything except:
microcode: Microcode Update Driver: v2.2.
MrEen wrote:
Tue Jan 14, 2020 5:50 pm
Also, your alsamixer screen shot doesn't show the Capture controls that you access by pressing F4.
Pressing F4 during the command alsamixer returns:

│ This sound device does not have any capture controls. │

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

In the terminal enter xed admin:///etc/modprobe.d/alsa-base.conf and when the file opens scroll to the bottom and add this new line:

Code: Select all

options snd-hda-intel model=aspire-v5
Save and close the file, ignore the warnings from the terminal then reboot and test the mic.

If that doesn't work, either of these might instead, but be sure to only have one in the file at a time:

Code: Select all

options snd-hda-intel model=laptop-amic

Code: Select all

options snd-hda-intel model=laptop-dmic
Good luck.

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

MrEen wrote:
Fri Jan 17, 2020 8:27 am
In the terminal enter xed admin:///etc/modprobe.d/alsa-base.conf and when the file opens scroll to the bottom and add this new line:

Code: Select all

options snd-hda-intel model=aspire-v5
Save and close the file, ignore the warnings from the terminal then reboot and test the mic.

If that doesn't work, either of these might instead, but be sure to only have one in the file at a time:

Code: Select all

options snd-hda-intel model=laptop-amic

Code: Select all

options snd-hda-intel model=laptop-dmic
Good luck.
Thank you, I tried all of them but nothing changed. Internal microphone and also externals (when I plug in a different mic) are still not working

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

Let's get a look at your full sound setup. Paste back the output of this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

MrEen wrote:
Mon Jan 20, 2020 3:48 pm
Let's get a look at your full sound setup. Paste back the output of this command:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
Sure! Here it is:
https://termbin.com/s14e

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

Okay. It appears the earlier edits should have given you Capture control in alsamixer now. Open alsamixer, and look for the Internal Mic column. Arrow over to it, then press the m key to unmute it and the up arrow to raise the levels. I am basing that on this:

Code: Select all

Simple mixer control 'Internal Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
That shows it is muted (off) and has zero volume.

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

MrEen wrote:
Wed Jan 22, 2020 2:31 pm
Okay. It appears the earlier edits should have given you Capture control in alsamixer now. Open alsamixer, and look for the Internal Mic column. Arrow over to it, then press the m key to unmute it and the up arrow to raise the levels. I am basing that on this:

Code: Select all

Simple mixer control 'Internal Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
That shows it is muted (off) and has zero volume.
Thank you, you're right. However after I did the changes, the microphone doesn't work yet :(
Here I launched again the command curl https://gitlab.freedesktop.org/pulseaud ... line=false | bash | nc termbin.com 9999
and in here the result: https://termbin.com/gv15 now the internal mic is on but still not working

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

Well, I see some things that might be the cause of the issue, but not sure how to try to fix:

Code: Select all

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
  Control: name="Internal Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x02 0x02]
  Pincap 0x00003724: IN Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Control: name="Internal Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Internal Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Beep Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Control: name="Beep Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x18 0x18] [0x1d 0x1d] [0x80 0x80] [0x80 0x80] [0x0f 0x0f]
  Connection: 5
     0x18 0x19 0x1a 0x1b 0x1d
Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Control: name="Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Device: name="ALC255 Analog", type="Audio", device=0
  Amp-In caps: ofs=0x17, nsteps=0x3f, stepsize=0x02, mute=1
  Amp-In vals:  [0x25 0x25]
  Converter: stream=1, channel=0
  SDI-Select: 0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x23
The Internal Mic Boost Volume pin showing Misc = NO_PRESENCE and the other 2 pins showing mute=1 are most likely why you're not getting any input.

One possibility is your edit to alsa-base.conf has this:

Code: Select all

options snd_hda_intel model=laptop-amic position_fix=1 enable=yes
Try it with just this followed by a reboot:

Code: Select all

options snd_hda_intel model=laptop-amic
Also, muting the Mic column in alsamixer may have some influence. It really shouldn't, but it might. Arrow over to the Mic column then press the m key so it shows MM at the bottom. This is not the Internal Mic column I'm referring to.

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

MrEen wrote:
Sun Jan 26, 2020 2:42 pm
Well, I see some things that might be the cause of the issue, but not sure how to try to fix:

Code: Select all

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
  Control: name="Internal Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x02 0x02]
  Pincap 0x00003724: IN Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Control: name="Internal Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Internal Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Mic Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Mic Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Beep Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Control: name="Beep Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=4, ofs=0
  Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x18 0x18] [0x1d 0x1d] [0x80 0x80] [0x80 0x80] [0x0f 0x0f]
  Connection: 5
     0x18 0x19 0x1a 0x1b 0x1d
Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Control: name="Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Device: name="ALC255 Analog", type="Audio", device=0
  Amp-In caps: ofs=0x17, nsteps=0x3f, stepsize=0x02, mute=1
  Amp-In vals:  [0x25 0x25]
  Converter: stream=1, channel=0
  SDI-Select: 0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x23
The Internal Mic Boost Volume pin showing Misc = NO_PRESENCE and the other 2 pins showing mute=1 are most likely why you're not getting any input.

One possibility is your edit to alsa-base.conf has this:

Code: Select all

options snd_hda_intel model=laptop-amic position_fix=1 enable=yes
Try it with just this followed by a reboot:

Code: Select all

options snd_hda_intel model=laptop-amic
Also, muting the Mic column in alsamixer may have some influence. It really shouldn't, but it might. Arrow over to the Mic column then press the m key so it shows MM at the bottom. This is not the Internal Mic column I'm referring to.
I've been playing with many different parameters, however the microphone still doesn't work.
https://termbin.com/afn8

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

Okay, let's try changing the pin used for the internal mic.

Install alsa-tools-gui then run HDAJackRetask. When it opens, make sure Realtek ALC255 is chosen by Select a codec: at the top. In the left pane check the Override box for pin 0x19 then change the drop down box to Not connected.

Next click on Show unconnected pins in the upper right area. Now find a Not connected pin in the left pane other than 0x19 and see if checking it's Override box allows it to be changed to Internal mic. If not, move on to another pin. If you can change it to Internal mic, do so then click on Apply now. You'll need to make sure the mic isn't muted after before each test. And make sure the Internal mic is the default input. The best way to do this is on the Input Devices tab of PulseAudio Volume Control by making sure the check mark is highlighted next to it's Port. The best way to test is run this in the terminal: arecord -d 10 test-mic.wav

Then you can run aplay test-mic.wav to listen to the 10 second recording.

If that didn't help, undo the pin change you made and move on to another Not connected pin.

Each time to make a pin change click on Apply now before testing the mic. If something works, then click on Install boot override and hopefully it'll be working from then on.

Flagy
Level 1
Level 1
Posts: 8
Joined: Sat Jan 04, 2020 7:51 am

Re: Internal microphone not working.

Post by Flagy »

MrEen wrote:
Mon Jan 27, 2020 10:09 pm
Okay, let's try changing the pin used for the internal mic.

Install alsa-tools-gui then run HDAJackRetask. When it opens, make sure Realtek ALC255 is chosen by Select a codec: at the top. In the left pane check the Override box for pin 0x19 then change the drop down box to Not connected.

Next click on Show unconnected pins in the upper right area. Now find a Not connected pin in the left pane other than 0x19 and see if checking it's Override box allows it to be changed to Internal mic. If not, move on to another pin. If you can change it to Internal mic, do so then click on Apply now. You'll need to make sure the mic isn't muted after before each test. And make sure the Internal mic is the default input. The best way to do this is on the Input Devices tab of PulseAudio Volume Control by making sure the check mark is highlighted next to it's Port. The best way to test is run this in the terminal: arecord -d 10 test-mic.wav

Then you can run aplay test-mic.wav to listen to the 10 second recording.

If that didn't help, undo the pin change you made and move on to another Not connected pin.

Each time to make a pin change click on Apply now before testing the mic. If something works, then click on Install boot override and hopefully it'll be working from then on.
I tried all the different pins, nothing. Also interesting by default pin 0x19 was set to internal mic but it was already in the Not connected section. I have also tried to switch to other kernel versions but the problem remain. I'm loosing the hope.

User avatar
MrEen
Level 16
Level 16
Posts: 6995
Joined: Mon Jun 12, 2017 8:39 pm

Re: Internal microphone not working.

Post by MrEen »

This has been a somewhat common issue with Acer Aspires recently. One user has submitted a bug report but has had no reply so far.

Bug report: https://bugzilla.kernel.org/show_bug.cgi?id=206121

Thread: viewtopic.php?f=49&t=308376

If you add to the bug report, that might help get more action on this issue.

Post Reply

Return to “Sound, Multimedia, & Codecs”