Sound device gone (Dummy Output)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
cv01
Level 1
Level 1
Posts: 2
Joined: Sun Nov 22, 2020 7:27 am

Sound device gone (Dummy Output)

Post by cv01 »

Dear Forum members,

I have used Linux Mint on my Laptop with great joy for almost half a year, all hardware was supported from the beginning, the experience has been awesome. Now after some time and system updates I lost my Sound support somehow for the internal Sound Card and speakers.

I see some errors in dmesg which might have to do with it:

Code: Select all

[    5.788615] acp_pdm_mach acp_pdm_mach.0: ASoC: failed to init link acp3x-dmic-capture: -517
[    5.788620] acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -517
[    5.789659] acp_pdm_mach acp_pdm_mach.0: ASoC: failed to init link acp3x-dmic-capture: -517
[    5.789663] acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -517
[    5.851986] acp_pdm_mach acp_pdm_mach.0: dmic-hifi <-> acp_rn_pdm_dma.0 mapping ok
I tried running

Code: Select all

sudo apt-get install --reinstall alsa-base pulseaudio
with no success. Since it has been working for quiet some time, any idea what to try and do to get Sound back on my machine?

My full dmesg ist here https://filebin.net/i3s8f6j33t6lelu0/dm ... t=si5wbkyj and the https://termbin.com/n7t5 might also help.


Regards, cv01
Attachments
Bildschirmfoto vom 2020-11-22 12-30-13.png
User avatar
MrEen
Level 22
Level 22
Posts: 15140
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound device gone (Dummy Output)

Post by MrEen »

Hi cv01, and welcome to the fourm.

There were some updates that have caused issues for AMD users. To revert those, run this then then reboot and your sound will probably return:

Code: Select all

apt update && apt install libasound2=1.2.2-2.1 libasound2-data=1.2.2-2.1 libatopology2=1.2.2-2.1
You'll need to then not apply those updates again when they get offered. Hopefully fixed versions will arrive soon, but I can't say when.
DanielPe
Level 1
Level 1
Posts: 13
Joined: Mon Nov 09, 2020 8:12 pm

Re: Sound device gone (Dummy Output)

Post by DanielPe »

Yeah absoluty this code function very nice for me. The sound device is gone
I use online video downloader for videos
cv01
Level 1
Level 1
Posts: 2
Joined: Sun Nov 22, 2020 7:27 am

Re: Sound device gone (Dummy Output)

Post by cv01 »

Perfect, thank you, it worked and once there is updates with fixes I try again the newer packages. :D :D :D
User avatar
MrEen
Level 22
Level 22
Posts: 15140
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound device gone (Dummy Output)

Post by MrEen »

Haha! The new packages just arrived in the past day and I've had one report of them fixing the issue.

You already know how to fix it again, so go ahead and allow the updates after refreshing the Update Manager and see if everything works properly.

EDIT: I stand corrected. The new alsa-ucm package fixes the issue that downgrading the others also fixed. So upgrading everything available should result in working sound again.
Post Reply

Return to “Sound, Multimedia, & Codecs”