Page 1 of 1

How do I get 'ugly' gstreamer plugins for i386 on 64 bit?

Posted: Sun Jul 22, 2012 8:55 pm
by Rua
I'm using a 32-bit program in Mint 13 64 bit that relies on gstreamer and its plugins to play streaming media. The repositories do provide what seems like a 32 bit compatibility library for a subset of formats, gstreamer0.10-plugins-good:i386 (alongside gstreamer0.10-plugins-good which is the regular 64 bit library). Unfortunately, I can't find an i386 version of the two other packages, namely gstreamer0.10-plugins-bad and gstreamer0.10-plugins-ugly. That last one in particular is needed for mp3 playback, so mp3 streams (which almost all of them are!) will not play in 32 bit programs. Can I install 32 bit versions of those two packages some other way?

Re: How do I get 'ugly' gstreamer plugins for i386 on 64 bit

Posted: Mon Jul 23, 2012 6:00 am
by viking777
Bottom of this page:

http://packages.ubuntu.com/precise/gstr ... ugins-ugly

I can't vouch for the dependencies on this though, they may or may not work, and the version I linked to is for Ubuntu Precise or Mint Maya. There are other versions available if you are using an earlier version.

To install it you will probably need to use

Code: Select all

sudo dpkg -i --force-architecture /address where you stored the download

Re: How do I get 'ugly' gstreamer plugins for i386 on 64 bit

Posted: Mon Jul 23, 2012 10:14 am
by Rua
I got an error:

Code: Select all

Selecting previously unselected package gstreamer0.10-plugins-ugly:i386.
(Reading database ... 276694 files and directories currently installed.)
Unpacking gstreamer0.10-plugins-ugly:i386 (from gstreamer0.10-plugins-ugly_0.10.18.3-1ubuntu1_i386.deb) ...
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-ugly:i386:
 gstreamer0.10-plugins-ugly:i386 depends on liba52-0.7.4.
 gstreamer0.10-plugins-ugly:i386 depends on libcdio13.
 gstreamer0.10-plugins-ugly:i386 depends on libdvdread4.
 gstreamer0.10-plugins-ugly:i386 depends on libmp3lame0.
 gstreamer0.10-plugins-ugly:i386 depends on libmpeg2-4.
 gstreamer0.10-plugins-ugly:i386 depends on libopencore-amrnb0.
 gstreamer0.10-plugins-ugly:i386 depends on libopencore-amrwb0; however:
  Package libopencore-amrwb0:i386 is not installed.
 gstreamer0.10-plugins-ugly:i386 depends on libsidplay1; however:
 gstreamer0.10-plugins-ugly:i386 depends on libtwolame0; however:
 gstreamer0.10-plugins-ugly:i386 depends on libx264-120; however:
dpkg: error processing gstreamer0.10-plugins-ugly:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gstreamer0.10-plugins-ugly:i386

Re: How do I get 'ugly' gstreamer plugins for i386 on 64 bit

Posted: Mon Jul 23, 2012 11:32 am
by viking777
I can't say I am surprised.

BTW do you have ia32-libs installed?

If not install it and see if that cures the problem. It is supposed to have various 'magic' properties when it comes to mixing architectures, I am not sure if that includes making gstreamer work though.

Re: How do I get 'ugly' gstreamer plugins for i386 on 64 bit

Posted: Mon Jul 23, 2012 6:59 pm
by Rua
Yes I do have it installed. It may work for some things but as far as I know it's being phased out in favour of multi-architecture support. Unfortunately that isn't working yet in this case... :/