I just installed the latest version of LMDE (NO SOUND!)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
abzuexnihilo
Level 1
Level 1
Posts: 5
Joined: Fri Dec 21, 2012 5:11 pm

I just installed the latest version of LMDE (NO SOUND!)

Post by abzuexnihilo »

How do I fix this?? I went to sound preferences and clicked on my usual setting: RS880 HDMI Audio [Radeon HD 4200 Series] Digital Stereo. This setting worked for past versions of Linux Mint Debian, but now no setting for audio works! What can I do to solve the problem???? There is absolutely no sound anywhere. Not in vlc media player, not on youtube, nothing. Any help would be greatly appreciated! This is my output from

Code: Select all

lspci -v
in the terminal:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge
Subsystem: Advanced Micro Devices [AMD] RS880 Host Bridge
Flags: bus master, 66MHz, medium devsel, latency 32
Memory at <ignored> (64-bit, non-prefetchable)
Capabilities: <access denied>

00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (int gfx) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 99
Bus: primary=00, secondary=01, subordinate=01, sec-latency=68
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: fd500000-fd6fffff
Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
Capabilities: <access denied>

00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 1) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 0000b000-0000bfff
Memory behind bridge: fd400000-fd4fffff
Prefetchable memory behind bridge: 00000000fdf00000-00000000fdffffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 4) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: 0000e000-0000efff
Memory behind bridge: fde00000-fdefffff
Prefetchable memory behind bridge: 00000000fdd00000-00000000fddfffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fdc00000-fdcfffff
Prefetchable memory behind bridge: 00000000fd900000-00000000fd9fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40) (prog-if 01 [AHCI 1.0])
Subsystem: Giga-byte Technology GA-MA770-DS3rev2.0 Motherboard
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 44
I/O ports at ff00
I/O ports at fe00
I/O ports at fd00
I/O ports at fc00
I/O ports at fb00
Memory at fe02f000 (32-bit, non-prefetchable)
Capabilities: <access denied>
Kernel driver in use: ahci

00:12.0 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at fe02e000 (32-bit, non-prefetchable)
Kernel driver in use: ohci_hcd

00:12.2 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at fe02d000 (32-bit, non-prefetchable)
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:13.0 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at fe02c000 (32-bit, non-prefetchable)
Kernel driver in use: ohci_hcd

00:13.2 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at fe02b000 (32-bit, non-prefetchable)
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
Flags: 66MHz, medium devsel

00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller (rev 40) (prog-if 8a [Master SecP PriP])
Subsystem: Giga-byte Technology Device 5002
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at fa00 [size=16]
Kernel driver in use: pata_atiixp

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
Subsystem: Giga-byte Technology Device a102
Flags: bus master, slow devsel, latency 32, IRQ 16
Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
Subsystem: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller
Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40) (prog-if 01 [Subtractive decode])
Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
Bus: primary=00, secondary=05, subordinate=05, sec-latency=64
I/O behind bridge: 0000a000-0000afff
Memory behind bridge: fdb00000-fdbfffff
Prefetchable memory behind bridge: fda00000-fdafffff

00:14.5 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:15.0 PCI bridge: ATI Technologies Inc SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
I/O behind bridge: 00009000-00009fff
Memory behind bridge: fd800000-fd8fffff
Prefetchable memory behind bridge: 00000000fd700000-00000000fd7fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:16.0 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at fe029000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:16.2 USB controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: Giga-byte Technology Device 5004
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at fe028000 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
Flags: fast devsel
Capabilities: <access denied>

00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
Flags: fast devsel
Capabilities: <access denied>
Kernel driver in use: k10temp

00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
Flags: fast devsel

01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4290] (prog-if 00 [VGA controller])
Subsystem: Giga-byte Technology Device d000
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at d0000000 (32-bit, prefetchable) [size=256M]
I/O ports at ce00 [size=256]
Memory at fd6e0000 (32-bit, non-prefetchable) [size=64K]
Memory at fd500000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: radeon

01:05.1 Audio device: ATI Technologies Inc RS880 HDMI Audio [Radeon HD 4200 Series]
Subsystem: Giga-byte Technology Device 960f
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at fd6fc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03) (prog-if 30 [XHCI])
Subsystem: Giga-byte Technology Device 5007
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at fd4fe000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: xhci_hcd

03:00.0 Network controller: Atheros Communications Inc. AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) (rev 01)
Subsystem: D-Link System Inc Device 3a70
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at fdef0000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 43
I/O ports at de00 [size=256]
Memory at fd9ff000 (64-bit, prefetchable) [size=4K]
Memory at fd9f8000 (64-bit, prefetchable) [size=16K]
[virtual] Expansion ROM at fd900000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: r8169

05:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link) (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
Flags: bus master, medium devsel, latency 32, IRQ 22
Memory at fdbff000 (32-bit, non-prefetchable) [size=2K]
Memory at fdbf8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: firewire_ohci

06:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02) (prog-if 01 [AHCI 1.0])
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at fd8fe000 (32-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: ahci

06:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02) (prog-if 85 [Master SecO PriO])
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 17
I/O ports at 9f00 [size=8]
I/O ports at 9e00 [size=4]
I/O ports at 9d00 [size=8]
I/O ports at 9c00 [size=4]
I/O ports at 9b00 [size=16]
Capabilities: <access denied>
Kernel driver in use: pata_jmicron

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: I just installed the latest version of LMDE (NO SOUND!)

Post by zerozero »

Code: Select all

su

Code: Select all

head -n 1 /proc/asound/card0/codec*
is it the alc889?
this should work (tho is for the 887) >> http://www.webupd8.org/2010/11/fix-hda- ... sound.html
Image

[ bliss of ignorance ]

abzuexnihilo
Level 1
Level 1
Posts: 5
Joined: Fri Dec 21, 2012 5:11 pm

Re: I just installed the latest version of LMDE (NO SOUND!)

Post by abzuexnihilo »

No, it's the ALC892. This was the output:

Codec: Realtek ALC892


Will the fix on that link work just as well for the ALC892? Should I go ahead and try it? I have had no error messages just so you know. I can open up the alsamixer fine. There's just no audio.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: I just installed the latest version of LMDE (NO SOUND!)

Post by zerozero »

you can try that fix, you sure won't be worst than now; if it doesn't work (you still have no sound) just undo the changes and we'll have to dig further.

i too have a 887 and it gives no errors, gives no sound either :lol: at all (not until i apply that fix)
Image

[ bliss of ignorance ]

User avatar
eiver
Level 5
Level 5
Posts: 566
Joined: Fri Jan 23, 2009 5:51 am

Re: I just installed the latest version of LMDE (NO SOUND!)

Post by eiver »

I also lost sound after updating from UP4 to UP6.

In the syslog I noticed:

Code: Select all

pulseaudio[4170]: [pulseaudio] module.c: Failed to open module "module-cork-music-on-phone": file not found
pulseaudio[4170]: [pulseaudio] main.c: Module load failed.
I solved the problem by editing the file: /etc/pulse/default.pa
I changed load-module module-cork-music-on-phone to load-module module-role-cork
The sound is back, although the sound applet is missing in mate, which is another issue.

Post Reply

Return to “Sound, Multimedia, & Codecs”