Mint 14 no sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 7
Joined: Fri Jan 11, 2013 9:30 pm

Mint 14 no sound

Post by finkelmana » Fri Jan 11, 2013 11:21 pm

I am a linux noob so bear with me

I had LM13 running on a PC and everything worked fine. I decided to install LM14 and the install went fine, but I had no audio even though it properly detected my SB X-FI extreme audio card. I tried reinstalling just to see if that fixed it, but no. I swapped computers, but put in the same card as I need its optical out to connect to my surround sound receiver. That PC had windows and the audio worked fine, so I know its not the card. I installed LM14 on the new pc and again, it detects the X-FI, but no audio.

Any ideas on what to do?

Level 1
Level 1
Posts: 7
Joined: Fri Jan 11, 2013 9:30 pm

Re: Mint 14 no sound

Post by finkelmana » Fri Jan 11, 2013 11:47 pm

after doing some more googling, I found the answer... on this site :D

Had to install the gnome-alsamixer and play with the settings.

Level 1
Level 1
Posts: 7
Joined: Fri Jan 11, 2013 9:30 pm

Re: Mint 14 no sound

Post by finkelmana » Sat Jan 12, 2013 1:34 am

Well, it looks like my fix was only temporary. After rebooting, the sound is gone and I cant get it working again.

Level 1
Level 1
Posts: 7
Joined: Fri Jan 11, 2013 9:30 pm

Re: Mint 14 no sound

Post by finkelmana » Sat Jan 12, 2013 4:56 am

Well, I tested some more... Analog audio works, but not digital...

It would appear this forum isnt visited often though, I might just have to downgrade.

Level 1
Level 1
Posts: 1
Joined: Sun Jan 13, 2013 1:01 pm

Re: Mint 14 no sound

Post by steete » Sun Jan 13, 2013 1:13 pm

I installed Linux Mint for the first time ever this morning, but no sound. I'm glad I found this post. The reference to alsamixer was the solution on my Gigabit motherboard with a VIA VT2021 codec.

Level 1
Level 1
Posts: 8
Joined: Sun Jun 17, 2012 10:24 am

Re: Mint 14 no sound

Post by standev » Fri Apr 05, 2013 7:20 am

I tried a lot of what has been posted on the web to solve the sound problem on the current Linux Mint (cinnamon). It had the sound at startup after logging in, but then it was gone. What worked for me, was this:
1. open Terminal window (Ctrl + Alt + T)
2. launch 'alsamixer' in the Terminal
3. there's going to be text-mode configuration of volume levels. Go to the right and select "automute" setting (I had it enabled). Disable it by pressing enter.
4. Sound works perfectly now.

I wish sound worked out of the box, I almost gave up after struggling with this issue for hours. Thank you for this thread!

Level 1
Level 1
Posts: 11
Joined: Fri Oct 26, 2012 5:11 pm

Re: Mint 14 no sound

Post by cipri_tom » Tue Apr 09, 2013 9:44 am

I am also having problems with a SB card. I haven't seen your post earlier, because it didn't show up in search.
Anyway, none of your solutions worked for me. Gnome alsa mixer has no effect. in terminal version of alsamixer I can't find that "automute" option.
I have no analog or digital output. I really think I am downgrading

User avatar
Level 5
Level 5
Posts: 946
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Mint 14 no sound

Post by anandrkris » Tue Apr 09, 2013 9:57 am

Type alsamixer in terminal and see if volume is unmuted for speakers. Default sound card can be changed in aslamixer by hitting F6 key.

Code: Select all

Please post the specs of your sound card. Share the output of the below commands from Terminal.

Code: Select all

lspci | grep -i audio 

Code: Select all

inxi -A 
Guys - - I have posted an idea on having a Troubleshooting wizard in Mint for audio related issues. I feel it will really help new users migrating to Linux world. Request you all to have a look at it and provide your views and if it makes sense cast your vote on it.
Am rallying the user forums who have sound issues to get consensus on the idea. Let us join our hands together in building a user-friendly Linux Mint. :)

Below links are of custom search engines that help in searching linux related topics. I find them to be very useful to solve linux related issues. You could search for your problem there. ... _owgx6xyi0
If there is a drive, there will be a path

Level 1
Level 1
Posts: 3
Joined: Thu Apr 11, 2013 9:52 am

Re: Mint 14 no sound

Post by phonky » Thu Apr 11, 2013 10:02 am

I am also having problems with sound on Linux Mint 14 :(

I am also pretty sure that initially I had sound.
I have a dual boot with ubuntu 12.10, on which sound works without problems.
So it must be Mint.

In fact, if I go to System Tools - System Settings - Sound,
I have no hardware in the hardware tab!

That explains why all the other suggested solutions (gnome-alsamixer, automute etc.)
can't work for me.

lspci | grep Audio:

Code: Select all

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
inxi -A:

Code: Select all

Audio:     Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: 1.0.25

Level 1
Level 1
Posts: 20
Joined: Thu Jan 12, 2012 4:34 pm

Re: Mint 14 no sound - and how I fixed it

Post by deminted » Thu Apr 11, 2013 4:40 pm

Re: Mint 14 no sound
fixed, solved, resolved (for now)

I too have been all around the system looking at diagnostics & solutions that don't actually work.

Try this: fire up a terminal & give it
sudo alsactl -F init

If alsactl is not there, you may need to use software manager to get it.

That's it. Worked for me.


Within a short time, sound was gone again.
(I wonder how long this will last as a working solution? Mysterious unssen forces seem to be at work...)

First install & update alsamixer if it's not there.
I have alsamixergui, alsa-utils, alsa-base installed, together with pulseaudio & supporting libraries. Use Admin > Syanptic, and Admin > UpdateManager to install.

As above, in terminal
sudo alsactl -F init

then I found a need to tweak alsamixer.
in terminal
sudo alsamixer
Which generally comes up as a coloured panel with Master selected
use up-arrow to up the volume of the Master control.
Now scroll across the alsamixer controls using right-arrow >>, until you see the automute column
use down-arrow to set auto-mute to disabled

Sound works again (for now...)

Now, if you really don't have a correct sound driver, or your sound card is U/S, it isn't going to help much.
Other posts have covered in depth how to grope around to attempt fixes for that.
The alsamixer has F2 for system info (up/down arrows, enter to proceed, esc to get back)
and F6 for card selection (up/down arrows, enter)

This is how it went, the story so far:
I fired up a live DVD of Mint 14 Cinnamon ( 64-bit version).
Because I'd lost sound before, I checked at various stages in my customisation that prefs->sound->[hardware] , [Test Speakers] (lower right of panel) was sounding out.
Sound was initially present, but went AWOL as soon as I fired up the (should have been updated) Firefox, & set a FF password.

What's happening with Update Manager I don't know. It's trying to download AMD software for a non-AMD machine, presumably for the ATI/AMD RADEON video driver for an imaginary Radeon sound card which I don't have. There are missing repos. It hangs without giving a sensible reason.

I could really do with a working non-free nVidia driver, in a way that doesn't require reboot (which one can't do with live DVD). but that's another matter.
Other distros manage to do that, it's bitterly disappointing that Mint chooses not to. NIH maybe.

Anyway, Update should have given me FF 20.0, but I see I still have the rather ancient FF 16.0.1 Odd.
Update seems to be FUBA, failing to upload the right things, sticking at file 55 of 111, saying "no space left on device" when there's plenty.
These are quite ancient & venerable errors, and really should have been fixed by now.
Sometimes I honestly suspect sabotage (but no-one would do that would they?) Surely it can't be foolishness or indifference?

Then I'm into
dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
Perhaps I should have done a bleachbit earlier, but there seemed genuinely to be no need up until Firefox.
I am unhappy.

All that fell into place after stopping FF, running bleachbit (with the right language parameters) and a terminal > sudo dpkg --configure -a'
as suggested.

To return to sound issues:
I had already installed alsamixer, but it didn't look right, with only master-in & master-out levels. And no colour. And it didn't bring sound back.

I decided to take radical approach, to see if there was a repair already available.
first I fired up a terminal & asked > apropos alsa
which was unenlightening
so, > apropos sound
(cunning, eh?) Which brought up, inter alia, something called "alsactl - advanced controls for ALSA soundcard driver "
Worth a try I thought.
After looking at alsactl --help, I first tried command >alsactl -F restore
(just in case it had been backed up ) No dice.
Go for it:
sudo alsactl -F init
and that works! (Good, init?)
Found hardware: "HDA-Intel" "Nvidia MCP77/78 HDMI" "HDA:10ec0888,1025015e,00100202 HDA:14f12c06,1025015e,
00100000 HDA:10de0003,10de0101,00100000" "0x1025" "0x015e"
Hardware is initialized using a generic method

...and faint noises from the sound test!
So, continue to > sudo alsamixer
which is now its technicolour self again. Use up-arrow to up the master volume (left/right arrows to select channel) (ctl-C to exit back to terminal)

Yippee, sound!!

Flash is version 11,2,202,243 and is still c### ("code")

Something is awry with the Firefox install. I suppose Minters & Mozilla can argue amongst themselves. Shouldn't take long. I blame Firefox & the culture therein, but I could be wrong.

Something is very wrong with the Updater, missing repositories, wrong things being detected & asked for.

I should raise some bugg reports.


This gets weird. Next day, after using the plain sudo alsactl -F init approach, no sound again.
I re-tried > sudo alsactl -F init
nothing. Silence.

It seems that something had set alsamixer "automute" to enabled.
Very funny... Do these things really happen on their own? Should I call an exorcist?

This is puzzling to the casual observer, because one doesn't see the automute column in alsamixer as it comes up in the terminal (unless the terminal is very wide) - it's hidden way over to the right of the visible panel.

in terminal,
sudo alsamixer
then right-arrow until you see automute (turns red)
down-arrow to set auto-mute to disabled

This took me a little extra forum seeking.
The tip about automute, ... 47#p649966 by Dreamingtune (thanks),

I also found this
Two posts by kvnsz on Sat Mar 02, 2013
First, kvnsz has found a working fix & published it.
Minutes later, he reports sound was off again.

It must be gremlins.

Level 1
Level 1
Posts: 5
Joined: Fri May 03, 2013 6:18 pm

Re: Mint 14 no sound

Post by 6dandl5 » Mon May 06, 2013 12:58 pm

I was having a lot of trouble with VLC, Banshee & Audacious playing the wma media files. I have a C-Media sound card that my sound works through. Since I dual boot my system with windows xp I tried a different approach to my sound issue. I have started converting my wma files to .ogg and transfering to my Linux Mint OS. I now have a very good listening experence playing my music with VLC Player. Haven't found a decent sound converter for Linux so I use the Free Rip program in XP. Works great for me.

Level 1
Level 1
Posts: 23
Joined: Sun May 05, 2013 8:38 pm

Re: Mint 14 no sound

Post by os2x » Mon May 06, 2013 9:18 pm

I noticed the same problem working with the music cdroms. I had an idea what it was so I check the "MIXER" and sure enough it was
turned down to the lowest setting or I should say, OFF! So, check it out and make sure it is turned up.


Level 2
Level 2
Posts: 65
Joined: Sat Sep 18, 2010 12:01 pm
Location: Cornwall, GB

Re: Mint 14 no sound - and how I fixed it

Post by anamnesis » Wed May 08, 2013 11:32 am

deminted wrote: Try this: fire up a terminal & give it
sudo alsactl -F init
no need for that all:
$ alsamixer (no need for sudo)
F6 select your card
turn up all the needed channels press m to unmute (color changes pale to green).
Important: when finished press esc to leave the mixer.
If you want to save your settings (normaly no need for that) run $ sudo alsactl store
Notabene: instead of creating new soundservers like phonon or pulseaudio they should provide the new users with a funky 3-d transparent cube shaped spinning and bouncing techno-music-playing! cool! What a mixer baby!

Level 1
Level 1
Posts: 23
Joined: Sun May 05, 2013 8:38 pm

Re: Mint 14 no sound

Post by os2x » Sat May 18, 2013 2:53 pm

What a MIXER! Make sure you have the level turn down on a SoundBlaster if you value your speakers! Because that is
what it will do...


Level 1
Level 1
Posts: 6
Joined: Sat Nov 24, 2012 6:31 pm

Re: Mint 14 no sound

Post by alicebtoklas » Fri Dec 27, 2013 9:30 am

don't know if it is related, but this bug
seems to affect a lot of people.
Good luck,

Post Reply

Return to “Sound, Multimedia, & Codecs”