Page 1 of 1

no sound from headphones (happen randomly, ASUS vivobook)

Posted: Fri Apr 05, 2013 5:18 pm
by jxhan
Installed Mint 13 on a new ASUS vivobook S550CM. This notebook has only one plug to host headphone and microphone at the same time. From time to time after a new boot, the headphone has no sound, but the speaker works well when headphone unplugged. No matter what sound settings I try, no sound comes from the headphone. Occasionally after a fresh boot, the headphone could work. But then with another boot up, it ceases to work again. Completely unpredictable. Tried to set alsa and played with pluseaudio and checked dmesg etc with no clues yet. Could someone please give me some directions?

The problem seems to have brought me back to the early days when almost everything needs to be configured manually for a new linux installation...

And I got plenty more of annoying hardware-related problems with this new ASUS vivobook: Fn+key for brightness not working; screen booted up with lowest brightness (also happend randomly!); no multi-touch touchscreen support (and not even a touch-screen support with the default Maya 3.2 kernel); no nvidia video card support (only detected the integrated intel HDA video)... And even more wierd: the battery status icon suddenly begins to miss since two days ago together with the bar to adjust screen brightness! I've now tracked down the battery icon problem to be caused by my /etc/cups/client.conf in which I added a cups server with restricted accessing IP range. During boot-up the system seems to be trying really hard to connect to the server when actually I have not set up the network environment to enable it to connect. After removing the client.conf my battery icon, and brightness settings, now have come back to my desktop. And I do not want to mention the one week's nightmare of trying to boot a mint CD in UEFI mode and installing grub and configuring the bootloader.... and the nightmare of windows 8 does not shut down completely with fast-boot enabled, causing loss of data on the NTFS disk shared with linux... And I haven't even tried to utilize the intel RST occupied SSD in linux. Why it seems that suddenly, linux has fallen like 3 years behind the hardware development and we have to suck from hacking around UEFI and GNOME 3 and undetected video card and ill-configured sound card and even a crashing kernel (which happens occasionally for the default 3.2 kernel)...why... I just want to get my work done, that's why i came to mint, but now can't get satisfied....

Re: no sound from headphones (happen randomly, ASUS vivobook

Posted: Thu Aug 15, 2013 9:30 am
by jxhan
A solution: when it happens, close the lid to suspend the system, then resume. After that, you get sound!

Re: no sound from headphones (happen randomly, ASUS vivobook

Posted: Mon Sep 09, 2013 3:49 am
by baluvix
Thank you very much. Had a similar issue with my Asus K55V, and your solution worked. I had spent almost a day hunting around for workarounds! :-)