No System Sounds!

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Sat Jun 14, 2008 2:01 pm

No System Sounds!

Post by Relentless » Sun Jun 15, 2008 1:23 pm

Hi all,

I would like to install some sound themes, but the problem is that when i go to Preferences > Sound > Sounds and try to "test" the sound files, nothing plays, i have disabled them all ("No Sound") but i still get the login and out sounds, basically this menu does not seem to control the system sounds at all, does anyone have any ideas and solutions?

Thanks all!

Does anyone have any articles, tutorials and/or code snippets they would gladly submit to my site? Full reference and thanks to yourself and link back to you if wanted :D - Contact:

Knowledge is Power.

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No System Sounds!

Post by Husse » Wed Jun 18, 2008 6:38 am

Which version?
Sounds are there in Elyssa, but not quite as they should be...
Don't fix it if it ain't broken, don't break it if you can't fix it


Re: No System Sounds!

Post by nepmak2000 » Sat Jun 28, 2008 3:16 am

I have noticed that under circumstances Gnome Alsa Mixer produces an OSS error message: SigmaTel STAC 9721,23 error ( , ) not allowed...! Although I use my Audigy 2 ZS!!!
This is a persistent thing most likely due to keyboard layouts (wellknown from that 'other' OS). The , must be a . Question is where to tackle this minute typo? It causes however uncontrollable (not to save new Prefs) sound if at all! Particularly when intializing Elyssa you get a thunderous roar 100% or none at all... Great when the family is in bed and Dad wants to work late night... I assume that the problem described has to do with this. The work-around is using to open 'Volume Control' (right click on it), Open Volume Control and File-> Change Device to use: Playback ..... (your set-up). Yet, this OSS SigmaTel error persists. How to correct that bloody , ???


Re: No System Sounds!

Post by nepmak2000 » Sat Jun 28, 2008 3:34 am

Husse, this is what I read after failing to initialize Prefs for Gnome Alsa Mixer.
This refers only to this bloody , phenomenon. Weren't that there most of us won't have silly sound troubles, I am sure!
I saw more such freak reports, like low volumes etc. With me it is the reverse - thunderous roar at start up.... (I know how to handle that!).
But the phenomena with this programme are related to that , STAC 9721,21 xx21 . 23 it should be!

28 June 2008 06:59:50 Received signal 6
28 June 2008 06:59:50 GNUsound crashed or was killed.
28 June 2008 06:59:50 ------ Dumping backtrace to logfile ------
28 June 2008 06:59:50 Trying to save unsaved data...
28 June 2008 06:59:50 Attempting to salvage shell 1 of 1
28 June 2008 06:59:50 Writing Untitled1.crashed.wav...done (0 of 0 frames)
28 June 2008 06:59:50 Finished, continuing with default signal handler


Re: No System Sounds!

Post by nepmak2000 » Sat Jun 28, 2008 6:38 am

I got so angry this morning not able to find the "bug" that I dissected the whole 'root' to find a -as usual- simple solution for the users of ONE sound-card. The Elyssa builders assumed possibly that most users apply more than 1 SoundCard. Just that caused the mix up for us simple users of but one such card :roll: . Here we go:

In the ROOT 'File System' (so be careful) find: /etc/pulse/
Then see the marked-out (#) line: # load-module module-alsa-sink remove now this # token to activate the line upon restarting.
OR: select the line you would prefer in this small section instead. I assume you would want to work with Alsa..!

Then # mark out the next whole paragraph about "automatic load driver modules depending.... " Disable only that paragraph!

It now looks like this:
### Automatically load driver modules depending on the hardware available
#load-module module-hal-detect
### Alternatively use the static hardware detection module (for systems that
### lack HAL support)
#load-module module-detect

I strongly suppose that this automatic selection causes a lot of trouble in "older" equipment... But who am I to say so as "learned novice".

Ok, then save and restart. Go into your personal user "Home".
Goto Main Menu: Sound & Video -> PulseAudio Manager
Now we SYSTEMATICALLY CLICK all TABbed Items for their VOLUME setting, which may be way to soft or much too LOUD...!!!
Critically important to click the words "reset" next to the various windows per item. This takes a few minutes to do.

Nextly go to the (Gnome) Volume Applet and select its 'Preferences' to select the DEVICE (which should be setup correctly now) and the varius controllers you would use to SET-UP your tone and balances for your sound system. For now you may select any controllerset you wish...

Then select in this applet "Open Volume Control" and see all your controllers, some at their bottom NOT chained for LR adjustment if needed!
Now run a nice Wiener Walz or some HipHop on your RhythmBox and adjust the controllers. When satisfied with your 7.1 stereo, or 5.1 surround or 2 channels pingpong , or whatever, GO BACK TO PREFERENCES in the Volume Applet to only select MASTER and deselect the rest!
If not, you would influence ALL selected controllers for your sound when manipulating the volume control (via a keyboard) or in the applet or otherwise! This is vitally important I find. Having adjusted thngs to your liking make a restart for safety and a clean memory to begin with.

This method solved the sound crisis I faced and hopefully you'll find some intriguing hints in this to enjoy excellent AudioPulse sounds!


Level 2
Level 2
Posts: 56
Joined: Sun Sep 02, 2007 12:07 am

Re: No System Sounds!

Post by tri » Wed Jul 02, 2008 10:19 am

You can type sudo apt-get remove pulseaudio. It will fix your trouble.

Post Reply

Return to “Sound, Multimedia, & Codecs”