SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
bravoelf
Level 1
Level 1
Posts: 12
Joined: Sat Sep 21, 2013 1:11 pm

SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Post by bravoelf »

Hi everyone,
First of all,
The Linux Mint distro, I'll talk about: Petra, 32bit, Cinnamon.
My Laptop is: Acer Aspire 6930G, with NVidia 9600M GT on it.

I decided to open a new thread cause I can't find a solution by myself.
For the last couple of week I tried to resolve my sound issue, I googled it, watched some: Ubuntu-Opensuse-Fedora and of cause a Linux Mint forums.
Unfortunately with no sucess.
There was a couple of guys that solved their sound problems by "unmuting some outputs" and similar kind of way.. but in my case this don't work.

What is my exact problem:

I have my Acer laptop connected to 24" external Samsung monitor via HDMI cable (its model: SyncMaster T240). The monitor itself has no built-in speakers, but it do have a standart headphones output (where I connected my ext. speakers.
The problem is:that there is no output on those ext. speakers, instead of this all the sound goes through my laptop speakers or my headphones (if they are connected to laptop).
There was a couple of things that I've tried:

1. Installed pavucontrol.
At the "configuration" I choose several options like:"Digital Stereo(HDMI) output + Analog Stereo Output" or just "Analog Stereo Output" the maximum I've got from those settings was the situation I described above.
At the "Output Devices" I choose:" HDMI/Display Port" option, with/without "fallback" option selected (BTW what this option means? ^_^) -- Nothing happend.
2. The installation of "Daily Updated DKMS...." and updated my User Groups (could someone provide me some addition info what do I need those groups for?) ---> I cheked "pulse" and "pulse access".
Like this guy:

Code: Select all

http://forums.linuxmint.com/viewtopic.php?f=48&t=150972
- Didn't yield any result also.

It feels like my system reconizes HDMI output (at least it sees some HDMI output) but won't work with it.

3. I've have also tried:
Keep the line GRUB_CMDLINE_LINUX="radeon.audio=1" in /etc/default/grub
Run: sudo update-grub, and
Restart the system.
Like in this thread:

Code: Select all

http://askubuntu.com/questions/285920/no-sound-through-hdmi-out-13-04
I know that this is kinda lame way to make things, especially in case, when I don't have Radeon video card but Nvidia, still I tried.

*** Futhermore, I was up with some interesting moment: when I updated my GRUB I got this message:
No Volume Groups Found
, I got it in both cases, I mean, when I added the "radeon.audio=1" string, and after I returned my
GRUB file to the original state.

Some additional info (in case you need more just tell what command to use ^_^):

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: LX3000 [Microsoft LifeChat LX-3000], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code: Select all

aplay -L
default
    Playback/recording through the PulseAudio sound server
sysdefault:CARD=Intel
    HDA Intel, ALC888 Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, ALC888 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=Intel,DEV=0
    HDA Intel, HDMI 0
    HDMI Audio Output
dmix:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    Direct sample mixing device
dmix:CARD=Intel,DEV=1
    HDA Intel, ALC888 Digital
    Direct sample mixing device
dmix:CARD=Intel,DEV=3
    HDA Intel, HDMI 0
    Direct sample mixing device
dsnoop:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    Direct sample snooping device
dsnoop:CARD=Intel,DEV=1
    HDA Intel, ALC888 Digital
    Direct sample snooping device
dsnoop:CARD=Intel,DEV=3
    HDA Intel, HDMI 0
    Direct sample snooping device
hw:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    Direct hardware device without any conversions
hw:CARD=Intel,DEV=1
    HDA Intel, ALC888 Digital
    Direct hardware device without any conversions
hw:CARD=Intel,DEV=3
    HDA Intel, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=Intel,DEV=0
    HDA Intel, ALC888 Analog
    Hardware device with all software conversions
plughw:CARD=Intel,DEV=1
    HDA Intel, ALC888 Digital
    Hardware device with all software conversions
plughw:CARD=Intel,DEV=3
    HDA Intel, HDMI 0
    Hardware device with all software conversions
sysdefault:CARD=LX3000
    Microsoft LifeChat LX-3000, USB Audio
    Default Audio Device
front:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    Front speakers
surround40:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    Direct sample mixing device
dsnoop:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    Direct sample snooping device
hw:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    Direct hardware device without any conversions
plughw:CARD=LX3000,DEV=0
    Microsoft LifeChat LX-3000, USB Audio
    Hardware device with all software conversions

Any help will be greatly appreciated.

Thanks in advance.

P.S. This situation was the same when I installed Linux Mint 15, Ubuntu, OpenSuse distros.
Last edited by bravoelf on Mon Dec 16, 2013 6:25 am, edited 1 time in total.

nomko

Re: Linux Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Post by nomko »

Try this:

In a terminal, type the following commands:

Code: Select all

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

Code: Select all

apt update

Code: Select all

apt install oem-audio-hda-daily-dkms

bravoelf
Level 1
Level 1
Posts: 12
Joined: Sat Sep 21, 2013 1:11 pm

Re: Linux Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Post by bravoelf »

OMG!!! But how? It works fine now,it so weird. Thanks a lot.
From the other side: I've done this before, I mean I instaled those daily dkms stuff, so why it started to work only now?

Once again, thanks.

pfennigcat
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 2:55 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by pfennigcat »

I'm in the exact same situation with my Acer Aspire 6930, no audio over HDMI. My screen died recently, so I'm trying to get this working over my TV for audio and video.

I'm running Ubuntu 13.10, a fresh install with updates installed then these packages added:
nvidia-319
xbmc
nfs-common

I add the repository above and add the repository and package above and reboot (Note: for any new users, try 'apt-get' instead of just 'apt' in the update and install commands above). After reboot

Code: Select all

aplay -L
does not list any devices and I have no audio out of anything. Removing the dkms package and rebooting again restores to working state:

Code: Select all

sudo apt-get purge oem-audio-hda-daily-dkms
What am I doing wrong?
Is there any reason to suspect the 'fix' will work if I'm using Mint instead of stock Ubuntu?
Is there a specific daily-dkms that I can specify somehow?

bosko431
Level 1
Level 1
Posts: 1
Joined: Mon Dec 23, 2013 6:28 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by bosko431 »

This uninstalling finally helped me to solve my problem. Sound broke yesterday. This really helped. Very much appreciated!!

bravoelf
Level 1
Level 1
Posts: 12
Joined: Sat Sep 21, 2013 1:11 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by bravoelf »

As I said before, this is some weird problem. Cause I actually did all the same steps to resolve it (I'm talking about my first post here), had no result. But, in some occasion, it resolved when I installed those dkms packages once more time.
Ordinary I used to see such kind of problems in MS Windows and not in Linux. Still I'm glad, it finally works.

pfennigcat
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 2:55 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by pfennigcat »

My guess is that there is a particular daily build of the above dkms package that fixed it, but it regressed later. The fact that I had zero audio devices (no sound working at all) after applying the package makes me think that the latest versions of it are broken in some other way. Or it may be some combination of the dkms package and the rest of your system that works for you now but didn't work when the other bits of your system were at slighly older versions. Something like that.

I'm going to punt and just use stock packages (no daily packages) and use VGA + stereo audio from the headphone jack. I have the inputs available on my TV and a spare cable somewhere around here.....

abati
Level 1
Level 1
Posts: 10
Joined: Sun Dec 15, 2013 2:51 pm

Re: Linux Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Post by abati »

nomko wrote:Try this:

In a terminal, type the following commands:

Code: Select all

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

Code: Select all

apt update

Code: Select all

apt install oem-audio-hda-daily-dkms
hy m8 i also had some problem with my hdmi to my lcd, each time i connect the hdm from my laptop to my lcd, the saund always came from the laptop and not from the lcd.

so i tried these comands you mentioned, and now i dont even have anny sound on my laptop and also no sound on the lcd.

So basically i dont have anny sound at all

PLease help me fix this

pfennigcat
Level 1
Level 1
Posts: 3
Joined: Mon Dec 23, 2013 2:55 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by pfennigcat »

abati, see the 'purge' command above to remove teh dkms package -- I also had no sound at all after installing it, but it came back after removing the package (still no working HDMI audio for me though of course).

abati
Level 1
Level 1
Posts: 10
Joined: Sun Dec 15, 2013 2:51 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by abati »

pfennigcat wrote:abati, see the 'purge' command above to remove teh dkms package -- I also had no sound at all after installing it, but it came back after removing the package (still no working HDMI audio for me though of course).
Thnx for the great response m8 !

it worked out for me as you mentioned, about the above command (sudo apt-get purge oem-audio-hda-daily-dkms)

bravoelf
Level 1
Level 1
Posts: 12
Joined: Sat Sep 21, 2013 1:11 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by bravoelf »

Hello guys,

As for now(1/3/2013) I made a fresh install of Mint 16 (Petra) 32 bit.
The steps I've made to obtain my HDMI output(please don't ask me if thay are all necesery to make, I actually don't know cause I'm new linux user)
1. I've made system update, using Update Manager --- restarted PC
2. Installed "pavucontrol" via Synaptic Software manager.
3. Added some groups to my account. You go to the: Menu-->Administration-->Users and Groups--> here you mark wiht "x" these groups:" audio, pulse, pulse-access, video, voice"
4.Then you need to make steps mentioned above:
nomko wrote:Try this:

In a terminal, type the following commands:

Code:
sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily


Code:
apt update


Code:
apt install oem-audio-hda-daily-dkms

Then I rebooted my laptop, and there was an HDMI output (welcome sound played). <--- At this point make sure you don't have any headphones plugged in, cause in that case all the sound will go to this output and not to the hdmi speakers.
My guess is that there is a particular daily build of the above dkms package that fixed it, but it regressed later.
As for now, I can only say that your opinion about those dkms was wrong, cause I reinstalled my system from scratch(I made it a week after you put here your message), so there is no any "particular" dkms packages.

Secondary, you also told about:
it may be some combination
So this is the main reason of why I came back here, and described the steps I have done to get it work, on a system that was installed from scratch.

Hope this will help to others.

SIncerely,

ultranol
Level 1
Level 1
Posts: 41
Joined: Mon Sep 30, 2013 11:02 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by ultranol »

I did everything on this thread and the problem persists.

Actually when I click on the sound icon on the system tray, the HDMI device shows up. I can select it, but no sound happens. If I open the Sound Settings window, the HDMI will not be there.

Edit: fixed the problem. I actually upgraded from LM15, and there I had the actual driver for my video card (Radeon 7000 series). I couldn't install it so I was using the open source compatible one, and that one seems to not work out with the HDMI audio. Then I found this post: http://forums.linuxmint.com/viewtopic.p ... 57#p798690 and managed to install the proper drivers. Rebooted and for the first time I have heard a startup sound (even though audio worked on LM15, for some reason it never played a startup sound).

bripod
Level 1
Level 1
Posts: 1
Joined: Sun Mar 09, 2014 7:10 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by bripod »

I have to resurrect this thread. I've been searching all over on how to fix sound via hdmi and I haven't gotten it to work since Ubuntu 3 years ago. I'm just now on LM 16 and it's great so far. It's actually the most stable distro I've tried for my little Asus n10 netbook. So I've researched around and I believe some ubuntu guys got theirs to work by downloading Pulse Audio Volume Control. This lets you select the output of the sound for it to go through the tv rather than speakers. I tried this last night. When music was playing on my laptop/netbook with the speakers selected, you can see the volume bar go up and down with the music or whatever, but when switched to HDMI, it's nothing even while playing. I tried this fix and it seemed promising with the dmkg download. This volume control program now looks like sound is going through hdmi as the volume bar is lively but there's still no sound. I don't know what I'm missing now.

User avatar
nanders83
Level 1
Level 1
Posts: 14
Joined: Thu Dec 06, 2012 11:40 am
Location: The Netherlands
Contact:

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by nanders83 »

I also didn't have sound via HDMI (headphones connected to monitor). After installing pavucontrol I had to change the profile in the configuration tab from "Digital Stereo (HDMI) Output (unplugged)" to "Digital Stereo (HDMI) Output". I didn't need to install anything else. Maybe this helps others too.

Image
Linux Mint 17 Cinnamon

Hobbes2
Level 1
Level 1
Posts: 23
Joined: Sun Jun 22, 2014 4:33 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by Hobbes2 »

Just like to confirm, the above information from nanders83 worked for me too (in Mint 13 Cinnamon) on a Dell Inspiron 7520. Nice simple solution for once! Thanks for posting.
Hobbes2

wewa
Level 1
Level 1
Posts: 36
Joined: Tue Jan 24, 2012 4:20 am

Re: Linux Mint 16 - no HDMI Output sound (Acer Aspire 6930g)

Post by wewa »

Okay.

After reboot, this seems to have worked.
On my Gateway notebook NV55C with LM 17.1.
Using a Acer DA220HQL external HDMI display.

My 2nd install, after I got Black Screen of Death on 17.0 after installing Intel Graphics Driver for Linux. :(
Not a devoted Linux user after that.
So many problems in Linux. Just as bad as Windows. Maybe worse.
XP just works.

nomko wrote:Try this:

In a terminal, type the following commands:

Code: Select all

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

Code: Select all

apt update

Code: Select all

apt install oem-audio-hda-daily-dkms

wewa
Level 1
Level 1
Posts: 36
Joined: Tue Jan 24, 2012 4:20 am

Error when executing: apt install oem-audio-hda-daily-dkms

Post by wewa »

$ apt install oem-audio-hda-daily-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
oem-audio-hda-daily-dkms
1 upgraded, 0 newly installed, 0 to remove and 68 not upgraded.
Need to get 255 kB of archives.
After this operation, 5,120 B disk space will be freed.
Get:1 http://ppa.launchpad.net/ubuntu-audio-d ... ly/ubuntu/ trusty/main oem-audio-hda-daily-dkms all 0.201508071531~ubuntu14.04.1 [255 kB]
Fetched 255 kB in 2s (112 kB/s)
(Reading database ... 239780 files and directories currently installed.)
Preparing to unpack .../oem-audio-hda-daily-dkms_0.201508071531~ubuntu14.04.1_all.deb ...

-------- Uninstall Beginning --------
Module: oem-audio-hda-daily
Version: 0.201507292116~ubuntu14.04.1
Kernel: 3.13.0-37-generic (amd64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

snd-hda-codec-cirrus.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-intel.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-conexant.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-analog.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-core.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


snd-hda-codec-cmedia.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-hdmi.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-ca0132.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-realtek.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-ca0110.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-idt.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-via.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-generic.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


snd-hda-codec.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//

snd-hda-codec-si3054.ko:
- Uninstallation
- Deleting from: /lib/modules/3.13.0-37-generic/updates/kernel//
- Original module
- Archived original module found in the DKMS tree
- Moving it to: /lib/modules/3.13.0-37-generic/updates/kernel//
depmod......

Removing original_module from DKMS tree for kernel 3.13.0-37-generic (amd64)

DKMS: uninstall completed.

------------------------------
Deleting module version: 0.201507292116~ubuntu14.04.1
completely from the DKMS tree.
------------------------------
Done.
Unpacking oem-audio-hda-daily-dkms (0.201508071531~ubuntu14.04.1) over (0.201507292116~ubuntu14.04.1) ...
Setting up oem-audio-hda-daily-dkms (0.201508071531~ubuntu14.04.1) ...
Loading new oem-audio-hda-daily-0.201508071531~ubuntu14.04.1 DKMS files...
First Installation: checking all kernels...
Building only for 3.16.0-38-generic
Building for architecture amd64
Building initial module for 3.16.0-38-generic

Error! The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch. This indicates that it should not be built.
Done.

jjmk1
Level 1
Level 1
Posts: 11
Joined: Wed Nov 16, 2011 8:33 pm

Re: SOLVED- Mint 16 - no HDMI Output sound (Acer Aspire 6930

Post by jjmk1 »

I simply rebooted and then I could see HDMI audio out. Seems if you plug in HDMI after booting, the hdmi audio option may not get initialized.

Post Reply

Return to “Sound, Multimedia, & Codecs”