Flash videos all green purple and distorted

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
steve24rdg
Level 1
Level 1
Posts: 4
Joined: Sat Jan 04, 2014 6:36 am

Flash videos all green purple and distorted

Post by steve24rdg »

Hello to everyone.
I have an annoying problem, I cant get videos to play I can hear the sound but the image is purple green and distorted. I checked out several posts with so called fixes but nothing seems to work in my case.
So what do I do now?? I got rid of XP because it had become so slow and unpractical, I thought I could revive an old desktop computer with linux, only to be dissapointed.
I have tried lubuntu and linux mint 16 xfce, both the same result. Not good really and getting quite annoyed with it.
I have puppy linux on an old laptop and flash videos work fine. I would put it on the desktop if the app installer, software center and automatic updates were as good as the mint / ubuntu distros.
Can someone please help me fix this problem on what is in every other sense a good distro

Thanks

computerbob
Level 4
Level 4
Posts: 283
Joined: Wed Jan 01, 2014 1:55 pm

Re: Flash videos all green purple and distorted

Post by computerbob »

You need video ram to play video. I'm running a quad core i7 and with 1024MB of shared ram, just running off the onboard video, I was able to watch most HD vids. I was happy that I didn't have to install a PCIe-16 card. Then I watched a HD with a little higher pixel density and the screen images stalled. So I installed a video card and I'm good. The thing about video ram is that 1GB should be enough to play 1920x1080, but the speed of onboard video, even with a Hazwell CPU, is nowhere near the speed of the vram in a card.

steve24rdg
Level 1
Level 1
Posts: 4
Joined: Sat Jan 04, 2014 6:36 am

Re: Flash videos all green purple and distorted

Post by steve24rdg »

I dont think its a ram issue as flash worked fine on this computer when I had ubuntu 12.10 installed.
anyhow here is a copy of my system info for those who might be able to make sense of it.
inxi -Fxz
System: Host: steve-OptiPlex-GX270 Kernel: 3.11.0-12-generic i686 (32 bit, gcc: 4.8.1)
Desktop: Xfce 4.10.2 (Gtk 2.24.20) Distro: Linux Mint 16 Petra
Machine: System: Dell product: OptiPlex GX270
Mobo: Dell model: 0U1325 Bios: Dell version: A07 date: 06/26/2006
CPU: Single core Intel Pentium 4 CPU (-UP-) cache: 512 KB flags: (sse sse2) bmips: 5586.27 clocked at 2793.137 MHz
Graphics: Card: Intel 82865G Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.14.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x1024@60.0hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio: Card: Intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller driver: snd_intel8x0 ports: ee00 edc0 bus-ID: 00:1f.5
Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic
Network: Card: Intel 82540EM Gigabit Ethernet Controller driver: e1000 ver: 7.3.21-k8-NAPI port: df40 bus-ID: 01:0c.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 45.1GB (9.1% used) 1: id: /dev/sda model: Maxtor_2F040L0 size: 41.1GB
2: USB id: /dev/sdc model: Mass_Storage size: 4.0GB
Partition: ID: / size: 12G used: 3.9G (35%) fs: ext4 ID: swap-1 size: 1.54GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 138 Uptime: 3 min Memory: 228.5/494.0MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4

thanks

oscarferreira
Level 1
Level 1
Posts: 1
Joined: Sat Jan 11, 2014 2:11 pm

Re: Flash videos all green purple and distorted

Post by oscarferreira »

Alô..

Instal Google Chrome: https://www.google.com/intl/pt-PT/chrome/browser/

and: 32 bit .deb (Para Debian/Ubuntu) - and click the "executable"

Google Chrome have the flash player

ArtVandalay
Level 1
Level 1
Posts: 5
Joined: Thu Dec 26, 2013 12:30 am

Re: Flash videos all green purple and distorted

Post by ArtVandalay »

I have the same exact problem as Steve and have never found a solution on a new Mint 16 Mate install. All flash videos are, as Steve posted, "green purple and distorted." I deactivated acceleration in flash but it did not work. It is frustrating.

It looks like I have a similar setup on an old Dell. Here's my info:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
00:1d.0 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)


I have also uninstalled and reinstalled Firefox, and later Flash. Same problem. Other than just switching from Firefox to Google Chrome, has anyone found a fix?

Can I try to update the driver(s)? If so, can anyone give a "newby's" guide on exactly how to do it? I've found a driver download center on Intel's website ...

https://downloadcenter.intel.com/Detail ... ldID=13815

... but it is confusing and I cannot figure out exactly what to choose. I don't want to do something I can't undo.

Thanks.

User avatar
grimdestripador
Level 6
Level 6
Posts: 1051
Joined: Fri Feb 16, 2007 2:26 am

Re: Flash videos all green purple and distorted

Post by grimdestripador »

Answer: Click on the flash object, get settings/properties. Toggle between (On/Off) hardware acceleation. Although I kinda like my martian and venetian colored newscasts..

palo
Level 4
Level 4
Posts: 462
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: Flash videos all green purple and distorted

Post by palo »

ArtVandalay wrote:I have the same exact problem as Steve and have never found a solution on a new Mint 16 Mate install. All flash videos are, as Steve posted, "green purple and distorted." I deactivated acceleration in flash but it did not work. It is frustrating.

It looks like I have a similar setup on an old Dell. Here's my info:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
<snip>


The problem lies with the newer kernel and intel graphics. It can be fixed by making a xorg.conf file that allows you to use the old acceleration method. See item 3. in this topic: http://forums.linuxmint.com/viewtopic.p ... 16#p781916

Pat

Post Reply

Return to “Sound, Multimedia, & Codecs”