Installing and using JACK audio - my adventures in Mint17

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Flemur
Level 16
Level 16
Posts: 6271
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Installing and using JACK audio - my adventures in Mint17

Post by Flemur » Thu Sep 18, 2014 9:44 pm

I was wanting to setup a guitar "effects rack" sorta thing using LADSPA effects. "Normal" audio has too much latency, and supposedly "jack" (jackd) will allow real-time effects. So I setup a separate Mint17 install to play with it.

The jack documention I've seen, or watched on youtube, is really bad, so here are some notes I took while installing and getting sound output from ardour3, vlc, and audacity.

+++++++++

Remove pulseaudio, install jack and some utils. Reboot.

qjackctl -> Start
"Cannot lock down 82274202 byte memory area " ...etc.
IOW, Jack server won't start.

1 - add "username" to "audio" group

2 - /etc/security/limits.conf: Add 2 lines at end:
@audio - rtprio 99
@audio - memlock unlimited

Reboot

Jack Server now starts OK.

+++++++++++++++
START VLC -
Error messages about can't open sound output.

qjackctl -> Connect -> All connections are "capture_N" (1,2) or "playback_N" (1-8)
What the 8 playback things are I have no idea!
No mention of vlc.

VLC UNRESOLVED.

install vlc-jack plugin; now vlc doesn't complain about sound, but still no sound.

w/vlc, select jack audio output thru Tools->Prefs->Audio
HAVE THE JACK SERVER RUNNING.

+++++++++++++++++++
START ardour3

qjackctl -> Connect -> shows plenty or connections, named audour, automatically connected.

ardour3 unresolved.
(same for audacity - shows audacity connections, no sound).

+++++++++++++

qjackctl: changed Setup->Interface to hw:0 (from 'default')
Start jackd, got this error:
ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio0": ...

Fixed that with
$ killall -9 jackdbus
...then jackd server starts (IOW, it was two stupid to know it was already using hw:0).

Still no sound output.
+++++++++++

qjackctl -> Setup -> Interface = plughw:0 (No tutorial mentions this!)
PRESS "PLAY" button (no tutorial mentions this!)
SOUND! From audacity! AND VLC! And Ardour3!

+++++++++++++++

At this point I can't record anything using jack, so I'll post updates if/when that happens.

With audacity I can record line-in by shutting off jack server and selecting alsa in audacity, tho the pass--thru sound is distorted, sometimes the recorded wave file is distorted and sometimes audacity crashes.

Adobe audition(+wine) records fine.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
Flemur
Level 16
Level 16
Posts: 6271
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Installing and using JACK audio - my adventures in Mint1

Post by Flemur » Wed Oct 08, 2014 3:46 pm

Update: I can now use linux as a guitar effects rack with no noticeable delay/latency! And it only took about 10 hours!
Using "guitarix" effects box. Showing about 2-3% CPU use with effects running, which is pretty good.
Note: I didn't have to make or change any connections in qjackctl tp use guitarix.
Will give rakarrack a try next.

Anyway, here are some more notes that may help someone else trying to use linux audio & jack - good luck!

DISCOVERY: I was using audio input from a TV cable box, and thru the computer it was out of sync with the TV sound, by about 200ms (1/5 second). Turns out the delay was IN THE TV! (TV audio later than audio from the cable-box it's connected to). I've never heard of a TV buffering sound and picture, but this is a "smart" TV, so I guess it out-smarted me. Taking audio from the back of the TV kept TV and computer sound in sync.

Not much luck with ardour3!

Ardour3: recorded some sound from TV - no delay; no effects (can't find them in Ardour menu...sigh)
Saved the recording as a "CD" (.wav?) file:
["ardour3" The selected preset did not load successfully! Perhaps it references a format that has been removed?]
Got a wav file (21Meg), silent. Same as above with .ogg.

Found some stuff about ardour3 export: "Turning off the ALSA-Audio bridge for the export process did the trick."
That's truly lame.

So I couldn't find any mention of ALSA-Audio bridge (and no "alsa" in "ps -ef") in ardour or gjackctl, so stopped the jack server and tried the export again...ardour3 instantly crashed:
JACK HALTED: JACK server has been closed

(ardour-3.5.308~dfsg-1:6386): glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: basic_string::_S_construct null not valid
[1]+ Trace/breakpoint trap ardour3

Great stuff! Linux audio is the only thing that makes me miss windows...
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

autumnleaves
Level 2
Level 2
Posts: 59
Joined: Wed Nov 18, 2009 2:43 pm

Re: Installing and using JACK audio - my adventures in Mint1

Post by autumnleaves » Wed Oct 08, 2014 3:51 pm

I am also in a wrestling match with Mint 17 audio. My sympathies!

User avatar
Flemur
Level 16
Level 16
Posts: 6271
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Installing and using JACK audio - my adventures in Mint1

Post by Flemur » Wed Oct 08, 2014 4:27 pm

autumnleaves : I am also in a wrestling match with Mint 17 audio. My sympathies!

My sympathies back atcha! It's like pulling teeth. Your own teeth.

I put the process on hold (IOW, gave up) until I discovered that TV sound delay issue; the delay was short enough that it was hard to tell which was first unless you stand between them and listen carefully. Lesson learned: don't assume anything.

A bright spot is the "hydrogen" drum machine: works great, very flexible, GUI makes sense, works without "jack", and DOESN'T CRASH.

Edit:
To record the guitar+effects with audacity:
"Audio host" = jack
"Input device" = guitarix_effects" (or something like that), not jack.
(those settings aren't labeled - that's what the mouse-over pop-up help says)
When I selected "guitarix_effects" input the first time I got error messages, then later it worked.
IIRC, guitarix_effects=stereo and guitarix_amp=mono.

Also: Rakarrack's help consisted of a good explanation of audio inputs & impedance matching when using electric guitar as input.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Post Reply

Return to “Sound, Multimedia, & Codecs”