Page 1 of 1

Audio crackles and stutters every few minutes

Posted: Sat Nov 29, 2014 9:22 pm
by Glossic
I recently installed mint 17.1 and I'm having audio issues. I know its not exclusive to 17.1 as 17 also had the same issue. Every few minutes wheater on Google Chrome or Clementine my audio cracks. I tried editing the /etc/pulse/ and adding tsched=0 to the load-module module-udev-detect line but that only made the issue less frequent. It went from a few seconds to a few minutes. Is there anyway to fix this?

Re: Audio crackles and stutters every few minutes

Posted: Tue Dec 02, 2014 12:05 am
by SirGreatNose
I have the same problem, with games as well. I started with a clean install of Mate 17.1 64bit, videos stuttered, and games that used to run flawlessly (Icewind Dale), would run well for a time, before the sound got very 'scratchy'. I decided to try Cinnamon 17.1 64bit, videos still stutter, though honestly, not as often, and Icewind Dale remained clear, but locked up/crashed. Most other games 'pause' for a split second, every so often.

I had no problems with the same applications on 17, other than a performance hit once in a while with some games. I'm getting a little worried. I've read that others have had similar issues, but haven't found a solution yet.

Re: Audio crackles and stutters every few minutes

Posted: Tue Dec 02, 2014 4:58 pm
by SirGreatNose
Okay, I've just formatted, and put Mate 17 64bit on, didn't download the lower tier updates, just the preselected number ones, and watched a 16 minute video on YouTube, no stutters or pauses. It played perfectly. Haven't installed any gaming software yet, but it's pretty obvious for me, anyway, that 17.1 is causing my sound issues. I'm just gonna stick with 17 without upgrading, as long as I can. Hopefully, someone will identify the problem, and address it.

EDIT: Zero problems with Icewind Dale, ( And MAME, and Fusion, ) I'm sticking with 17.0.

Re: Audio crackles and stutters every few minutes

Posted: Tue Dec 16, 2014 7:52 pm
by phill1978
its actually cinnamon and its bloody annoying. I cant belive a dev hasnt noticed it.

if you move your mouse and change focus on a window the audio clicks :? and window function and the audio clicks.

pretty bad.

Re: Audio crackles and stutters every few minutes

Posted: Mon Jan 05, 2015 3:24 pm
by cos5000
Is this an official Linux Mint bug?

Has anyone had any luck addressing this issue?
phill1978 wrote:its actually cinnamon...
This conflicts with information I've found elsewhere:

Right now, on my HTPC, I am using a fresh install of:
Linux Mint 17.1 Cinnamon 64-bit
Cinnamon version 2.4.5

For me, the issue occurs during playback across formats (.avi, .mkv, .mp4) and resolutions (SD, 720p, 1080p) and players (VLC, XBMC).
Every 5-10 minutes or so, there is a stutter in the video and audio. It is very slight, but noticeable and very annoying considering this is my primary entertainment system.

Any advice or help is appreciated. I can post logs or any other information needed to help.


Re: Audio crackles and stutters every few minutes

Posted: Tue Mar 03, 2015 8:25 pm
by brentb
I have the same issue. I'm a new user who just installed Linux Mint a couple of weeks ago. After I installed Clementine, the sound would start blasting white noise or static at about 2 minutes in to any youtube video or other online video.

I uninstalled Clementine, and so far the sound seems fine. I'm hoping that either the developers of Clementine or Mint figure this out for the people that prefer the Clementine player.

Re: Audio crackles and stutters every few minutes

Posted: Wed Mar 04, 2015 7:06 am
by tinca
just a thought,

If any of you have a Z97 chip set then go to

Best Regards Keith

Re: Audio crackles and stutters every few minutes

Posted: Tue Mar 10, 2015 1:08 pm
by ben2talk
I've been cussing about this for years.

Now I'm sorted... though I don't use Clementine...

I started getting interesting in finding DTS music (multichannel stuff) and now use Plex Home Theatre to drive my TV... so I really needed to get sound sorted.

The first thing to sort out is your basic settings... don't set Dolby Surround in the settings, I use HDMI and it's set to Digital Stereo.

The second thing is to ditch Pulseaudio as the default.
Run this, select the RECOMMENDED (Alsa) instead of the Default:

Code: Select all

sudo dpkg-reconfigure linux-sound-base

So simple. Now if I run Clementine, or Banshee - I get good sound (you can't get 5.1 from normal music files, but you can still run DSP in your receiver to get some 5 channel stereo, or other effects. VLC needs properly setting up - I can't be bothered with it (played for a few hours... then just stuck to adding my 'downloads' and 'video' folders separately in Plex... and a terminal alias to do a quick scan via keyboard shortcut/shorcut on panel:

Code: Select all

alias pmscan='sudo su - plex -c "export LD_LIBRARY_PATH="/usr/lib/plexmediaserver";/usr/lib/plexmediaserver/Plex\ Media\ Scanner --scan --refresh"'
When I play DTS or other multichannel stuff, it works best with Audacious - and I get DTS passed through to the receiver (i.e. Mint doesn't mess with it or try to play it, the stream goes straight out on HDMI).

Similarly, when I play stuff in Plex Home Theatre, instead of the usual audio settings in Preferences, using ALSA I actually see HDMI with the NAME of my TV listed as an option.

This means that stereo goes out as stereo PCM, but my AceNorton download from Dolby lights up as Dolby Digital+ and my DTS lights up for DTS... passthrough works perfectly and I get none of the crackles or anything else I used to get trying to get 5.1 before (with Pulseaudio).

I'm not sure how you're connected - but maybe it's worth ditching whatever connections you have and buying a long HDMI (mine's 10 metres, cost less than 15 USD, cheap as chips... but no issues with using my HDTV as monitor or sound via my Yamaha receiver).

This is the first time since 2007 I've been genuinely happy with the sound in Linux...

I'm not sure how much my hardware is helping here - but it's a whole lot simpler than editing text files and potentially messing up your system trying to follow instructions from the GURU's...

Re: Audio crackles and stutters every few minutes

Posted: Tue Mar 10, 2015 1:49 pm
by Flemur
Disable pulseaudio.

Re: Audio crackles and stutters every few minutes

Posted: Fri Mar 13, 2015 9:26 am
by phill1978
if you have a onboard soundchip apparently the crackle can be fixed by changing the default rate to 48000khz

there is a guide to pulse i found by googling here: ... pulseaudio

Re: Audio crackles and stutters every few minutes

Posted: Fri Jun 12, 2015 3:43 pm
by SirGreatNose
I seem to have found a solution, in my own personal case, anyway.

I recently tried to put different DEs of 17.1 on, in the hopes that recent updates may have addressed my sound problem, but to no avail, I still experienced my previously mentioned issues.

Well, today, after going back to MATE 17.0, which doesn't give me those sound problems, I decided to try the 'upgrade to 17.1' feature. I'm happy to say that upgrading did NOT carry any of those problems over. No stuttering, repeating, or static. I'm not sure why, I'm just very pleased!

Maybe this info can be useful to someone else, as well?

Re: Audio crackles and stutters every few minutes

Posted: Fri Jun 17, 2016 11:51 am
by blackoutworm
For those of you still having this issue (in which I had until just recently) I have found a solution.
This will not only fix the problem as it relates to the sound crackling every other minute or so, but also make the audio a whole lot better.
NOTE! This particular PPA will ONLY work for Mint 17 and other Ubuntu 14.04 based distros.
So first you wanna go ahead and add these PPAs. Open up a terminal and copy/paste:

Code: Select all

sudo add-apt-repository ppa:mc3man/trusty-media

Code: Select all

sudo add-apt-repository ppa:rvm/smplayer

Code: Select all

sudo add-apt-repository ppa:strukturag/libde265
This will update your multimedia software and codecs with a bunch of custom tweaks.
So go ahead and add that. Then do

Code: Select all

sudo apt-get update
Now run

Code: Select all

sudo apt-get upgrade
Next, delete the folder ~/.config/vlc as the new modded version of VLC contains a few different settings.
And also, Rhythmbox+grilo - needs to be enabled in Rhythmbox > tools > plugins
Install grilo-plugins and rhythmbox-plugins if not already.
Here are some more Rhythmbox plugins for you: ... ox-plugins
Now, install a few more packages:

Code: Select all

sudo apt-get install ffmpeg libde265 vlc-plugin-libde265 alac-decoder mencoder wavpack flake fdkaac-encoder monkeys-audio flac lame mppenc musepack-tools h264enc x264 x265 gstreamer1.0-libde265 gstreamer0.10-libde265 ttaenc faac aac-enc speex firmware-crystalhd gstreamer1.0-crystalhd aften abcde
This is how I fixed the audio glitch, but these tweaks will also give you way better sound and smoother hd video playback. The guy who put together this PPA sure knows his stuff.
Some good decompression, decoding and HD playback tools in here.

Re: Audio crackles and stutters every few minutes

Posted: Tue Dec 18, 2018 7:05 pm
by teamspoad
EDIT: I thought it was SOLVED for my system as follows, but it worked once, then continued to stutter on reboot. Many "fixes" have worked temporarily, but something still causes freezes: ... hones-fix/

NOTE: his examples capitalize B in bluetooth in the path, this caused errors, make sure you change the uppercase to lowercase B. again, this only worked until reboot, therefore, this is left here to help those troubleshooting the issue.