[Solved] Laptop lenovo internal mic (/pulseaudio?) issue

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Oc3lot
Level 3
Level 3
Posts: 138
Joined: Tue Aug 26, 2014 4:28 am

[Solved] Laptop lenovo internal mic (/pulseaudio?) issue

Post by Oc3lot »

Hi,
i've a problem with my laptop lenovo g 50-30 (running Mint 17.1 but the problem was in 17 too). When i call someone on skype the volume of the built in microphone is very very very low. I boosted the volume through the audio options and alsa mixer too. I think it's a pulseaudio problem because if i use audio-recorder and record my voice then the volume is ok. Any suggestion?

PS: the microphone in my headset works too.
Last edited by Oc3lot on Sun Nov 30, 2014 4:50 pm, edited 1 time in total.

User avatar
Flemur
Level 17
Level 17
Posts: 7634
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Laptop lenovo internal mic (/pulseaudio?) issue

Post by Flemur »

Try deleting ~/.pulse*

Another thing to try is removing pulseaudio. Everything will (*should*) still work.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

Oc3lot
Level 3
Level 3
Posts: 138
Joined: Tue Aug 26, 2014 4:28 am

Re: Laptop lenovo internal mic (/pulseaudio?) issue

Post by Oc3lot »

Flemur wrote:Try deleting ~/.pulse*

Another thing to try is removing pulseaudio. Everything will (*should*) still work.
Thanks for the reply.

mmm if everything should still work then why is it installed? :?
I read about someone on ubuntu who uninstalled pulseaudio but the system audio was something like buggy :cry:

UPDATE: ok this is funny. If i run pavumeter --record i can clearly see the signal is ok. The bars move reasonably with is voice. The funny fact is that if i open the audio control
of Linux mint/Ubuntu that bar (in the input tab) is almost flat, i have to speak close to the mic to make the bar move a bit.

EPIC UPDATE: I did it. I found the solution in a 2010 topic in ubuntu forum. Solution
1. install pavucontrol
2. run it and go in the input tab
3. Unlock the sliders for the for the mic and drag the right one to zero (the mic is mono, no stereo). Done!
Remember to use the the pavucontrol to adjust the volume of the mic (only the left slider) since adjusting it from the Linux Mint/Ubuntu audio settings bring back the right slider at the same value of the left one

:D

User avatar
Joleen_
Level 1
Level 1
Posts: 17
Joined: Thu Feb 05, 2015 11:39 am

Re: [Solved] Laptop lenovo internal mic (/pulseaudio?) issue

Post by Joleen_ »

maybe you should check out wyrdoak's suggestion in this thread: http://forums.linuxmint.com/viewtopic.php?f=49&t=74288
that worked for my brand new lenovo laptop. I also did the thing right above, by adding the suggested lines to the alsa.conf file. But I think wyrdoak's suggestion via pavucontrol did the thing.

Hoser Rob
Level 15
Level 15
Posts: 5971
Joined: Sat Dec 15, 2012 8:57 am

Re: Laptop lenovo internal mic (/pulseaudio?) issue

Post by Hoser Rob »

Oc3lot wrote:
Flemur wrote:Try deleting ~/.pulse*

Another thing to try is removing pulseaudio. Everything will (*should*) still work.
Thanks for the reply.

mmm if everything should still work then why is it installed? :? ...
Good question ... in fact purging pulseaudio is one of the most common pieces of bad advice I see on audio problems. Pulseaudio has so many dependencies that this will cause problems later. Here's a blog by a ubuntu dev on the subject:

http://voices.canonical.com/david.henni ... our-audio/

User avatar
Flemur
Level 17
Level 17
Posts: 7634
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: [Solved] Laptop lenovo internal mic (/pulseaudio?) issue

Post by Flemur »

Good question ... in fact purging pulseaudio is one of the most common pieces of bad advice I see on audio problems.
Pulseaudio has so many dependencies that this will cause problems later.


I have yet to see any.

Here's a blog by a ubuntu dev on the subject:

After describing ludicrous ways of temporarily turning pulseaudio off and on - because it causes problems(!) - here's what he said:

Unexpected side effects:

They are so trivial....

The Gnome sound settings, the sound indicator and the volume up/down keys relies on PulseAudio, so they won’t work when PulseAudio is off.

Use a better volume control. There are plenty that work fine without pulseaudio. Bad gnome design: does it also leave the "mute" stuck on until you run pavucontrol?

PulseAudio mixes audio, so that means that only one application at a time can output audio if PulseAudio is disabled (and you aren’t using some other sound server).

That is incorrect.

Several applications have PulseAudio backends. Some of them will need reconfiguration to use ALSA directly, some will just automatically redirect themselves, and some won’t work at all.

"Several applications", huh? So many that he can't list them! I haven't run into any of them despite having a ton of audio software installed.

If needing skype, use "apulse".

Bluetooth audio might not work without PulseAudio.

IOW, bluetooth might work without pulseaudio.
If it works w/o pulse or you don't use bluetooth, no problem.
If you use bluetooth and need pulseaudio, then you should probably put up with the other problems pulseaudio causes, and get around those by turning it off and on all the time because it sucks.

In summary: linux audio is awful. It really is! If it weren't awful, this thread and thousands like it wouldn't exist.

But it's slightly less awful without pulseaudio unless you're forced to use gnome volume control rather than a better volume control, or need to use some badly designed bluetooth software.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
xfrank
Level 5
Level 5
Posts: 608
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: Laptop lenovo internal mic (/pulseaudio?) issue

Post by xfrank »

Oc3lot wrote: 1. install pavucontrol
2. run it and go in the input tab
3. Unlock the sliders for the for the mic and drag the right one to zero (the mic is mono, no stereo). Done!
Remember to use the the pavucontrol to adjust the volume of the mic (only the left slider) since adjusting it from the Linux Mint/Ubuntu audio settings bring back the right slider at the same value of the left one

:D
didn't work for me. I have the same laptop (almost: Lenovo G40-30, is the 14" version) , and the same problem. I opened pavucontrol, dragged the right input sound to 0% (the left is on 100%), but the test call didn't work. :?
Active Distros in my computers: LM19.3 (Mate,Xfce); MXLinux (Xfce); SparkyLinux (Xfce); Manjaro (Xfce)

Oc3lot
Level 3
Level 3
Posts: 138
Joined: Tue Aug 26, 2014 4:28 am

Re: Laptop lenovo internal mic (/pulseaudio?) issue

Post by Oc3lot »

xfrank wrote:
Oc3lot wrote: 1. install pavucontrol
2. run it and go in the input tab
3. Unlock the sliders for the for the mic and drag the right one to zero (the mic is mono, no stereo). Done!
Remember to use the the pavucontrol to adjust the volume of the mic (only the left slider) since adjusting it from the Linux Mint/Ubuntu audio settings bring back the right slider at the same value of the left one

:D
didn't work for me. I have the same laptop (almost: Lenovo G40-30, is the 14" version) , and the same problem. I opened pavucontrol, dragged the right input sound to 0% (the left is on 100%), but the test call didn't work. :?
Does the mic work? Or it works but the volume is just very very low?

User avatar
bbaker6212
Level 5
Level 5
Posts: 522
Joined: Wed Aug 12, 2015 6:35 pm

[SOLVED] Re: Laptop Lenovo G50 internal mic not working with Skype

Post by bbaker6212 »

Thanks for this. #3 fixed it for me. I'm on a Lenovo G50-45 (AMD cpu) with v17.2 Cinnamon 64bit.
Oc3lot wrote:
Flemur wrote:Try deleting ~/.pulse*

EPIC UPDATE: I did it. I found the solution in a 2010 topic in ubuntu forum. Solution
1. install pavucontrol
2. run it and go in the input tab
3. Unlock the sliders for the for the mic and drag the right one to zero (the mic is mono, no stereo). Done!
Remember to use the the pavucontrol to adjust the volume of the mic (only the left slider) since adjusting it from the Linux Mint/Ubuntu audio settings bring back the right slider at the same value of the left one

:D
Linux Mint Mate 19.1 k/4.15, Windows 10, Manjaro 18.03 Xfce k/4.19.24-1 MX-Linux 18.1 Lenovo Ideapad G50-45 8GB
Lenovo Ideapad 330S-15IKB, Core i5-8250U, 8GB RAM, Samsung EVO 850 SATA SSD, 14GB Optane M.2 PCIe NVMe, QCA9377 WiFi

jollyjack
Level 4
Level 4
Posts: 307
Joined: Sat Aug 16, 2014 10:25 am

Re: [Solved] Laptop lenovo internal mic (/pulseaudio?) issue

Post by jollyjack »

If I can join this thread? (I have the same problem with Skype, on a Lenovo laptop.)

I have PAVU installed, I've set Front Right internal microphone to zero, Left to 100%. If I speak, the level indicator below these two sliders reacts to my voice. If I go to Settings->Sound, again the level indicator reacts to my voice.

Yet, when I make test call on Skype, it doesn't seem to pick up anything - dead silence during the playback (or possibly VERY low volume).

Any help will be appreciated.

Thanks

User avatar
bbaker6212
Level 5
Level 5
Posts: 522
Joined: Wed Aug 12, 2015 6:35 pm

Re: [SOLVED] Laptop Lenovo G50 internal mic not working with "inverted channel"

Post by bbaker6212 »

bbaker6212 wrote:
Wed Apr 06, 2016 2:37 pm
Thanks for this. #3 fixed it for me. I'm on a Lenovo G50-45 (AMD cpu) with v17.2 Cinnamon 64bit.
Oc3lot wrote:
Flemur wrote:Try deleting ~/.pulse*

EPIC UPDATE: I did it. I found the solution in a 2010 topic in ubuntu forum. Solution
1. install pavucontrol
2. run it and go in the input tab
3. Unlock the sliders for the for the mic and drag the right one to zero (the mic is mono, no stereo). Done!
Remember to use the the pavucontrol to adjust the volume of the mic (only the left slider) since adjusting it from the Linux Mint/Ubuntu audio settings bring back the right slider at the same value of the left one

:D
Old problem, but thought I'd doc further info and workaround. I'm not even on Mint any more but this problem exists on other distro's... cropped up again I think because of pulseaudio auto-adjusting the microphone channels, and some notebooks having the "inverted microphone" problem (one channel is inverted) so when both are set to equal levels you get no input. This can be worked around by turning one channel all the way down, but apparently PulseAudio now has a default where it's auto-setting the level in both channels. Anyway, my fix was applying this as documented on the Arch wiki: https://wiki.archlinux.org/index.php/Pu ... adjustment
After applying this turning down the volume on one mic channel, now it stays down instead of auto-adjusting up disabling the mic.

In /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf and /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf,

Under [Element Internal Mic Boost] set volume to zero.
Under [Element Int Mic Boost] set volume to zero.
Under [Element Mic Boost] set volume to zero.
Then restart PulseAudio or reboot
Linux Mint Mate 19.1 k/4.15, Windows 10, Manjaro 18.03 Xfce k/4.19.24-1 MX-Linux 18.1 Lenovo Ideapad G50-45 8GB
Lenovo Ideapad 330S-15IKB, Core i5-8250U, 8GB RAM, Samsung EVO 850 SATA SSD, 14GB Optane M.2 PCIe NVMe, QCA9377 WiFi

Post Reply

Return to “Sound, Multimedia, & Codecs”